?
Solved

A transient failure has occurred. exchange 2007 event id 4001

Posted on 2007-11-25
10
Medium Priority
?
24,637 Views
Last Modified: 2009-05-19
hi expert
i installed exchange 2007 to work with existing exchange 2003, the 2007 was installed as a member server same as the 2003 is,no hub transport has been configure on the new exchange , all incoming and outgoing emails are routing thru exchange 2003, the 2007 data store is 80 gig and the 2003 data store is 14 gig
my problem is that every day at the end of business day the store.exe on the 2007 get overloaded, by looking on windows perfomance i can see 5 gig of memory use and this server has only 4 phisical memory, the info store process is working on 5 gig memory use, from that point emails stop flow into the users mailboxes,when i restart the info store everything go back to normal, the phisical memory use ia back to 2 gig for couple of hours and everything is working,the only event i see every time on the application events on the exchnage 2007 is that one

A transient failure has occurred. The problem may resolve itself in a while. The service will retry in 56 seconds. Diagnostic information:

Cannot open mailbox /o=Almar Sales/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=ALMARNYEXCH2/cn=Microsoft System Attendant.
Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Cannot open mailbox /o=Almar Sales/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=ALMARNYEXCH2/cn=Microsoft System Attendant. ---> Microsoft.Mapi.MapiExceptionLogonFailed: MapiExceptionLogonFailed: Unable to open message store. (hr=0x80040111, ec=-2147221231)
Diagnostic context:
    Lid: 18969   EcDoRpcExt2 called [length=252]
    Lid: 27161   EcDoRpcExt2 returned [ec=0x0][length=116][latency=0]
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropLogon [254]
    Lid: 17082   ROP Error: 0x80040111
    Lid: 26937  
    Lid: 21921   StoreEc: 0x80040111
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 26426   ROP: ropLogon [254]
    Lid: 22970  
    Lid: 8620    StoreEc: 0x80040111
    Lid: 10786   dwParam: 0x0        Msg: ALMARNYEXCH2
    Lid: 1750    ---- Remote Context End ----
    Lid: 26849  
    Lid: 21817   ROP Failure: 0x80040111
    Lid: 26297  
    Lid: 16585   StoreEc: 0x80040111
    Lid: 32441  
    Lid: 1706    StoreEc: 0x80040111
    Lid: 24761  
    Lid: 20665   StoreEc: 0x80040111
    Lid: 25785  
    Lid: 29881   StoreEc: 0x80040111
   at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, Int32 ec, DiagnosticContext diagCtx)
   at Microsoft.Mapi.ExRpcConnection.OpenMsgStore(OpenStoreFlag storeFlags, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, MapiStore msgStorePrivate, String& correctServerDn, ClientIdentityInfo clientIdentityAs, String userDnAs, String applicationId, CultureInfo cultureInfo)
   at Microsoft.Mapi.ConnectionCache.OpenMapiStore(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, ClientIdentityInfo clientIdentity, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)
   at Microsoft.Mapi.ConnectionCache.OpenMailbox(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, WindowsIdentity windowsIdentityAs, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
   at Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString)
   at Microsoft.Exchange.Data.Storage.MailboxSession.Initialize(LogonType logonType, ExchangePrincipal owner, ADOrgPerson delegateUser, Object identity, OpenMailboxSessionFlags flags)
   at Microsoft.Exchange.Data.Storage.MailboxSession.CreateMailboxSession(LogonType logonType, ExchangePrincipal owner, ADOrgPerson delegateUser, Object identity, OpenMailboxSessionFlags flags, CultureInfo cultureInfo, String clientInfoString)
   at Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsAdmin(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString)
   at Microsoft.Exchange.Servicelets.SystemAttendantMailbox.Servicelet.Work()

For more information, see Help and Support Center at
our network is mixing with 100MB swiches and 1gig swiches, on the 2007 i have two NIC`s card, the one is connected is a 100MB link
do you guys think im having an hardware overloaded isue? i mean maybe i transered too many mailboxes from the 2003 to the new machine(2007)? or maybe this is a network isue?
thanks
0
Comment
Question by:activenet1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 20347371
Hardware overload? If you are running less than 1500 mailboxes on the server then that is not the problem.

What else is on the machine? This looks like a memory leak, but that is usually caused by a third party tool.

Simon.
0
 

Author Comment

by:activenet1
ID: 20347542
nothing else is running on the machine, only exchange, dual proccessor xeon power edge 2800 4 gig memory.
0
 

Author Comment

by:activenet1
ID: 20350843
simon, can u recomend on any diag tool for exchange? i have tried to use the build in diag tool in exchange 2007 but all seems to be fine
thanks
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 104

Expert Comment

by:Sembee
ID: 20351277
Third parties are still a long way from having anything - most people I think are waiting for SP1 to be released. The only tools really available are those that are built in to Exchange at the moment. Quest may have something, but it will be very expensive if they do.

I don't know what to suggest at this time, it isn't an error I have seen.

Simon.
0
 

Author Comment

by:activenet1
ID: 20351391
Simon,
 I have found 1 event ID in the exchange 2007 event viewer that might give us some information about the problem

The event is created every time before the server stops deliver emails, the event content is long so I just paste u the line I have found that refered to the problem

The event id is 4001 and its header is “A transient failure has occurred. The problem may resolve itself in a while. The service will retry in 56 seconds”

By digging into the event  I have found the following line:

 

“Microsoft.Mapi.MapiExceptionNetworkError: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)

I coudn`t found anything by googling for this line but I did find something in ExchangeExpert website

That error msg can ocurrs from 3 rerson`s,(see link below)wich posted in EE.

 

http://eventid.net/display.asp?eventid=4001&eventno=8880&source=MSExchange%20System%20Attendant%20Mailbox&phase=1

 

please let me know what you think

0
 
LVL 104

Expert Comment

by:Sembee
ID: 20351653
There have been reports on Rollup 5 causing problems.
I have also heard about issues with System Attendant stopping or not starting correctly. However I haven't seen either myself.
Quietly hoping that when Exchange 2007 Sp1 is released (hint - real soon now - I do know, but I am on NDA) that those problems will be cleared up.

There is no harm in re-running the prep again, that is non-destructive and run in production hours. If the server is having problems communicating with a domain controller then you should investigate that further as well, just in case. There should be other symptoms and things logged on that.

Simon.
0
 

Author Comment

by:activenet1
ID: 20351850
Simon, thanks for your help, i think i found the problem
our data store is 80 gig size and the exchange is standart ED, i forgot to add the reg twik to increase the
its wierd because the data store should have been dismounted and i should have seen any logs for that right? well i haven`t seen any error logs but i did see a lot of worning logs regarding to data store size limit.
ill wait till tomorrow morning and update you with the results
thanks
 
0
 
LVL 104

Accepted Solution

by:
Sembee earned 2000 total points
ID: 20352439
Exchange 207 standard doesn't have a hard limit. It has a soft limit of 50gb and should log something in the morning when it checks the size of the store. At that point it would dismount the database.

Simon.
0
 

Author Comment

by:activenet1
ID: 20365452
Simon,
it is so WIERD!! when the store is stops on exchange 2007 the event log that been created is an INFORMATION log and not an ERROR log.
That’s why I didn’t pay so much attention to that’s log, all I saw is the log that refered to " transient failure has occurred" yesterday i added the reg key folowing that article http://technet.microsoft.com/en-us/library/bb232092.aspx---and today the store has been dismounted again, im 99% sure im having size limit isue but i dont know why the reg twik didnt help
0
 

Author Comment

by:activenet1
ID: 20365504
i had an extra space in reg key syntax
im good now
thanks for your help Simon
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
New style of hardware planning for Microsoft Exchange server.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question