Cannot remote desktop after creating a VPN connection

I recently logged in from my home office PC (XP Pro) via Remote Desktop to machine A in domain A.
While on Machine A I created a VPN connection to domain B.  As soon as the VPN connected I lost my remote desktop connection.  I believe the reason why this happened is that the IP address for machine A changed once the VPN was created.  So how do I terminate the VPN connection since I no longer can access machine A.  Is the only solution a reboot of machine A? How can I find out its new IP address?

I am able to create a VPN to domain B from my home PC so is there a way I can terminate the VPN connection from a machine B in domain B? Or at least find out the new IP address for machine A so that I can reconnect via remote desktop?


Who is Participating?
salvagbfConnect With a Mentor Commented:
Your remote desktop connection dropped because when you VPN'ed to the other network, you effectively removed the computer from the network it was a part of when you first connected to it.

Your only way to terminate that computer's VPN connection is to gain physical access to it and terminate it, connect to the new network it's on (via the VPN) and remote desktop into it and kill the VPN connection, or possibly reboot it by connecting to the network it's VPN'ed into and opening a command prompt and running a

shutdown /r /m \\computerName /f

Though you may have to replace \\computerName with the IP it has on that network.

Good luck!

Hi ,
I hope you are using any vpn client software for logging into your domain. In domain part check the proper authentication from that side like the what the ipaddress you are getting from the defined given pool in your vpn server.  Test it from server side and check the log and port access also.It will help you to troubleshoot.

Rob WilliamsCommented:
There is a security feature in the VPN client that blocks local connections, including local Internet access, and therefore your remote desktop connection, to protect the remote network. You can disable this if you wish. To do so on the VPN client/connecting PC (Machine A), go to:
control panel | network connections | right click on the VPN/Virtual adapter and choose properties | Networking | TCP/IP -properties | Advanced | General | un-check  "Use default gateway on remote network"

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.