Solved

Problem transferring files bigger than 4GB with FTP

Posted on 2007-11-26
9
6,680 Views
Last Modified: 2013-12-09
Hi,

I am trying to transfer some files bigger than 4GB from a centos 5 (proftpd) server and when the first 4GB are transferred I am getting an error on my ftp client. I tried it with filezilla 3 and cuteftp pro trial and had no success. The files are tar.gz cpanel backups if that helps.

If there is no solution to my problem is there any tool to split the files on linux and join them on a windows system after download?

Thanks,
John
0
Comment
Question by:infodigger
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 27

Expert Comment

by:Tolomir
ID: 20348946
this might look promissing:

http://www.softpicks.net/blog/11/turboftp-560620-an-alternative-ftp-client.htm

A new version of TurboFTP has been released, a FTP client with broad functionality, by means of which you can easily transfer files via the Internet. The program has a user-friendly and customizable interface. It allows you to transfer files larger than -----> 4 GB   <---- , set the speed limit, set transfer only of those files that have been updated since the last load. In addition, with the help of the program you can compare the contents of local and remote folders, to prioritize data transmission. TurboFTP supports firewalls, including HTTP proxy, SOCKS 4, SOCKS 4a and SOCKS 5, as well as protected connections SSL / TLS, including implicit and explicit SSL.

Tolomir
0
 
LVL 27

Expert Comment

by:Tolomir
ID: 20348953
Here is the download link:

http://www.turboftp.com/download.htm

0
 
LVL 12

Assisted Solution

by:ibu1
ibu1 earned 100 total points
ID: 20349050
Have You tried scp?
scp user@sourcepc:/path/to/file /local/path
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 3

Assisted Solution

by:amirs80
amirs80 earned 100 total points
ID: 20349091
use winscp it is very nice graphical tool. u can use it on microsoft windows system easily to transfer the files
0
 
LVL 3

Expert Comment

by:amirs80
ID: 20349101
winscp is free software to transfer files specially b/w linux and windows
0
 
LVL 12

Expert Comment

by:ibu1
ID: 20349172
The above command is to copy the file through secure shell. It should be enable.If not, do this
/etc/init.d/sshd start
0
 
LVL 27

Expert Comment

by:Tolomir
ID: 20349274
Can I transfer file larger then 4 GB (or 2 GB)?

WinSCP places no limits on size of the file transferred.

However there are restrictions placed by protocols used. SCP protocol does not support files over 4 GB (32-bit boundary), while SFTP and FTP support them.

Please note that size limit may be imposed also by particular server implementations.

http://winscp.net/eng/docs/faq_4gb

---

Tolomir
0
 
LVL 27

Accepted Solution

by:
Tolomir earned 300 total points
ID: 20349285
So this might be the solution:

http://elliottback.com/wp/archives/2007/03/10/combine-split-files-in-windows/

I recently ran into an issue where I had about 7.5 GB of files split into 512M chunks downloaded from linux machine. The files had been generated using the split command:

    split -b 512m files.tgz

This created the following files:

    -rw-rw-rw- 1 user group 536870912 Mar 9 20:44 xaa
    -rw-rw-rw- 1 user group 536870912 Mar 9 20:46 xab
    ...
    -rw-rw-rw- 1 user group 222082405 Mar 9 21:13 xao

I wanted to combine them in windows and looked around for a while until I realized you can use Microsoft's  copy utility in binary mode!

    copy /b xa* files.tgz /b

---

Tolomir
0
 

Author Closing Comment

by:infodigger
ID: 31410937
Thanks,

The ftp clients didn't work so I finally had to split the file to transfer it.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
As a financial services provider, your business is impacted by two of the strictest federal regulations on record: the Sarbanes-Oxley Act and the Gramm-Leach-Bliley Act. Correctly implementing faxing into your organization to provide secure, real-ti…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question