Solved

Hide Min/Max button in Access 2003 forms

Posted on 2007-11-26
3
854 Views
Last Modified: 2013-11-29
I'm working on an Access 2003 database.  In the Form_Load of my forms i have a DoCmd.Maximize command.  I want the forms to maximize and not have any control box or min/max buttons.  The format settings are as follows:
Auto Resize - No
Auto Center - No
Control Box - No
Min Max Buttons - No
Close Button - No

In spite of these settings I still get a Min/Max button in the Access menu bar.  

How can i get rid of this?  There is also a Help field that is superfluous which says 'Type a question for help'.  If I could get rid of this it would be helpful as well.
0
Comment
Question by:irglebleeben
3 Comments
 
LVL 46

Expert Comment

by:tbsgadi
ID: 20349164
Hi irglebleeben,

Maybe there's Code or a Macro that's changing the settings?

Good Luck!

Gary
0
 
LVL 84

Accepted Solution

by:
Scott McDaniel (Microsoft Access MVP - EE MVE ) earned 500 total points
ID: 20349296
Remove the question box like this;

Application.CommandBars.DisableAskAQuestionDropdown = True

This is an app-wide setting (i.e. this will cause the box to not show up in ANY Access app on that machine), so you may need to store that value when opening your app, then reset it when closed.

Not sure about the Min/Max buttons; perhaps these links may help:

http://www.mvps.org/access/api/api0057.htm
http://www.mvps.org/access/api/api0022.htm
0
 
LVL 74

Expert Comment

by:Jeffrey Coachman
ID: 20355444
irglebleeben,

You can try this:

Border Style: Dialog
AutoCenter: Yes
ScrollBars: Nither
RecordSelector: No
And waaaaaaay down at the bottom of the Properties box…
Moveable: No

Now you have to adjust the form *Grid* dimension to just barely fit the screen.
Approximately 10.25in x 5.75in, for a screen resolution of 1024 x 768
(This allows for two toolbars on top)

On the Open and Activate events put:
    Docmd.Restore

What all this will do is *Restore* the form, (meaning not maximized or minimized.)

Since you resized the Form grid, the form will *almost* fit the screen. (Maximize tends to always show the Min/Max buttons)

Since you set Movable to NO, users can’t move the form around.
Hope this helps as well


JeffCoachman
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Regardless of which version on MS Access you are using, one of the harder data-entry forms to create is one where most data from previous entries needs to be appended to new records, especially when there are numerous fields and records involved.  W…
Introduction The Visual Basic for Applications (VBA) language is at the heart of every application that you write. It is your key to taking Access beyond the world of wizards into a world where anything is possible. This article introduces you to…
Familiarize people with the process of retrieving data from SQL Server using an Access pass-thru query. Microsoft Access is a very powerful client/server development tool. One of the ways that you can retrieve data from a SQL Server is by using a pa…
With Microsoft Access, learn how to specify relationships between tables and set various options on the relationship. Add the tables: Create the relationship: Decide if you’re going to set referential integrity: Decide if you want cascade upda…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question