LoadVars Problem - Flash URL Variable not loading & outputting Correctly

I am having some major issues because of one little glitch. I am calling a variable into flash through a FlashVars value in the object of one html file.  I then load it into a Flash file only to reoutput it into another html file via a URL.  However,  in this process the final url variable has an addition to it, an equal sign. I do not know where this is coming from or how to get rid of this.  It is ABSOLUTELY crutial I figure this out as it is holding up some other coding and deadlines. Any help would be greatly appreciated.  I have included my code.
OBJECT TAG and URL Variables in HTML Page One:
 
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="1023" height="455">
              <param name="movie" value="http://www.website.com/shop/main_menu.swf">
              <param name="quality" value="high">
			  <param name="base" value="MY_URL">
			  <param name="wmode" value="trasparent">
			  <param name="salign" value="t">
			  <param name="FlashVars" value="sid=1234567">
              <embed src="http://www.website.com/shop/main_menu.swf" FlashVars="sid=1234567" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="1023" height="455" base="MY_URL"></embed></object>
 
My Flash code: 
on (Release) {
	mySid = new LoadVars();
         mySid.decode(_level0.sid);
	getURL("http://www.website.com/shop/therapiespro.php?category=HHTB&side="+mySid, "_blank");
        _root.blankmc.loadMovie("page=therapies.swf");
}
The OUTPUTTED URL & Variables in HTML Page Two:
http://www.website.com/shop/therapiespro.php?category=HHTB&sid=1234567=
as you can see from the above there is an = sign at the end of the URL. I am not sure where this is coming from but it should not be there. I do not know how to get rid of it. This variable is being called out on other areas of the site and the equal sign is causing some major issues.
I am awarding a lot of points as this is time sensitive. Thanks again!

Open in new window

LVL 1
battlepigeonsAsked:
Who is Participating?
 
CyanBlueConnect With a Mentor Commented:
Try this...



CyanBlue
on (Release) {
       getURL("http://www.website.com/shop/therapiespro.php?category=HHTB&side="+_level0.sid, "_blank");
        _root.blankmc.loadMovie("page=therapies.swf");
}

Open in new window

0
 
Michel PlungjanIT ExpertCommented:
how about

<param name="FlashVars" value="1234567">

.
.
FlashVars="1234567"
Does this link hep?

http://www.flash-creations.com/notes/servercomm_database.php
0
 
Michel PlungjanIT ExpertCommented:
side= or sid= ???
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
battlepigeonsAuthor Commented:
It is "sid" without the e.  I tried CyanBlue's resolution and it worked!  I cannot believe I did not see it.  I guess when you are staring at it for so long sometimes what is right in front of you completely escapes you.  Thank you so much, especially for your quick response.  It is very much appreciated.
0
 
CyanBlueCommented:
Glad to be of your service...  :)

CyanBlue
0
 
battlepigeonsAuthor Commented:
Thank you again. It was a quick response.  The resolution made sense and it worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.