• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 918
  • Last Modified:

Multiple screen redraws in MS PowerPoint and SmartDraw 2008

Hi, mighty all

I am experiencing a problem with MS PowerPoint 2003 and SmartDraw 2008.
When I create a picture where there are overlapping boxes filled with transparent or semi-transparent fill, the screen seems somehow to jump into redrawing frenzy - on a minor change it gets redrawn multiple times, while application gets stuck with roughly 90% of CPU time taken.

I suspect it is somehow connected to some system library (possibly from .NET) that is responsible for that semi-transparency, but due to my lack of knowledge, cannot present any proof.

I googled it, but found only some referrals to VB programming. I guess there is something wrong with the way the window repaint is being done - instead doing the repaint in some hidden window (some buffer?) it does it all right in my application window.

It is really irritating. Depending upon the number of overlapping objects there might be up to 30 window redraws on a simple scrollbar move or mouse click. Several times I noticed Visio 2007 doing that as well, but I use it very seldomly.

I use IBM Thinkpad T43p with WinXP SP2, 2 GB RAM, ATI Mobility Radeon X300, the drivers were always been updated through IBM.
Other software - MS Office 2003 SP3, MS Visio 2007.

Interesting enough, the problem manifests itself if I copy-paste pictures from PowerPoint, SmartDraw or Vision as metafiles into MS Word. I see the page with such picture redrawing itself for 20-30 seconds (many times over).

I would be very grateful to anyone helping me - this thing is really driving me insane...
0
ksmirnov
Asked:
ksmirnov
3 Solutions
 
GlennaShawCommented:
Try turning back your Graphics Hardware Acceleration:
http://pptfaq.com/FAQ00129.htm

0
 
tajsimmonsCommented:
ksmirnov,

Even though you state that the drivers are being updated.
>ATI Mobility Radeon X300, the drivers were always been updated through IBM.

I'd manually update the driver by visiting the ATI website, selecting your operating system, and download the latest driver.

Cheers
TAJ Simmons
0
 
FrankWaltersCommented:
Hi Ksmirnov,

Of course, as indicated above, you should always try to keep your drivers current.  However, to solve this problem, you may also try turning off Write Combining.

You can right click on your desktop, choose properties, settings tab, advanced button and then toggle the 'Enable write combining' option.  Be sure to reboot afterwards, even if it doesn't ask you, before checking to see if this was successful.


cheers,

-fw
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now