[Ticket: 45523] CRM Outbound Email Delivery Issues

When using the Outlook client of Dynamics CRM, all activities are being processed normally.  However, when the web client is used, outbound emails with attachments are either having a delay of several days or not being delivered at all.  When the same email is sent through the Outlook client, the email is delivered within minutes.  The attachments are not above the size limit nor are they blocked in the list of blocked attachments.  All emails without attachments are being processed properly.  Also, the following event is logged each time: (email address is present in the event, but removed for this post)
Event Type:      Warning
Event Source:      MSCRMExRouterService
Event Category:      None
Event ID:      0
Date:            11/25/2007
Time:            1:12:00 PM
User:            N/A
Computer:      TFH01S1
Message: [Subject:'RE: Official Site id 21239' From:'' To:'"email address" <email address>' CC:''] in mailbox: [CRMServerUrl:'http://TFH01S1:5555/' EmailServer:'TFH01S1' EmailAccount:'CRMMail' ForceReDelivery:'False'] has no single attachment.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Who is Participating?
preitmeyerConnect With a Mentor Commented:
Okay, here is what you have to do:
1. Add the user CRMMAIL to both PrivUser groups (did you install CRM twice? as there should only be one group)
2. Add CRMMAIL to the following group: Domain Admins (yes, its a security issue, but it needs to be done)
3. Remove expiration on the CRMMAIL account
4. Set the CRMMAIL account to be the "run as user" for the Microsoft CRM Exchange Router Service
5. Restart the Microsoft CRM Exchange Router Service
6. Try it all again, you will see some "errors" in the event log for the Exchange Email Router, and we can fix those later with a registry fix.

Let me know how it goes.
ITD Tech,
It seems as though you have incorrectly set-up your CRM server. The issue you are referring to relates to having a single Exchange mailbox associated as both the CRM router email user (crmmail) and a support queue (usually support@whatever.com). Remove the queue you created via the rule deployment wizard and check to make sure the crmmail user is NOT disabled in active directory. Let me know if that fixes it.
Also, Im assuming you're running this on SBS 2003? Let me know
ITD_TechnicianAuthor Commented:
There was a a support queue that was deployed in the rule deployment wizard that I've removed.  I'll monitor for a day or to make sure that it is working correctly now.  And yes, running on SBS 2003.
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Ok, as far as CRM is concerned, the CRMMAIL account can not be used for anything else (ie: queues) aside from routing mail to and from users mailboxes.
ITD_TechnicianAuthor Commented:
Ok, all rules were removed from the Rule deployment wizard, as just removing the support queue did not resolve the issue, and still I receive the error from the original post.  What else could be causing this issue?  If you need any other configuration details as well to figure it out, please let me know.
Sorry about the delay getting back to you.
Can you send me the list of members in the Active Directory Group: "Priv User" ?
Also, send me the configuration of the CRMMAIL user, its group memberships, and its account status (active / deactivated).
ITD_TechnicianAuthor Commented:
No group simply called "PrivUser". There are two groups with codes following them, both with the CRM server as a member (this server is also the SMTP server).

CRMMail: Username: CRMMail; no profile. Password has expiry. Account is active. No forward address or send on behalf. Address is CRMMail@domain. Member of Domain Users. Mailbox rights: Domain admins have full control, Self has Read and Full mailbox access, and everyone has read.
ITD_TechnicianAuthor Commented:
Hi Paul,

I followed  your suggestions, and the service started successfully.  However, the following error was registered:

Event Type: Warning
Event Source: Userenv
Event Category: None
Event ID: 1509
Date: 12/3/2007
Time: 1:27:24 PM
User: TFH\CRMMail
Computer: TFH01S1
Windows cannot copy file C:\Documents and Settings\Default User\Application Data\Microsoft\CLR Security Config\v1.1.4322\security.config.cch.592.161140 to location C:\Documents and Settings\CRMMail\Application Data\Microsoft\CLR Security Config\v1.1.4322\security.config.cch.592.161140. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.

DETAIL - Access is denied.


I will be monitoring to see whether the errors about "has no single attachment" persist.  Given the fact that the service started successfully, will the above error cause any issues?
It looks like that error was caused due to a roaming profile option, but no it shouldn't cause any issues.
If you see a bunch of errors on the CRM Exchange Router Service with an event id of 0, perform the following:

That's it man, good luck
Oh, and in reference to above, I mean this part of it:

If there are warning messages in the application event log after you follow these steps, you can change the logging level of the MSCRMExRouterService to suppress the warning messages. To do this, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
1.      On the Exchange server where the Microsoft CRM-Exchange E-Mail Router Service is installed, click Start, click Run, type regedit, and then click OK.
2.      In Registry Editor, click the following subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSCRMExRouterService
3.      Change the value of LogLevel from 1 to 2.
4.      Restart the Microsoft CRM-Exchange E-Mail Router Service:
a.       Click Start, point to Programs, point to Administrative Tools, and then click Services.
b.       Right-click Microsoft CRM-Exchange E-Mail Router Service, and then click Restart.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.