Update 10.4.11 ate my keychain

Hello - I have recently updated my iMac to to 10.4.11, with problematic results. Basically, I am no longer able to make any SSL/HTTPS connections to/from the web. Safari will not connect to Hotmail or GMail, and Apple Mail will not connect to our e-mail server, which also uses SSL. Mozilla Firefox is unaffected.

I have tried deleted the affected items in my key-chain, then rebooting. No change. I reset my key-chain anew, with no change. I do not want to reinstall Mac OS X, is there anything I can do? Do besides not update Mac OS X again???

Thanks
LVL 27
Jason WatkinsIT Project LeaderAsked:
Who is Participating?
 
Jason WatkinsConnect With a Mentor IT Project LeaderAuthor Commented:
Ok,

Here is what I did:

Performed a disk repair, and installed the 10.4.11 combo update, no change.
I then went into the keychain.app and ran the 'repair' option.
The repair failed, and threw an error indicating that /System/Library/Keychains/X509Anchor was corrupt.
The options were to copy it from another Mac or reinstall. The copy worked!

Thanks
0
 
heteronymousCommented:
Probably not.

Restore your keychain from a known-good backup since it's not clear what you deleted and you may have made matters worse.

Then, download the *COMBO* updater from Apple, namely the 10.4.11 combo update for your platform (PPC or Intel).

Launch DiskUtility & repair permissions for your boot drive.
Install the Combo updater.


0
 
Jason WatkinsIT Project LeaderAuthor Commented:
Hi,

There is no 'known-good' backup.  The user only backs his data, and not the OS itself.  The 10.4.11 update has already been installed, could I install over it?

Is there a way to disable keychain all together?

Thanks

/F
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
heteronymousCommented:
Well, you can ignore the keychain by and large - just never use it, never have it save any passwords.

There is an option within the Keychain Utility (aka "Keychain Access") to reset the keychain.
This will cause *ALL* saved passwords to be lost: most critically email account passwords, but also website username & passwords, etc.
0
 
Jason WatkinsIT Project LeaderAuthor Commented:
I did reset the keychain with no change in performance, no SSL/HTTPS connections possible.
0
 
heteronymousCommented:
Right but have you done what I first posted ?
Downloaded and installed the /Combo/ 10.4.11 updater ?

0
 
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.