?
Solved

Help configuring old Cisco 837 ISDN Router

Posted on 2007-11-26
7
Medium Priority
?
514 Views
Last Modified: 2008-02-01
Hi All,

Bit of a nightmare here, One of our sites' ADSL has gone down, and I've been tasked with getting their ISDN fax line working as a data connection too. We have an 837 at the customer's site, and one of them at our end with an ISDN-2 at each side, I have a config of their site's 837 router, but need some help as to what to program the router at our end with, in order to get it working.

Remote 837

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service  password-encryption
service udp-small-servers
service tcp=small-servers
!
hostname REMOTEROUTER
!
enable last-resort PASSWORD
enable password PASSWORD
!
username BTMDIP password 0 PASSWORD
username action014 password 0 PASSWORD
!
dial-peer voice 1 pots
 no call-waiting
 ring 0
 port 1
 destination-pattern REMOTE_PHONE_NO
!
pots country GB
pots ringing-freq 25Hz
ip subnet-zero
no ip source-route
ip dhcp excluded-address 172.16.150.1 172.16.150.16
!
ip dhcp pool REMOTESITE
     network 172.16.150.0 255.255.255.0
     default-router 172.16.150,.1
     dns-server 192.168.10.13
     lease 2
!
no ip domain-lookup
isdn switch-type basic-net3
isdn tei-negotiation first-call
!
!
interface Loopback0
 no ip address
 no ip directed-broadcast
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer enable-timeout 1
 dialer map ip 192.16.10.100 broadcast HEAD_OFFICE_PHONE_NUMBER
 dialer-group 1
 isdn switch-type basic-net3
 isdn incoming-voice modem
 no fair-queue
 ppp authentication chap callin
 ppp multilinl
 hold-queue 75 in
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.100
no fair-queue
ppp authentication chap callin
ppp multilink
hold-queue 75 in
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.100
ip route 192.168.10.100 255.255.255.255  BRI0
!
dialer-list 1 protocol ip list 103
!
line con 0
 password PASSWORD
 login
 transport input none
 stopbits 1
line vty 0 4
 password PASSWORD
 login
!
end

What do I need to do with the router it connects to at Head Office?

Many Thanks
Andy
0
Comment
Question by:A4eIT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 11

Assisted Solution

by:tvman_od
tvman_od earned 999 total points
ID: 20355755
Before we go anywhere, could you tell us if data services enabled by telco for this ISDN lines? If so, what kind of signaling will CO (telco) switch will work with.

Here is a pretty nice guide how to configure remote access ntworking using BRI dialers

http://www3.shastacollege.edu/cna/students/Ann/extralabs/configuringbri.pdf
0
 

Author Comment

by:A4eIT
ID: 20356569
They were originally used for data before ISDN so yes I assume so, as this has been done in the past in the event of ADSL failure.

Regarding the signalling, I have no idea am afraid :-(
0
 
LVL 11

Accepted Solution

by:
tvman_od earned 999 total points
ID: 20361665
BTW, I'm wandering where do you connect the BRI port of Cisco? What kind of adaptors for your FAX do you have?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 7

Assisted Solution

by:naughton
naughton earned 501 total points
ID: 20362206
i'd confirm with the telco that the ISDN service is set to Point-to-multipoint  VS  Point-to-Point.



0
 

Author Comment

by:A4eIT
ID: 20365146
Thanks for all your help, we have managed to onfigure the router, assigning points for your efforts!
0
 
LVL 11

Expert Comment

by:tvman_od
ID: 20365261
Would be nice to know what was it, just for the knowledge base.
0
 

Author Comment

by:A4eIT
ID: 20365330
Sure, no probs, see below!


!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname tiverton
!
enable last-resort password
enable password xxxxxx
!
username xxxxxxx password 0 xxxxxxxxx
username tiverton password 0 cisco
username bessemer password 0 cisco
!
!
!
dial-peer voice 1 pots
 no forward-to-unused-port
 no call-waiting
 ring 0
 port 1
 destination-pattern xxxxxxxxxxxxx
!
pots country GB
pots ringing-freq 25Hz
!
ip subnet-zero
no ip source-route
ip dhcp excluded-address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
!
ip dhcp pool Remote
   import all
   network xxx.xxx.xxx.xxx 255.255.255.0
   default-router xxx.xxx.xxx.xxx
   dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
   lease 2
!
no ip domain-lookup
isdn switch-type basic-net3
isdn tei-negotiation first-call
!
!
!
interface Loopback0
 no ip address
!
interface Ethernet0
 description Connection to the TIVERTON ethernet segment
 ip address xxx.xxx.xxx.xxx 255.255.255.0
!
interface BRI0
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer enable-timeout 1
 dialer map ip xxx.xxx.xxx.xxx broadcast xxxxxxxxxxxx
 dialer-group 1
 isdn switch-type basic-net3
 isdn incoming-voice modem
 no fair-queue
 ppp authentication chap callin
 ppp multilink

no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
ip route xxx.xxx.xxx.xxx 255.255.255.255 BRI0
!
dialer-list 1 protocol ip list 103
!
line con 0
 password cisco
 login
 transport input none
 stopbits 1
line vty 0 4
 password cisco
 login
!
no rcapi server
!
!
end
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question