Solved

exchange message limits and attachment limits

Posted on 2007-11-26
34
785 Views
Last Modified: 2011-04-14
I am running exchange 2007. I have edited the send and receive connectors to allow 30 MB max message size. I have checked the global settings using get-transportconfig and it shows max send/receive as unlimited. However, we still have issues sending and receiving email with attachments over 10MB. Where do I adjust this setting? thanks
0
Comment
Question by:CCLCLS
  • 19
  • 14
34 Comments
 
LVL 6

Expert Comment

by:-DJL-
Comment Utility
http://technet.microsoft.com/en-us/library/bb124345.aspx

Are you actually getting an auto reply telling you the attachment is over 10MB?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
Sounds like you hit them all but the user setting but by default its unlimited

get-recieveconnector | fl name,maxmessagesize
get-sendconnector | fl name,maxmessagesize

are you trying to send from OWA or full client?
0
 

Author Comment

by:CCLCLS
Comment Utility
ya, i looked there too, it was unlimited,.

i getthe message right away, as soon as i try to attach something over 10MB.

i was reading about editing the smtp connector using adsiedit

"DelivContLength" and "SubmissionContLength" Under ....Services/Microsoft/Exchange/Organization/Message Delivery in your Configuration Naming context in AD.  This is not visible anywhere in E2k7, but is being used - The default is 10mb- You can change it in ADSIEdit.

can I download adsiedit from somewhere? I don't have support tools or access to CD. Does this sound like it could be the problem?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
Question: Can users send anything over 10mb? internal or external?

You should not have to modify that via Adsi, I have been working with 07 since Beta1 and setting it on the connectors and global is all that is typically needed.

Have you tried to restart your transport services since you have made the change?
0
 

Author Comment

by:CCLCLS
Comment Utility
restarted server
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
Not that I dont trust everything can you put the output of the following

get-transportconfig | fl
Get-Recieveconnector | fl maxmessagesize,name
get-sendconnector | fl name,maxmessagesize

get-mailbox anyuser | fl maxsendsize
0
 

Author Comment

by:CCLCLS
Comment Utility

get-transportconfig | fl
ClearCategories                : True
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : unlimited
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : unlimited
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
Xexch50Enabled                 : True


Get-Recieveconnector | fl maxmessagesize,name
MaxMessageSize : 30MB

MaxMessageSize : 30MB




get-sendconnector | fl name,maxmessagesize
MaxMessageSize : 30MB

MaxMessageSize : 30MB



get-mailbox anyuser | fl maxsendsize
MaxSendSize : unlimited







0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
Ok, everything is correct as I thought, next question are you running AV like forfront which can set message size limits?

You are submitting this via OL correct for OWA you have edit a config file?
0
 

Author Comment

by:CCLCLS
Comment Utility
i am running trend micro client server security for SMB, I searached the console and didn't see anything pertaining to email scanning or limits. We are trying to use outlook not owa, is tht what you are asking?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
yes, just wanted to validate the sending method since editing them are done different....... you have a copy of the ndr?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
user cannot send internal to each other with large files?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
0
 

Author Comment

by:CCLCLS
Comment Utility
there is no NDR. As soon as we browse to the attachment within outllok and try to attach it, we get an error saying the attachment exceeds the limit (or something like that) and won't allow it to be attached. Can't even attach it let alone send it.
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
do you have any transport rules?
0
 

Author Comment

by:CCLCLS
Comment Utility
no, i didn't create any, unless there are some by default
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
let me look into the OL attachment....... sounds like more of an OL thing.... do you have any GPO's restricting OL settings.. normaly when you set message size limits it will allow the user to submit the message and bounce it with an ndr but you are getting stopped on the OL adding the attachment.
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:CCLCLS
Comment Utility
no, no group policy stuff set for outlook. Also, they were able to do this fine until we switched over to exchange 2007. Yes, that is what is happening, no NDR, just an error right from Outlook.
0
 

Author Comment

by:CCLCLS
Comment Utility
how do i check the current attachmentsize limit settings?
0
 

Author Comment

by:CCLCLS
Comment Utility
How do i change these in exchange 2007?

Global limits
Source  Property  Default value  
Active Directory
 delivContLength in Active Directory

Incoming message size in Exchange System Manager Global Settings in Exchange 2003

 10240 KB (10 MB)
 
Active Directory
 submissionContLength in Active Directory

Outgoing message size in Exchange System Manager Global Settings in Exchange 2003

 10240 KB (10 MB)
 
0
 

Author Comment

by:CCLCLS
Comment Utility
What about this?
Start adsiedit and locate
Configuration => Configuration => Services => Microsoft Exchange => First
Organisation => Global Settings => Message Delivery


Right click the Message Delivery container, and choose Properties. In the
Attribute list, locate DelivContLength and SubmissionContLength. I suspect
both values are set to something like 10240. If the values are present and
set, I want you to double click both attributes, and then click the Clear
button followed by the OK button. At this point the value should be <Not
set>.

Where can i download adsiedit for 2003 server?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
You can check this however from what I read those just = maxsend and maxrecievesize

adsiedit is on the Windows CD under support tools
0
 
LVL 22

Accepted Solution

by:
ATIG earned 125 total points
Comment Utility
I checked my org and its set to "not set" I would be curious if you have somthing there?
0
 

Author Comment

by:CCLCLS
Comment Utility
i will try this tonight, i don't have access to the CD right now, was hoping i could download it somewhere but i haven't been able to find it anywhere.
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
0
 

Author Comment

by:CCLCLS
Comment Utility
thank you, i ran adsiedit and found those atrtributes, they were both set to 10MB (10240). Now i need to restart the exchange services. Is there one exchange service i can restart that will then restart the rest as well? What's the best way to restart the services?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
interesting..... guess I will learn about somthing new today :) ..... I wonder what was done in the past to set those? Our system has gone from 2000--> 2003--> 2007 --> 2007 sp1 and it was not set :P
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
http://www.simonsen.bz/blog/Lists/Posts/Post.aspx?ID=26 --- going to talk to MS about why the global settings stayed from 03 even though 07 is unlimited.....

Do you still have 2003 around?
0
 

Author Comment

by:CCLCLS
Comment Utility
i uninstalled exchange 2003 from the old server after moving the mailboxes, etc, but the old server is still running AD and 2000 server.
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
It would appear that you have set global limit in Ex 2003 and that in coexsistence the 2003 value wins, after removing 2003 that value remain in AD and the unlimited setting on 2007 is overriden by this....

I would assuming that if you would have run set-transportconfig -maxmesagesize unlimited or 30MB it would have modified that value in AD.

I do not like the fact that the commandlet does not show that info from AD and I am pining the Exchang guys at MS about this..... I am sure this will stay that way but  I want to make sure there is a KB or blog at least talking about this setting from MS.

Thanks for letting me learn somthing new today :)

Is your problem resolved?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
Ok, exchange 2007 Sp1 has added a warning when there is a mismatch in these settings that will be helpful down the road.
0
 

Author Comment

by:CCLCLS
Comment Utility
i hope this resolved it, I can't restart the services though until this evening. assume it is resolved unless i post here again. thanks for your help.

something weird: they had no problems sending large attachmetns in the exchange 2003 environment, it only started since i moved over to 2007, so why would the setting come from 2003?
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
That is a good question.... I never saw you config before the 07 deployment.... by deafult the global settings on 2007 is unlimited.
0
 
LVL 22

Expert Comment

by:ATIG
Comment Utility
Ok, here is the answer-- apparenly when you have 2003 set to unlimited and introduce 2007 those attributes get set......

http://technet.microsoft.com/en-us/library/bb310771.aspx
An Exchange 2007 environment that has been upgraded from Exchange 2003   If any of the global message size limits were set to the value No limit when the Exchange 2003 organization was upgraded to Exchange 2007, Exchange 2007 setup will change the value of those global message size limits to the following values:
o      Outgoing message size   10240 KB
o      Incoming Message Size   10240 KB
o      Maximum number of recipients   5000
If any of the global message size limits were set to a specific value when the Exchange 2003 organization was upgraded to Exchange 2007, Exchange 2007 setup won't change the value of those specific global message size limits.
•      A pure Exchange 2007 environment that wasn't upgraded from Exchange 2003    Exchange 2007 setup sets the global message size limits to the following values:
o      Outgoing message size   10240 KB
o      Incoming Message Size   10240 KB
o      Maximum number of recipients   5000
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now