• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 11776
  • Last Modified:

Print Spooler causing super slow Office Word/Excel opening?

Hello,

We have a very wierd issue going on with a previously fine working WIndows XP Pro SP2 machine. This system is having a particular problem in which Microsoft Office Word/Excel files are opening very slowly when either opened as an attachment or directly off the desktop or folder. THis problem started occuring just about a week ago and we do not know what has caused this. Since a system restore did not fix the issue, it is not software related. Here is the long list of things I tried to fix this:

Changed network cards (from Intel to 3COM), upgraded to Office 2003 SP3, System Restored to 3 weeks earlier, reinstalled both network printers with latest HP drivers, tried the normal.dot fix for slow Word opening, tried to split the network connection from wall jack into a switch and connected desktop directly to switch, turned off macro security in Word/Excel, Turned off AV scanning in real time, Updated all of Windows and Office (both XP and 2003 versions tried).

What I found which has pretty much allowed me to square this issue down is by using FileMOn from Microsoft. THis program allowed me to check what queries each program was making during its operation. So I recorded with FileMOn what WinWord and Excel were calling during their execution and found that SPOOLSV.exe was what each was trying to call about 5 times in a row before opening.

This as we know is the print spooler service. SO I went ahead and turned this service off and tried to launch documents from the desktop and outlook and it worked JUST FINE! Turning print spooler back on brings back the issue.

Does anyone know what could be causing this? We had an IBM laptop with a very similar issue (T60) back in May do this in the same office but we ended up working through IBM to get an entirely different model sent and the problem went away. This time we cant just recommend a replacement as the machine has been working fine for years and truly works great besides this print spooling issue.

THe printers we have on the network, if you are wondering, are:

HP LASERJET 4200N (using internal JetDirect)
HP LASERJET COLOR 4650 (using internal JetDirect)
HP Laserjet ??? (1990's model, very large, using external JetDirect Print Server via Parallel)

Let me know of any possible fixes you may have.

NOTE: We have already decided to try placing shortcuts on the shortcut for starting and stopping the print spooler when needed.
0
FASTECHS
Asked:
FASTECHS
5 Solutions
 
debuggerauCommented:
Hi FASTECHS,

Are the machines using a server as a print spooler or are all the individual machines talking to the HP jetdirect directly. Look at the port information in the printer and see if its a server share or an IP address straight into the JetDirect. If its a server, then look into disk space on the server, defragmentation and CPU availability.

Regards
Greg
0
 
moorhouselondonCommented:
Not a solution, but let's cross reference this with this one:-

http://www.experts-exchange.com/Microsoft/Applications/Q_23465397.html
0
 
FASTECHSAuthor Commented:
No, the print spooler is being used locally and no server as an intermediator.

Any other ideas?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
PJNHEN2Commented:
What make of print servers are you using , we have just swapped all our desktop (local) printers and replaced them with ones running on HP print servers & we have just developed this problem.
0
 
BitBurnerCommented:
Try deleting everthing in C:\Windows\Prefetch folder
0
 
mathiesen-dataCommented:
Go to the Control Panel, Folder Options, File Types.  Highlight XLS
extension and then click Advanced.  Click Open from the list, and then click
Edit.  Add "%1"  (quotes are needed) to the end of the Application used
string (which will be /e for the Excel XLS extension.)  Also uncheck the DDE
box.  This strategy resolved my problems for Excel and for Word.
0
 
mathiesen-dataCommented:
What solved it?
0
 
q2dm1Commented:
Go to Control Panel > Folder Options > File Types
Find and select Word Documents (DOC)
Click the Advanced button
Select Open in the Actions section
Click the Edit button
Uncheck "Use DDE"
Put your cursor on the "Application used to perform action:" box

Arrow all the way to the right and put in "%1" (include the quote marks)
If there is a /dde remove it
Click OK, then OK, then OK
Try to open another document
If that works, then you may want to repeat the steps for other Office document types (xls, ppt, docm
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now