?
Solved

MS, Windows, W2000, Laptop network troubles.

Posted on 2007-11-27
9
Medium Priority
?
237 Views
Last Modified: 2013-12-23
OK...

This has finally got me P'd off enough, to ask a question...   If I've posted this in the wrong part of EE, let me know, and I'll put links to it in any other section peeps' recommend.

Windows 2000, SP4 etc, on a Tosh Sat' Pro 4600 laptop.

Basically, it's got a problem recognising the internal NIC (Intel Pro 100/VE family)

When it can be persuaded to work, it works flawlessly with no problems whatsoever for days at a time.  But, if the PC is restarted, booted or whatever, then Windows if it sees the NIC at all, identifies it as "New Hardware" and all that hassle.   If it can reload the drivers, it will create a network connection as "Local Area Connection #3" for example, using "Ethernet Adapter #6" or some such odd combination, more often than not, the first figure will not change, but the adapter number will, but not in the properties of the logical network connection, and it won't let me just select the "new" one from a list.

Most of the time, it will not load any drivers.  Even the Intel Promon.exe utility says that no adapter drivers were found.

Now, I have tried all that I know, uninstalling the drivers, hardware, cleaning the registry, etc etc.   After a "Big" cleanout, it will install and work OK first time (but with odd numbering) but if then rebooted, it all goes badly wrong again.

I've even left it running Memtest86(v3.3) for days at a time, just in case there is a RAM fault.  None found to date.

Windows will work just fine without any network, just that I wish to use it on my LAN, not only to get to other resources, but so I can get to it remotely with VNC etc, for the purpose of remote control of some of my ham shack.  (Geek alert!)

I've even tried using another plug in (PCMCIA) network adapter I have, with W2k drivers, and it fouls up with that too, after it has got it working, it will not recognise it correctly for later sessions, resulting in the same overall mess...

Before I flatten the whole thing, and re-install windows from scratch, is there anything I can do to force Windows to only load one set of drivers, and the same set each time, regardless of how and why it identifies the hardware as "New" each time.

So....   Is this a windows problem, or something in the hardware? (the machines internal clock battery is not good)   Despite the fact that it also messes up with another known good adapter.

I've "recovered" the Windows product key, and have a Win2k setup CD, but what chance that it will accept the recovered key as valid?  The CD I have is for w2kPro, I have to admit I can't remember if this laptop is that version, or just Win2k.   Guess this could be a problem, from reading other posts.
0
Comment
Question by:g8kbv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 6

Expert Comment

by:ashutosh_kumar
ID: 20358877
you wrote
"the machines internal clock battery is not good" - Fix this...fix the whole issue...

as there is no reason for windows to mark it as new hardware every time it boots....
0
 
LVL 3

Author Comment

by:g8kbv
ID: 20359154
Hi...

Thanks for responding.

When I say it's not good, it's not dead either.  It'l happily keep the cmos going for a day or three, so a reboot is not a problem for it, even over night with no power it will keep the machine config, date and time etc.   That only needs resetting after say nearly a week on the shelf.

Even doing a windows restart, ie not killing the power to the machine, it still looses the NIC, or it's drivers.  Not only any for the internal NIC, but also those used for any plug in NIC too.

That's why I suspect windows got messed up somewhere, just I don't know where.

Cheers.

Dave.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20360615
The COA you have for Windows should work if you have the same TYPE of install disc. Retial Keys work on Retail discs, OEM keys to OEM Discs, VLK etcc.... You get the idea....
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 3

Author Comment

by:g8kbv
ID: 20364024
johnb6767.

Thanks, and yes I was aware of that from reading other threads about it.

I'd still like to find out what the problem is with the existing setup before "giving up" on it and reloading the OS.   After all, that is not a trivial task these days, what with service packs (that I have on CD) and all the updates etc.

Cheers anyway.

Dave
0
 
LVL 3

Author Comment

by:g8kbv
ID: 20483618
Hi again.

Well, some time has passed, as in all things.

Seems I have two different types of licence for WIndows2000 Pro', so "repairing" the buggy laptop with the other W2k CD is not an option, sadly, and for whatever reason, the CD spit's feathers if I try and boot it in the laptop.

However, after some more fiddling, I found that if I create a new user (with full admin rights etc) then login as that new user, and remove all traces of the original user (including all their temporary folders etc) and reboot, it finds the NIC, and loads the correct drivers just fine.   After that, it all goes funny again on subsiquent reboots.

If I "Suspend" the laptop, 99% of the time it will come back up with the NIC running and usable.  However, if I "Hibernate" the machine, most of the time (not always) it will "loose" the NIC or its drivers again.

As this is sounding more and more like a registry confusion problem, anyone know what/where to zap to get it to do the right thing each time?

At the moment I'm just leaving the thing powered up 24/7 with an app that periodicaly looks for something on the web downloads and graphs it (geomagnetic data) so far it seems perfictly reliable like this.  However it would be nice to know how to get it to load the correct NIC drivers, even by force feeding them to it if at all posible, so when I need to reboot it, I don't need to spend the next hour faffing with the thing.

Cheers.

Dave.
0
 
LVL 3

Accepted Solution

by:
g8kbv earned 0 total points
ID: 20559996
Well...

Happy New Year to all...

However, no other response to my question, so I intend to close it.

I did find some minor help elsewhere, I forget the URL, while trying to sort out a case of missing CD/DVD drives and "Error 31" issues on another W2k machine..   This is the text I found...   I took a flyer and tried it on the Tosh with the "variable" NIC allocation, so far, it seems to be behaving itself after removing dozens of "unused" drivers (including several incarnations of the NIC) that were still known about by the OS.

Begin:
Re: Error 31

As far as fixing 2000 - removing the offending hardware from Device Manage and reloading new drivers is a good start. You may want to use the Device Manager you get from a command line which allows you to see all not-present 'hidden' devices. Here are the commands to enter from the command line:
c:\> set devmgr_show_nonpresent_devices=1
c:\> start devmgmt.msc

when Device Manager opens, do a View/Show Hidden Devices. You will see listed all devices ever installed and not 'formally' removed - the nonpresent ones are greyed-out - and you can remove any device. You won't see the 'hidden' devices form the standard Windows Device Manager and I've had several instances where the hidden devices 'confuse' the OS.

End:

Cheers All.

Dave.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 20562713
nun by me...
0
 
LVL 1

Expert Comment

by:modus_operandi
ID: 20588042
Closed, 500 points refunded.
modus_operandi
EE Moderator
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am not new to IT, I have been working in the field since 1985.  But recently I came up against something that stumped even me (it doesn't happen as often as I would like).  I was running a screencasting session from the laptop to my TV via ChromeC…
Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question