Solved

New DHCP server wont activate

Posted on 2007-11-27
11
749 Views
Last Modified: 2012-08-13
I'm attempting to replace an existing DHCP server.  I authorized the new server, set up the scope and activated it.  However, the server never did authorize.  Now the option to unauthorize or authorize is no longer available.  What did I do incorrectly?

Thanks,

J.R.
0
Comment
Question by:jrsitman
  • 6
  • 4
11 Comments
 
LVL 2

Expert Comment

by:AndyJG247
ID: 20358466
Is the service running?  Try re-starting it.
Has the other DHCP server been stopped and are you sure there aren't any other DHCP servers around (favourite for for me was people using a router to increase the lan ports).
Have you got any messages in the event log as well?
0
 

Author Comment

by:jrsitman
ID: 20358518
Service is running.  and I've re-booted the server.  I originally unauthorized the existing server, but when the new server would authorize I had to re-authorize the original server.
No messages in the log
0
 
LVL 2

Expert Comment

by:orphanc
ID: 20358708
You have to be a member of the Enterprise Admins group to authorize DHCP- either by logging on with an account that has Ent.  Admins rights, or by using the  'run as' command , then right clicking the DHCP server icon and selecting authorize. Do you have this access? Is this what you did?

If yes, did you then create the scope and activate it? If yes, did this work fine? Also, is the previous DHCP still up and runnig? have you used a different scope? Have you received any errors? As above is the service running and do you have any errors in evnt vwr?
0
 

Author Comment

by:jrsitman
ID: 20358806
I'm logged in as Administrator.  Yes the scope activated.  Yes the previous DHCP is active but was unauthorized when I tried to set up the new server.  No I didn't use a different scope than the current one on the existing server.  No errors in the log and yes the service is running.
0
 
LVL 2

Expert Comment

by:orphanc
ID: 20359585
Have you removed DHCP from the new server, or have you left it as is? Do you want the new server to replace DHCP exactly as is on the old server, i.e, same scope settings etc?

If so, try this (bit of an old article but still the same):
http://support.microsoft.com/kb/130642

The priciple is still the same if you are introuducing a new DHCP server, must make sure services and DHCP are stopped on the old. I would suggest removing DHCP from the new and trying again. Setting up your scope and then authorizing.

0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:jrsitman
ID: 20359898
I willl delete the new server settings.  And yes I want them to be identical to the old.  Your suggestion sounds good.  If I do this during the day when the users are logged in it won't have any effect, correct?  Then if I reboot all workstations after the new DHCP server is working, the workstations should then find the new server, correct?
I just want to make sure I don't need to do a "release" per workstation.  Or should I change the lease duration to am hour?
0
 
LVL 2

Expert Comment

by:orphanc
ID: 20367644
Correct it shouldn't have any affect if done correctly, but you will have to change the lease duration to an hour so when the clients request a new lease they will request it from the new server.

From experience, it's best to perform such maintenace 'out of hours' - get all user's to shutdown their workstations, delete the settings from your new server, export the database from the old, install DHCP on the new, import the database on the new, stop dhcp settings/ services on the old, and then authorize your new server.

Hope that helps.

0
 

Author Comment

by:jrsitman
ID: 20367792
OK, I'll work on this tomorrow.  I'll keep you posted.
0
 

Author Comment

by:jrsitman
ID: 20373549
I followed each step with no problems.  Except the "authorize" option is still not displaying when I choose the actions to perform on the new server.  Where do I go from here?
0
 
LVL 2

Expert Comment

by:orphanc
ID: 20381674
Has you account got Enterprise Admin rights to the root domain? DHCP admins is not enough.
0
 

Accepted Solution

by:
jrsitman earned 0 total points
ID: 20382111
I found the problem.  The server has stopped communicating with the DC so it won't authorize.  I'm fixing that.  I'll get back to you when it's fixed if I still have problems.

Thanks
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The 6120xp switches seem to have a bug when you create a fiber port channel when you have a UCS fabric interconnects talking to them.  If you follow the Cisco guide for the UCS, the FC Port channel will never come up and it will say that there are n…
Learn about cloud computing and its benefits for small business owners.
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now