Solved

Support Code 0x80072F0D error when syncing with Motorola Q

Posted on 2007-11-27
5
2,479 Views
Last Modified: 2013-12-05
I need some help after spending and entire day yesterday trying to get ActiveSync to work on my Exchange Server.  I can get the syncing to work with out the SSL checked on the device.  But I have been unsuccessful when trying to synce with SSL checked in the device configuration.  I started on my Exchange server with a certificate from 3rd party trusted Vendor at wehostbiz.com and got a SSL certificate.

Result:
The security certificate on the server is invalid.  Contact your Exchange Server Administrator or ISP to install a valid certificate on the server.
Support code: 0x80072F0D

Weboutlook works fine with the Https://mail.opnarchitects.com wth the certificate.  But for some reason this error keeps coming up.
0
Comment
Question by:rbarr3766
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 20359433
You haven't got your root certificates in correctly.
The SSL certificate looks like it has come from Starfield, aka GoDaddy.

Also check whether that device has the root certificates for Starfield or www.valicert.com - I have heard that some Moto devices do not.

Simon.
0
 

Author Comment

by:rbarr3766
ID: 20359652
Thank You, I am contacting Starfield people right now on the issue.......wish me luck.
0
 

Author Comment

by:rbarr3766
ID: 20360137
I contacted Starfield and they gave me a long process to get the problem corrected.  I was actually a problem with the server.  I pasted there e-mail below in case someone else has the same problem.

Thank You for your help!!!

The issue you have is caused by either the presence of a Starfield root certificate in your trusted root certificate store located on your server, or a mis-installation of the intermediate certificates.

You need to do the following.

Go to Start...then Run, and type in MMC.

Once the MMC Console root is open, hit ctrl + m. This will bring up the Add/Remove Snap-In dialog box.

Select "Add"

In the Add Standalone Snap-in dialog box, choose "Certificates"; then click the "Add" button.

In the Certificates snap-in box it is very important you choose "Computer account," hit "Next," and then "Local computer."

Finish out of the standalone boxes and view the Console Root window. You should now see a Console Root folder, with a Certificates folder under it, and a list of folders under the Certificates icon/folder.

Open the "Trusted Root Certification Authorities" folder and then go to the "Certificates" sub folder and open it.

Seach the alphabetical listing for a Starfield Class 2 root certificate.

a) Right click the Starfield certificate
b) Select "Properties"
c) Select the radio button for "Disable all purposes for this certificate"
d) Click Ok

Then, in the Console Root window, expand on the Intermediate Certification Authorities folder and open the Certificates folder.

Find any Starfield certificates listed there and remove them.

Browse to https://certificates.starfieldtech.com/Repository.go

Download the following files:

sf_cross_intermediate.crt
sf_intermediate.crt

Then right click on the root or top level folder for the Intermediate Certification Authorities folder, choose All Tasks, and the Import option.

It is imperitive you install these files in the following order.

Browse to the sf_cross_intermediate.crt file and choose it.

Place it in the Intermediate Certification Authorities.

After completing the cross intermediate, do the same process, but this time for the intermediate certificate.

Next go to the "Personal" folder and open the Certificates folder.

If you have any expired or unused certificates in this folder, especially for the same domain you are working on, remove them.

Also, open the IE browser on your server and go to Tools/Internet Options/Content and click on the "Certificates" button and check the Trusted Root folder in it. Search for a Starfield Class 2 trusted root. If there is a Starfield listed, remove it.

Stop and Start IIS.

0
 

Author Closing Comment

by:rbarr3766
ID: 31411223
T'he answer pointed me back at the certificate provider.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 20360153
Did you check whether the valicert certificate is in the Windows Mobile device?

Simon.
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are many software programs on offer that will claim to magically speed up your computer. The best advice I can give you is to avoid them like the plague, because they will often cause far more problems than they solve. Try some of these "do it…
An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question