Canon, Pixma Colour all-in-one, MP460, Cannot install using usb - specified port unknown, Add New hardware Wizard - error specified port unknown

Trying to help neighbor install new Canon Pixma MP460 but it will not install & gives an error - specified port unknown.  I uninstalled all the Canon software through Control Panel/Add/Remove programs & rebooted.

I diligently followed the instructions carefully to install the software from CD BEFORE plugging in the USB cable, I only plugged in the printer when prompted to by the software & when I did the ‘new hardware detected’ bubble appears in the system tray several times, each showing the correct device (MP460).

Then after about 10 seconds the ‘install new hardware’ wizard  appears stating ‘Error – specified port unknown’.  

Then the ‘new hardware’ bubble changes to ‘an error occurred with the installation … your device may not work correctly’

I’ve tried the following:
- downloaded the latest drivers from the Canon website & used that – same error
- installed the software & then plugged in the printer in the front & back usb ports & it’s the same on each
- Other devices work fine in each of the ports
- checked Device Mgr – no errors & the printer shows up as an ‘Imaging Device’

Not sure what to try next? Any help appreciated, pls
jtkpenguinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

souseranCommented:
Is this a replacement for a previously existing USB printer? If so, make sure that all software for the previous printer is removed.

Disconnect the Canon printer. Uninstall the Canon software. Reboot.

Go to Start | Settings | Printers and Faxes | File (menu option) | Server Properties | Drivers (tab) | Installed printer drivers.

Remove every printer driver that shows up but is not known to be in use at all. Reboot.

Go through the steps for adding the Canon again.
0
jtkpenguinAuthor Commented:
Hello & thank you for your response, I have now tried the solution that you suggested (there was an old lexmark driver shown which I removed) but when I went through the Canon install setup again it gave exactly the same error.
Do you or anyone else have any other ideas, pls, I'm really desperate to get this sorted out.... thanks in advance.

0
souseranCommented:
Do you have a different USB cable that you can try with the Canon? I'll be offline for a few hours, but will get back to you later today.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

jtkpenguinAuthor Commented:
Thank you for your reply, yes I've tried a different cable.  I forgot to mention that each time I tried something different I made sure to un-install all canon stuff & reboot in between each time.

Interestingly, I'm able to scan from the computer & save a file????

Thanks again,
0
jtkpenguinAuthor Commented:
I too will be off-line until this eve & will await your help.
0
souseranCommented:
So you're saying the scan function on the device works, but it won't print?
0
jtkpenguinAuthor Commented:
yes using the MP Navigator software on the pc I can scan a document & view it on screen, then save it to MY Docs folder - no problem
I can also use the buttons on the front of the MP460 to scan to the pc - no problem
But it will not show up as a printer, & therefore I can't print

One other thing I've since discovered that may shed light somewhere or may just be me being thick!....  if the MP460 is plugged into the pc using USB cable when the pc is rebooted the pc will hang with just a cursor flashing in the top left-hand corner of the screen. When I unplug the usb cable the pc will continue to boot ok into windows.  I thought it may be seeing the MP460 as a storage device in the BIOS but don't know enough about it to change anything in there...

Thanks for your help.
0
souseranCommented:
Can you try the device in another USB port?
0
jtkpenguinAuthor Commented:
I have already tried it in each of the 2 front & 2 rear ports - the same error occurs
Yes I did un-install all canon stuff & rebooted before going through the installation again for each port, as you can imagin it took quite a long time... & I'm no nearer to a solution....
thanks for any help you can give me.
 
0
souseranCommented:
Try this.

Start | Run | type CMD | Press Enter.

In the command prompt window type:

set devmgr_show_nonpresent_devices=1

Press Enter. Type

start devmgmt.msc

The device manager screen should appear

Click on View | Show Hidden Devices.

Clear out any printer keys that are greyed out. Then remove any greyed out USB devices.

Save your changes. Disconnect the Canon printer. Reboot. Let Windows find the USB devices again.

If that doesn't work, I'm afraid I'm out of ideas on this one.
0
jtkpenguinAuthor Commented:
I did as you suggested (taking great care to do it exactly as you wrote) ... but.....

At the 'clear out any printer keys that are greyed out' bit it showed the Canon MP460 not greyed out but it showed 13 x LexmarkLexmark z25-z35 (yes twice like that) & I deleted them all
Also,
At the 'remove any greyed out USB devices' it showed 1 x unknown; 1 x USB composite device; 9 x USB mass storage; 8 x USB print support - all of which I deleted

Saved changes, disconnected the MP460 & rebooted, plugged in the MP460 &  it didn't work - exactly the same error happens....

I'm really lost & don't know what to do - I need to get this darn thing to print.... please can someone else help me out here.....

0
souseranCommented:
Dang! I'm sorry to say, I don't have any other ideas. If you are unable to get feedback from other Experst, my recommendation would be to close this question and open a new one. I would have absolutely NO objection to you requesting that your points here be refunded in that process. In the off chance that any of the information that is here might be helpful to another Expert by at least telling him or her what's already been done, I'd suggest closing the question rather than deleting it.

See this part of the FAQ for assistance:

Nobody answered my question. What do I do?

http://www.experts-exchange.com/help.jsp#hi71
0
jtkpenguinAuthor Commented:
Souseran, many thanks for your help,

I ended up doing a backup of his data & a full re-install of windows; drivers etc - I used the canon install software & it installed & was correctly recognised by windows. The pc was able to print; scan & copy perfectly.

A re-install was not really the option I wanted to use but after browsing the web for a good few days I realised that it was the only answer.
Jtk
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
souseranCommented:
@jtkpenguin,

Sorry it took a reinstall. Glad that fixed the problem. Since you did that, your best option for closing the question is this one:

I answered my question myself. What do I do?

http://www.experts-exchange.com/help.jsp#hi70
0
souseranCommented:
No objections.
0
Computer101Commented:
Closed, 500 points refunded.
Computer101
EE Admin
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Utilities

From novice to tech pro — start learning today.