Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 495
  • Last Modified:

Terminal Services Service Could Not Be Started On The Local Machine

I am just about going bald over this situation...I have 8 servers that I am able to remote desktop into, however one server I cannot. I go into the services and see that Terminal Services in not started, but when I try to start it, it gives me a message "Terminal Services Service could not be started on the local machine"? How do I get terminal services service to start?...what is causing this service to not be able to start up?
0
jb61264
Asked:
jb61264
  • 14
  • 14
  • 4
1 Solution
 
geniphCommented:
Do you get any error in the System Event Log when you try to start the service?
0
 
geniphCommented:
Also - have you tried uninstalling and reinstalling Terminal Services from the Control Panel Add/Remove Programs?  That sometimes helps.
0
 
jb61264Author Commented:
Terminal Services is not listed in the Add/Remove Programs and when I go to the Windows Components, its not listed there...just Terminal Server which as I understand however you don't need to have installed to use Remote Desktop for Administration
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
dreamyguyCommented:
1.could you copy paste the exact error message that u get in the event viewer?
2. also download filemon and regmon from www.sysinternals.com and run it while trying to start the terminal services service, export the logs to .log files and then compress and upload them to www.ee-stuff.com
3. yes, terminal server is installed by default on windows 2003 and doesnt needed to be added through add/remove programs. but if you try to install it, it would reinstall all the terminal server components therefore fixing any file/registry entries that might have been broken earlier. so install "terminal server" again through add/remove programs.
0
 
jb61264Author Commented:
1. I don't know that I know what message refers to my issue in event viewer...basically the indication that I have the I am having an error is when I use Remote Desktops and try to connect to the server...I get a brief message that says "connecting to server"...then after 2 seconds that message is gone and is replaced with "disconnected from server". If I review the event log on the server, I don't see anything that I can recognize as indicative of this event.

2. I was able to get Terminal Services to start...I read a forum post elsewhere that had me check the "Logon" tab of the window that opens when you double click the service...it was disabled there, I was able to set it to "enabled" and was able to start up the service...did that and restarted the machine, but I am still unable to connect to the server using Remote Desktops.

I went to the link you provided and MS must have swallowed up sysinternals.com...there was a statement about "Process Monitor" having replaced filemon and regmon...I have uploaded Process Monitor and will run shortly.

3. Terminal Server is not installed by default from what I understand...and does need to be added through add/remove programs...I'm no expert but have been reading quite a bit of material while trying to troubleshoot this...Terminal Services is a "root" service that allows remote desktop connections to be made and is the foundation that Terminal Server uses if installed as an option...is there an option somewhere I'm not seeing that allows me to reinstall "terminal services" so all the default settings will be made new?
0
 
dreamyguyCommented:
1. In that case export and compress and upload the entire system and application event logs.
2. Even procmon logs would do. You said that you're still not able to connect. What is the error message that you get this time?
3. Terminal server is installed by default on a windows 2003 server but in remote admin mode, and not application server mode. (it's not installed on a win2k server) there's no option to reinstall "terminal services" but there's an option to install terminal server under add remove windows components.
4. Have you checked the "allow users to remotely conect to this computer box under the remote tab under the system properties?
0
 
jb61264Author Commented:
1. would you like system and application logs in lieu of getting process monitoring logs? I just started Process Monitor and wow there are a billion things going on...I had to stop the "capture" and clear the events, then have someone come in and try the connect with remote desktops as soon as I said "go" which indicated that I restarted the capture with Process Monitor...am uploading this file now

2. Its not really an "error" message per se....its a message on Remote Desktops that says "connecting to server"...then after 2 seconds it says "disconnected from server"....so there's really no error message just a message indicating that it was connecting and then disconnected...but it never connects.

3. so you are suggesting I go ahead and install the Terminal Server option?

4. This was one of the first things I did after reviewing all the searches I've done regarding this problem...I also made sure that WIndows firewall was not enabled and if it was made sure that Remote Desktop was "allowed"
0
 
jb61264Author Commented:
Not sure where my uploaded file is located....I uploaded using the directions you provided and pasted in the URL of this question...but I don't see the file link anywhere
0
 
dreamyguyCommented:
1. well initially it was a service starting issue, and obviously the "service could not start" error was meaningless. By asking u to take a filemon/regmon/procmon, i wanted to see the files and registry keys that the service was trying to access in order to start itself and then i would have checked for access denied errors. since the service is starting now, that's no longer my concern.
2. i need the event logs so that i can see if there's an error message relating to the terminal service disconnection.
3. yes, u can install the terminal server option, there's no harm in it. only thing it does is that it reregisters the ts components and also adds the "application mode" option. u can also uncheck it later and remove that feature and it won't matter.
4. okay, have u also tried to disable windows firewall (just as a test) to eliminate that being the cause of interference?
0
 
dreamyguyCommented:
here's the link
https://filedb.experts-exchange.com/incoming/ee-stuff/5860-Logfile.zip
im downloading the file now. will post back if i find anything.
0
 
dreamyguyCommented:
yup, as expected, i didnt find any errors in the procmon log. that's understandable because the service starts fine now.
0
 
jb61264Author Commented:
2. I will run an event log now to see if you can help me isolate any error related to terminal service disconnection shortly.

4. I have had the Windows firewall disabled on this server for the past week while troubleshooting this issue
0
 
jb61264Author Commented:
I have uploaded the application log....the system log has nothing in it except for "print" events....I cleared all the log files prior to retrying to connect using remote desktops.

Let me know if you also want to see the security log.

BTW....thanks for hanging with me on this
0
 
dreamyguyCommented:
I want u to try this test on the server.

go to start--->run-->mstsc
type in "localhost" (without the quotes) and hit enter
let me know if it connects.
if not, then give me the error verbatim.
0
 
dreamyguyCommented:
I only see windows installer errors there related to the OMCI (Open Manage Client Instrumentation) installation. Those aren't related.
0
 
jb61264Author Commented:
Tried the mstsc connect and it wouldn't connect...message that came up is below:

The client could not connet to the remote computer. Remote connections might not be enabled or the computer may be too busy to accept remote connections. It's also possible that network problems are preventing your connection...try again later or contact your system admin if this continues.
0
 
dreamyguyCommented:
ok
1. Is the terminal server service started?
2. go to a command prompt and type in the following command
netstat -an

it'll show u a bunch of ip addresses and the states.
i want u to check whether the machine is listening on port 3389 (this is the port that rdp uses)
u should see something liek this

  TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING
0
 
geniphCommented:
This may seem obvious, but it is sometimes missed.  Go to the My Computer Properties\Remote tab (right click My Computer, select Properties, go to Remote) and make sure remote connectivity is enabled.  If Terminal Services logon had gotten set to disabled, it's possible that remote connections are also disabled.
0
 
jb61264Author Commented:
I don't have Terminal Server installed but the terminal services service is running...I went to command prompt and ran netstat -an......there is no port 3389 showing up
0
 
dreamyguyCommented:
I agree with geniph, besides I have already suggested you to check this setting earlier:

=======
4. Have you checked the "allow users to remotely conect to this computer box under the remote tab under the system properties?
=======
0
 
jb61264Author Commented:
geniph...thanks for the reminder, but I have been going back to that setting constantly to make sure it is enabled and it is....I also have Windows firewall configured to accept remote desktop clients even though it is turned off
0
 
jb61264Author Commented:
I don't see the "allow users to remotely connect to this computer box"....the remote tab I access is when you right-click on "My Computer" and select properties...I see a setting for "Remote Assistance" and "Remote Desktop" but no allow users to connect remotely...I do have "enable Remote Desktop on this computer" selected
0
 
jb61264Author Commented:
OK...something I just noticed...I double clicked on the LAN connection icon in my taskbar on the server....opened up the properties then the Advanced tab...there is a "Internet Connection Sharing" checkbox there that wasn't checked and also the "Settings" button once I clicked, it showed Remote Desktop not selected there among a list of things that also included Telnet which is not checked.

Also, I noticed that in services, the Windows Firewall service is started even though I have turned it off
0
 
dreamyguyCommented:
ok, since u dont have port 3389 there, it means that rdp is not listening.
let's recreate the rdp listener and see whether that solves the issue.
go to start-->run-->tscc.msc

you'll find a tcp-rdp connection entry listed there.
right click on it and delete it.
and then right click on it, select new and follow the wizard to create a new connection.
once the new connection is created, then check if it's working
0
 
dreamyguyCommented:
the same steps are also mentioned in http://www.ms-mvps.com/troubleshootingts.htm

"The client could not connect to the Terminal server. The server may be too busy. Please try connecting later"

Symptoms: 1. When trying to access TS (administration mode), you may get this message: "The client could not connect to the remote computer. Remote connections might not be enabled or the computer night be too busy to accept new connections...."

2. Under TS Manger, it shows Console only and not RDP-Tcp (listener).
Resolution: 1. Reset connection.
2. Recreate connection.
3. reboot the server.
0
 
jb61264Author Commented:
You are the freaking MAN dreamyguy...when I opened tscc.msc there wasn't any connection listed there...I've been to this connection manager before but just thought it was supposed to list current connections and since I wasn't able to connect I figured it shouldn't be listed anything...so I right clicked and added a connection named it RDP with the wizard and as soon as I did that netstat -an shows port 3389 is listening AND I can now connect using Remote Desktop...thank you, thank you, thank you

If I could give you double points I would  ;)
Here come the 500
0
 
dreamyguyCommented:
hehe that's awesome!
I'm glad to be of help!
0
 
jb61264Author Commented:
actually...you know...the question i had here () also had to do with this same issue and nobody could ever give me a solution that worked...if you go there and post the same accepted solution from above I'll award those points to you as well
0
 
jb61264Author Commented:
0
 
dreamyguyCommented:
really? wow how come i never noticed that question before. hehe
u wudnt have to go that far then :P
0
 
dreamyguyCommented:
the problem with people is that they like to bombard with suggestions without even starting at the base and trying to narrow down the issue.
i looked at the other related question and the suggestions people gave were too advanced and complicated, just like geniph said, "This may seem obvious, but it is sometimes missed".
0
 
geniphCommented:
I agree with the original poster, you definitely deserve the points for this and the other question.  I'm adding the solution to my knowledgebase, it's a handy tip to have.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 14
  • 14
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now