Solved

How to remove the menu bar in ie7

Posted on 2007-11-27
11
1,642 Views
Last Modified: 2013-12-08
I would like to remove/disable the menu bar in ie7 altogether.  At the moment the menu bar is auto-hidden but if the user clicks the Alt or F10 keys then the menu bar appears.  Is there anyway to stop this behaviour so the menu bar cannot be accessed at all?

Thanks
0
Comment
Question by:nicksbell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
11 Comments
 
LVL 20

Accepted Solution

by:
IndiGenus earned 125 total points
ID: 20360136
I'm sure it's doable with a reg edit. May want to take a look at this first.

http://technet.microsoft.com/en-us/ie/bb219541.aspx
0
 
LVL 97

Assisted Solution

by:war1
war1 earned 125 total points
ID: 20360185
Hello nicksbell,

You can hide the command bar with this registry edit
http://www.tech-recipes.com/rx/2036/ie7_how_to_hide_command_bar

But you cannot hide the entire Menu bar.

Hope this helps!
war1
0
 
LVL 2

Author Comment

by:nicksbell
ID: 20360543
I have looked at IEAK7 and although that allows you to disable varies menu items it doesn't actually give you the option to remove the menu bar.

It must be possible to do it via the registry as I have one user where the menu is disabled altogether and have created a new user where it shows if you press the Alt key.  I am trying to find the setting for the first user but have been unsuccessful so far.
0
Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

 
LVL 97

Expert Comment

by:war1
ID: 20360585
nicksbell, did you try the registry edit that I posted?
0
 
LVL 2

Author Comment

by:nicksbell
ID: 20361575
yes, I have previously hidden the command bar, thats not a problem.  Its the menu ar I am having the problem with.
0
 
LVL 97

Expert Comment

by:war1
ID: 20361808
There is no other way to hide the menu bar than to hit the ALT key.
0
 
LVL 2

Author Comment

by:nicksbell
ID: 20363857
mmmm, well thats very curious as I have one user where it works.  I guess I will have to do a registry comparison and see if I can spot the difference.
0
 
LVL 2

Author Comment

by:nicksbell
ID: 20363973
ok, I have discovered the difference.  The user where the menu is disabled has the following registry key:

hkcu/software/microsoft/internet explorer/toolbar/webbrowser/ITBar7Layout

This is a reg_binary key with what appears to be a few settings but when I apply it to a new user it disables the menu.  Only trouble is it is hard to tell what else it is doing.  Does anyone have any documentation as to what this key is used for?

0
 
LVL 2

Author Comment

by:nicksbell
ID: 20364917
After a bit of trial and error I have worked it out.  Strangely enough it was nothing to do with the ITBar7Layout binary key, but the WebBrowser key itself.  This is acting a bit more like a bug than an actual tweak but it seems to do what I want it to.  For anyone that is interested I have disabled the menu bar completely with the following 2 steps:

1. Add the DWORD value AlwaysShowMenus (set the value to 0) to the following key:

    [HKCU\Software\Policies\Microsoft\Internet Explorer\Main]

2. Add the following key

    [HKCU\Software\Microsoft\Internet Explorer\Toolbar\WebBrowser]

The WebBrowser key doesn't require any values it simply needs to be present.  Don't ask me how this works but it does.
0
 
LVL 97

Expert Comment

by:war1
ID: 20366531
nicksbell, glad you had a working registry to compare to.  Wonder how the registry got changed?
0
 
LVL 2

Author Comment

by:nicksbell
ID: 20367017
well it was the existence of the WebBrowser key that caused the menu to be removed.  That user obviously had an add-on or some other setting that required the ITBar7Layout value which is included in the WebBrowser key.  All very strange but it works.

As the two of you replied and both replies were useful, if not a solution, I'll split the points.

Thanks
Nick
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
Several part series to implement Internet Explorer 11 Enterprise Mode
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question