Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3183
  • Last Modified:

Exchange powershell question for set-receiveconnector settings

Hi we have just migrated to Exchange 2007 from Exchange 2003 and now our users cannot send a message larger than  10MB.  Have set this at an organisational level as below

[PS] C:\Documents and Settings\Admin\Desktop>get-transportconfig | fl *
~~~~
Name                           : Transport Settings
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
MaxReceiveSize                 : 24415KB
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : 24415KB
OtherWellKnownObjects          : {}

Think this is something to do with th receive connectors but we are struggling with the command.

[PS] C:\Documents and Settings\Admin\Desktop>get-receiveconnector | list
Fqdn                                    : server1.ourdomain.com
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize                           : 64KB
MaxHopCount                             : 30
MaxLocalHopCount                        : 3
MaxLogonFailures                        : 3
MaxMessageSize                          : 10MB

Question is how do we set the max message size on the receive connectors to 25MB???

Please help
0
dazzler1971
Asked:
dazzler1971
  • 3
  • 2
1 Solution
 
SembeeCommented:
Receive connectors or send connectors?
Remember you have two now.

This is the command structure for Send Connectors which is what controls what you can send
http://technet.microsoft.com/en-us/library/aa998294.aspx

You should be able to adapt the sample at the end of that page to adjust the setting.

Receive connector is for inbound email. That is here: http://technet.microsoft.com/en-us/library/bb125140.aspx
However the command is almost identical.

Simon.
0
 
dazzler1971Author Commented:
it is our outlook 2007 clients that connot send to the internet so not sure.  sounds like it could be the send connector then.  so from the settings i sent you we are now restricted to 10M inbound ??
0
 
SembeeCommented:
What you have shown is for incoming email.
Remember it is the server - so when your users send email the server is sending the email, not receiving it. It receives email from the internet.

Simon.
0
 
dazzler1971Author Commented:
OK made those changes to the receive connector as my mistake the problem was for incoming emails.  Do we need to restart any services for this to take effect??
0
 
SembeeCommented:
The most you will have to restart is the transport service.

Powershell: restart-service msexchangetransport

Simon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now