Solved

Internet Fails with Static IP on Fedora 7

Posted on 2007-11-27
9
702 Views
Last Modified: 2013-12-06
I have Fedora 7 installed and am not able to get internet access when I configure static IP.  My router is DDWRT and has a lease range of 100-255, so I set my static IP to 192.168.1.99 and netmask to 255.255.255.0 and default gateway to 192.168.1.1.

I can access the internet with system-network-config set to DHCP and Automatically obtain DNS from server, but outbound traffic fails if I switch to static.

# if config

eth0      Link encap:Ethernet  HWaddr 00:18:F3:65:0A:08  

          inet addr:192.168.1.99  Bcast:192.168.1.255  Mask:255.255.255.0

          inet6 addr: fe80::218:f3ff:fe65:a08/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:8687 errors:0 dropped:0 overruns:0 frame:0

          TX packets:9116 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000 

          RX bytes:4763228 (4.5 MiB)  TX bytes:1291750 (1.2 MiB)

          Interrupt:22 Base address:0xc000 
 

lo        Link encap:Local Loopback  

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:17026 errors:0 dropped:0 overruns:0 frame:0

          TX packets:17026 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0 

          RX bytes:43923989 (41.8 MiB)  TX bytes:43923989 (41.8 MiB)

Open in new window

0
Comment
Question by:daveokst
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 11

Accepted Solution

by:
tvman_od earned 500 total points
Comment Utility
1. Try to ping 192.168.1.1
2. Try to ping 216.109.112.135 (av.com)

If it goes through, so the problem with DNS settings. Most likely it has to be 192.168.1.1
0
 
LVL 11

Expert Comment

by:tvman_od
Comment Utility
BTW it's located in /etc/resolv.conf

nameserver 192.168.1.1
0
 
LVL 40

Expert Comment

by:omarfarid
Comment Utility
Hi,

Why don't you just look at the configuration you get from DHCP for default gateway, subnet mask, dns server, etc.?

It could be that a firewall / ACL not allowing your static IP address.
0
 

Author Comment

by:daveokst
Comment Utility
I'll check these things tomorrow after work... can you describe which configuration you are speaking of?  I took a look at /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-etho0... they look normal.
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 40

Expert Comment

by:omarfarid
Comment Utility
Hi,

if you run the ifconfig -a info you will see:

allocated ip
subnet mask
default gateway

if you run nslookup you should see the dns server ip
0
 

Author Comment

by:daveokst
Comment Utility
Ah.. right, Ive done that, but Ill copy the results tonight... the strange part is that dhcp works fine, so dunno how firewall would interfere.  

Some more background, I have had this working before ok.  I recently reinstalled Fedora again due to partition sizing problems, but during the install this time I enabled eth1 during the process.  But now I have it removed.
0
 
LVL 19

Expert Comment

by:alextoft
Comment Utility
Just to be pedantic, ifconfig does NOT display the default gateway. You use the route command for that :)

As mentioned, if you can ping an IP outside your subnet, it's probably a DNS issue. If you can't, you've probably not configured your default route correctly.
0
 

Author Comment

by:daveokst
Comment Utility
Hurray...

Ok, well apologies on two counts.  

1) Sorry for taking so long to get back, but my requirements changed.  See I ordered a 1U dual m-itx chassis with barebones that is intended to serve as a redundant router using VRRP.  I decided to go with Vyatta Community edition since it supports VRRP and has a lot of configuration options.  So that showed up in the mail, and I have been learning how to use it the past few days.

2) I should have tested tvman_od's original post.  I was trying to pint www.google.com with no replies.  Once I got Vyatta configured, I could ping my local network and the internet within the CLI, but not from a statically configured server on the network.  Finally it dawned on me that I needed to specify name servers so www.google.com would resolve.  If I had typed 216.109.112.135 listed above, I would have figured it out alot sooner.

All in all it taught me a bit more how this strange thing called a network works!  :)
0
 

Author Closing Comment

by:daveokst
Comment Utility
Thanks for everyones help!
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now