Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Cisco DSL Disconnect

Posted on 2007-11-28
1
Medium Priority
?
748 Views
Last Modified: 2013-12-14
Helo,

I have a newly configured Cisco 1841 router that I am using to connect to the Internet.  The service is very bad and keeps dropping out - the ISP is trying to blame this on the router config, but I am not sure that I can find anything incorrect in the config.  Please can any experts look at the config and see of there is anything wrong?  I attach the config and some of the loggin messages below

ROUTER CONFIG

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret
!
no aaa new-model
ip cef
!
!
!
!
ip domain name domain.com
ip name-server nameserver1
ip name-server nameserver2
vpdn enable
!
!
!
!
!
interface FastEthernet0/0
 ip address LAN_1_ADDRESS
 ip nat inside
 duplex auto
 speed auto
 hold-queue 100 out
!
interface FastEthernet0/1
 ip address LAN_2_ADDRESS
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 ip address PUBLIC_IP_ADDRESS
 ip access-group 101 in
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer remote-name redback
 dialer-group 1
 ppp authentication pap chap callin
 ppp chap hostname
 ppp chap password
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 150 interface Dialer1 overload
ip nat inside source static tcp LAN_1_ADDRESS 1723 ROUTER_EXTERNAL_IP 1723 extendable
ip nat inside source static tcp SERVER_INTERNAL_ILO 80 SERVER_EXTERNAL_ILO 80 extendable
ip nat inside source static tcp SERVER_INTERNAL_ILO 443 SERVER_EXTERNAL_ILO 443 extendable
ip nat inside source static tcp SERVER_INTERNAL_IP 20 SERVER_EXTERNAL_IP 20 extendable
ip nat inside source static tcp SERVER_INTERNAL_IP 21 SERVER_EXTERNAL_IP 21 extendable
ip nat inside source static tcp SERVER_INTERNAL_IP 25 SERVER_EXTERNAL_IP 25 extendable
ip nat inside source static tcp SERVER_INTERNAL_IP 80 SERVER_EXTERNAL_IP 80 extendable
ip nat inside source static tcp SERVER_INTERNAL_IP 443 SERVER_EXTERNAL_IP 443 extendable
ip nat inside source static tcp SERVER_INTERNAL_IP 1723 SERVER_EXTERNAL_IP 1723 extendable
ip nat inside source static tcp SERVER_INTERNAL_IP 3389 SERVER_EXTERNAL_IP 3389 extendable
!
access-list 23 permit X.X.X.X Y.Y.Y.Y
access-list 101 permit udp any eq domain any
access-list 101 permit tcp any any established
access-list 101 permit tcp any host SERVER_EXTERNAL_IP eq ftp-data
access-list 101 permit tcp any host SERVER_EXTERNAL_IP eq ftp
access-list 101 permit tcp any host SERVER_EXTERNAL_IP eq 1723
access-list 101 permit tcp any host SERVER_EXTERNAL_IP eq smtp
access-list 101 permit tcp any host SERVER_EXTERNAL_IP eq www
access-list 101 permit tcp any host SERVER_EXTERNAL_IP eq 443
access-list 101 permit gre any host SERVER_EXTERNAL_IP
access-list 101 permit tcp any host ROUTER_EXTERNAL_IP eq 1723
access-list 101 permit gre any host ROUTER_EXTERNAL_IP
access-list 101 permit tcp any host SERVER_EXTERNAL_ILO eq www
access-list 101 permit tcp any host SERVER_EXTERNAL_ILO eq 443
access-list 150 permit ip host SERVER_INTERNAL_IP any
access-list 150 permit tcp INTERNAL_LAN 0.0.0.255 any eq 1723
access-list 150 permit gre INTERNAL_LAN 0.0.0.255 any
access-list 150 permit ip host SERVER_INTERNAL_ILO any
dialer-list 1 protocol ip permit
!
control-plane
!
banner login ^C-----------------------------------------------------------------------------------
This router is the property of My Company Ltd. No unathorized access allowed.
-----------------------------------------------------------------------------------^C
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
end

LOGGING MESSAGES

*Nov 28 08:16:58.286: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:16:59.714: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:17:21.962: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:22:20.534: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:22:54.986: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:23:06.758: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:23:29.094: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:23:29.810: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:23:52.090: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:28:20.726: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:28:47.046: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:28:49.546: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:29:11.834: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:34:11.222: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:34:37.486: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:40:00.246: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:40:35.350: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:45:58.998: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:46:25.414: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:51:47.638: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:52:08.214: %LINK-3-UPDOWN: Interface ATM0/0/0, changed state to down
*Nov 28 08:53:09.398: %LINK-3-UPDOWN: Interface ATM0/0/0, changed state to up
*Nov 28 08:53:19.546: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:57:58.006: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:58:20.082: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:58:33.470: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:58:56.022: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 08:58:57.834: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 08:59:23.082: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 09:03:47.734: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 09:04:22.482: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 09:09:46.710: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 09:10:13.270: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 09:15:37.014: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 09:16:12.230: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 09:21:32.182: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 09:21:58.830: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
0
Comment
Question by:micross
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 10

Accepted Solution

by:
cstosgale earned 1500 total points
ID: 20377775
Hi,

This is most likely an issue with your line. The only way to prove to the SP is at fault however, is to try a different router on the line, ideally the one the ADSL provider supplied. This way, you know the router is not at fault.
0

Featured Post

Tech or Treat! - Giveaway

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question