Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1621
  • Last Modified:

USB 2.0 devices not recognised

When I plug a USB 2.0 device into any USB port on my motherboard (Asrock 939DUAL-VSTA, all USB 2.0 supported) it gives me the "This device can perform faster" error, and if I click on the bubble to view a list of available ports there are 8 listed under "ULi USB 2.0 Enhanced Host Controller", all unused.

As I understand it (correct me if I'm wrong) when a device is plugged in it is identified as USB 1 or 2, and then the appropriate controller is used, but this doesn't seem to be happening!

It is not an OS issue, as the problem has persisted through an OS reinstall (XP to Vista, clean install), and all motherboard drivers are installed. I have tried plugging only one device in to ensure a slower device wasn't "lowest common denominator-ing" everything, to no avail.

The controller is there, just not being used, nearly as if the ports don't have access to it. Any ideas?
0
adfinlay
Asked:
adfinlay
  • 6
  • 5
  • 3
  • +2
1 Solution
 
stesynthCommented:
Go to windows update and update all your drivers.
Then goto Start, Run and type in msinfo32 and then hit enter.
Goto components and select USB, see whether it shows up there.
0
 
adfinlayAuthor Commented:
the drivers are all up to date. The output from msinfo32 shows

3x ULi PCI to USB Open Host Controller
1x USB 2.0 Enhanced Host Controller

here is a screenshot, just in case it helps :)
http://img260.imageshack.us/img260/3673/msinfo32usbps5.jpg
0
 
PUNKYCommented:
Can you check in bios see if all options of usb enabled?
0
[Video] Oticon Case Study

Open office environments can create the dynamics for innovation, but they also bring some challenges. With over 1,000 employees in an open office, Oticon needed a solution that would preserve the environment while mitigating disruptive background noises.

Watch how they did it.

 
YGregersenCommented:
Are you sure your device is USB 2.0 or USB 2.0 compatible? Older devices also could try and draw above the 5m amps limit set by USB 1.1 standard. USB 2.0 enforces that limit and a lot of older devices croack.

I bought a special double ended usb cable for an older exteranl drives so it can draw more power.
0
 
adfinlayAuthor Commented:
@PUNKY: all of the relevant BIOS entries are set correctly... :(

@YGregersen: the devices I have tested with are a Belkin USB2.0 54g wireless adapter and my USB memory stick...again USB2.0

both devices have been verified as working correctly on other computers.
0
 
YGregersenCommented:
OK - plug in devices and go into device manager and uninstall it. Then uninstall the hubs shown in the list

Shutdown - remove the USB devices and turn on PC
after it refinds the hubs -
Install the drivers for the belkin
Plug belkin in - should find it
Plug in memory stick - should find it


What has happened is that the USB hardware ID's info in the registry has been incorrectly set - Unfortunately unlike XP they have locked out the ability to manually go in and delete the entries in the registry.

The only way for entries to be removed is through an uninstaller/installer - Which device manager can provide.
0
 
nobusCommented:
here my 2 cents :
i have several devices that Vista does NOT recognise, while XP has no trouble at all with them
i think your usb controller (onboard) has a problem. - as you were thinking
you can try to use a PCI to usb card to resolve your problem
or try these softwares, they have helped me in some cases (even when they apparently did nothing, the problem was gone later) :
http://drivers.softpedia.com/get/Other-DRIVERS-TOOLS/Others/Sony-EzRecover.shtml   
http://safelyremove.com/?pid=1      

another way to test is to run from a live knoppix cd - it supports usb :
ftp://ftp.uni-kl.de/pub/linux/knoppix/KNOPPIX_V5.1.0CD-2006-12-30-EN.iso
0
 
YGregersenCommented:
Did you try my fix?
0
 
adfinlayAuthor Commented:
Sorry, I've had a few things on recently and haven't had time...I'll try and give it a go later this evening, I have a Knoppix Live CD ISO ready to burn as well, but hopefully it will be an easy fix as opposed to a dodgy controller :)

0
 
adfinlayAuthor Commented:
I tried uninstalling the ahrdware and hubs but it didn't help...I booted up into a Ubuntu Live CD (knoppix iso corrupt) which supports USB 2.0 and detected the Controller, but still assigned the device to a USB 1.1 controller. So I think the problem lies with the controller/motherboard.

Is there anything I can do to resolve this or is it a replacement part issue?
0
 
YGregersenCommented:
Is there a setting in your BIOS to change your USB controller to compatability mode, or Hi-speed versus Normal?
0
 
YGregersenCommented:
These are the USB settings available as stated in your Manual - The 2nd looks like a candidate the legacy thing too might be a culprit. Check them out and let us know.


USB Controller
Use this item to enable or disable the use of USB controller.
USB 2.0 Support
Use this item to enable or disable the USB 2.0 support.
Legacy USB Support
Use this item to enable or disable the support to emulate legacy I/O
devices such as mouse, keyboard,... etc. Or you may select [Auto] so
that the system will start to auto-detect; if there is no USB device
connected, Auto option will disable the legacy USB support.
0
 
nobusCommented:
if it was ok before - and knoppix and windows now see it as usb1 - yes i think your motherboard is bad
This is the bad news - the good news is you do not need a new mobo, only a , which will restore usb 2 speed for you  http://www.everythingusb.com/hardware/USB_Cards/
0
 
adfinlayAuthor Commented:
Thanks for the suggestion about a PCI to USB card...this has restored functionality, although I'm annoyed I could not fix the problem...c'est la vie!
0
 
nobusCommented:
Mais oui mon cher . .
0
 
YGregersenCommented:
Thinking out loud here...

How would ALL USB 2.0  hardware controllers go bad by defaulting to USB 1.1 all at once?
* BIOS settings
* motherboard Jumpers.

If it is specific to devices:
* bad device
* USB cable is not rated for hi-speed
* Corrupt or incorrect drivers.


Did you try this? --

There are USB settings available as stated in your Manual - The 2nd looks like a candidate the legacy thing too might be a culprit. Check them out and let us know.

USB Controller
Use this item to enable or disable the use of USB controller.
USB 2.0 Support
Use this item to enable or disable the USB 2.0 support.
Legacy USB Support
Use this item to enable or disable the support to emulate legacy I/O
devices such as mouse, keyboard,... etc. Or you may select [Auto] so
that the system will start to auto-detect; if there is no USB device
connected, Auto option will disable the legacy USB support.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 5
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now