?
Solved

Cannot ping or telnet to switch

Posted on 2007-11-28
10
Medium Priority
?
544 Views
Last Modified: 2010-04-21
I have recently configured a couple of Cisco switches and have obviously got something wrong because i have the same problem with both.
The switch works Ok for passing data. It is visible in Show CDP Neighbour from connected switches. I can't Ping it or Telnet to is. I can't Ping it from itself (Connected via Console)
The config is as follows:

Current configuration : 2549 bytes
!
! Last configuration change at 15:38:47 UTC Tue Nov 20 2007 by sypte
! NVRAM config last updated at 15:39:18 UTC Tue Nov 20 2007 by sypte
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ********
!
aaa new-model
aaa authentication login default local
enable secret 5 *********
enable password 7 **********
!
username sypte password 7 *************
ip subnet-zero
!
spanning-tree extend system-id
!
interface FastEthernet0/1
 no ip address
======================================
(All interfaces the same at present)
======================================
interface Vlan1
 ip address ***.***.***.*** 255.255.255.0
 no ip route-cache
!
ip default-gateway ***.***.***.***
ip http server
!
snmp-server engineID local 800000090300000CCE2D3C01
snmp-server community public RO
snmp-server community public@es0 RO
snmp-server location Comms room
!
line con 0
 exec-timeout 0 0
 password 7 *********
line vty 0 4
 exec-timeout 30 0
 password 7 ***********
line vty 5 15
 exec-timeout 30 0
 password 7 ************
!
ntp clock-period 17179823
ntp server ***.***.***.***
end

I'm sure its a pretty simple setting, but comparng the config with another working switch, i can't see it.
Current configuration : 2549 bytes
!
! Last configuration change at 15:38:47 UTC Tue Nov 20 2007 by sypte
! NVRAM config last updated at 15:39:18 UTC Tue Nov 20 2007 by sypte
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ********
!
aaa new-model
aaa authentication login default local
enable secret 5 *********
enable password 7 **********
!
username sypte password 7 *************
ip subnet-zero
!
spanning-tree extend system-id
!
interface FastEthernet0/1
 no ip address
(All interfaces the same at present)
!
interface Vlan1
 ip address ***.***.***.*** 255.255.255.0
 no ip route-cache
!
ip default-gateway ***.***.***.***
ip http server
!
snmp-server engineID local 800000090300000CCE2D3C01
snmp-server community public RO
snmp-server community public@es0 RO
snmp-server location Comms room
!
line con 0
 exec-timeout 0 0
 password 7 *********
line vty 0 4
 exec-timeout 30 0
 password 7 ***********
line vty 5 15
 exec-timeout 30 0
 password 7 ************
!
ntp clock-period 17179823
ntp server ***.***.***.***
end

Open in new window

0
Comment
Question by:SYPTE-IT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 21

Expert Comment

by:from_exp
ID: 20365999
show log, please
0
 
LVL 1

Author Comment

by:SYPTE-IT
ID: 20366048
which log?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20366229
Are you using public IP addresses on this switch?
0
Plug and play, no additional software required!

The ATEN UE3310 USB3.1 Gen1 Extender Cable allows users to extend the distance between the computer and USB devices up to 10 m (33 ft). The UE3310 is a high-quality, cost-effective solution for professional environments such as hospitals, factories and business facilities.

 
LVL 21

Expert Comment

by:from_exp
ID: 20367807
when your are logged in to the switch via console,
enable
 <password>
show logging
0
 
LVL 1

Accepted Solution

by:
mmurraynet earned 400 total points
ID: 20368715
Here's a dumb question - did you try doing a "no shut" on the VLAN 1 interface?

Also, do you have active ports in VLAN 1?
0
 
LVL 1

Author Comment

by:SYPTE-IT
ID: 20375125
OK, I'll have to wait till I next visit the switch to get the log (not at this site)
Using private addressing (192.168.xxx.xxx)
Tried shutting down and no shutting VLAN 1, same problem both ways. currently not shut down
There is only VLAN1 on the switch, and all ports are in it.

typical port config

MHI-Comms-S01#show int fa0/1
FastEthernet0/1 is up, line protocol is up
  Hardware is Fast Ethernet, address is 000c.ce2d.3c01 (bia 000c.ce2d.3c01)
  MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     777941 packets input, 159411780 bytes, 0 no buffer
     Received 247 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 7 multicast, 0 pause input
     0 input packets with dribble condition detected
     894185 packets output, 386517420 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 300 total points
ID: 20375312
Since you're using private addresses, there's no need to hide them. In fact, it makes it very difficult to troubleshoot without them.

Please provide the IP address of the host, the port it's connected to and the config of the switch.
0
 
LVL 21

Assisted Solution

by:from_exp
from_exp earned 300 total points
ID: 20375387
you have provided status of the interface
please provide log:
show logging command
and show running-config output, please
0
 
LVL 1

Author Comment

by:SYPTE-IT
ID: 20418648
Red face time now, I've just gone hyperterminalled on to get the config and logs etc and I've noticed VLAN1 was shutdown. No Shut makes everything work! I'm sure I checked that, as I said I even tried shutting it and no shutting it, but I must have made a mistake.

Thanks to everyone for their efforts tho.
0
 
LVL 1

Author Closing Comment

by:SYPTE-IT
ID: 31411428
I've split the point for your efforts, giving mmurraynet a bit for more for accidentally being on the right lines!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question