Solved

Firefox and IE can't resolve host names

Posted on 2007-11-28
12
284 Views
Last Modified: 2013-12-04
Odd problem this morning.  My Windows XP SP2 computer suddenly can't connect to websites using the url.  If I type in the IP address, it works, so "www.google.com" gives me an error, but "64.233.161.104" works fine.  The error is simply "Firefox can't find the server at www.google.com."

This happens in both IE and Firefox.  Outlook can still connect to my 3 email accounts and get my mail.  FeedDemon RSS reader can still collect all my RSS feeds.  I'm on a local network, and all the other computers are fine (which is where I'm posting this from).

I've "repaired" my network connection, flushed the DNS, and changed the DNS servers to the OpenDNS servers (also tried auto-detect, and my ISP's DNS servers)  I've disabled the Kaspersky firewall.  Nothing seems to work!

Any ideas for something else I can try?

0
Comment
Question by:cinepro
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 4

Expert Comment

by:scottdorsey
ID: 20367477
First guess would be spyware/virus. Can you ping a domain name by dns? Check your 'hosts' file, download hijack this and analyze the log file at www.hijackthis.de to see if anything nasty is lurking. I presume you have anti-virus installed? www.free.grisoft.com if not.
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 20367536
Hi,

If on those m/cs you run from the command line

nslookup

server dnsipaddress

www.cnn.com (or the domain you have problem with)

Do you get the response back or it just give error message / or just time out

If it resolves then there is no problem with the dns server or the communication to it.

If you see errors / time out then your dns servers for some reason are responding or not reachable
0
 

Author Comment

by:cinepro
ID: 20367696
Here's how it went:

-----------------------------------------------------------------------
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\jburk>nslookup
Default Server:  resolver1.opendns.com
Address:  208.67.222.222

www.google.com
Server:  resolver1.opendns.com
Address:  208.67.222.222

Non-authoritative answer:
Name:    google.navigation.opendns.com
Addresses:  208.67.216.230, 208.67.216.231
Aliases:  www.google.com

>
---------------------------------------------------------------------------
0
Turn Insights into Action

Communication across every corner of your business is essential to increase the velocity of your application delivery and support pipeline. Automate, standardize, and contextualize your communication processes with xMatters.

 

Author Comment

by:cinepro
ID: 20367873
Additional Note:

Ran "HiJackThis", didn't find anything unwanted.  Ran "spybot s&d", only found tracking cookies (deleted them).

Still no joy.
0
 

Author Comment

by:cinepro
ID: 20367884
Additional additional note:

Just installed "Opera".  It works fine.  Still no Firefox or IE.
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 20367900
So, as you can see there is no problem in resolving domain names and the dns server is ok.

Ok, try

C:\> telnet www.google.com  80
GET http://www.google.com


The command above will connect you to www.google.com on port 80

If you see that the session is trying and then disconnecting, then you could be having problem going out.

If you could manage to type the second line and get some response (the index.html) then you have no problem to connect to the web site.
0
 

Author Comment

by:cinepro
ID: 20368354
Can't telnet to www.google.com.  It just says "connection lost"
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 20368432
Did you telnet to port 80?

If yes, then there could be a firewall some where interrupting your connection.

0
 

Author Comment

by:cinepro
ID: 20368509
It looks like I can ping www.google.com.  But it still won't load in IE or Firefox (but Opera is fine)


-------------------------------------------------------------------------------------
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.


C:\Documents and Settings\jburk>ping www.google.com:80

Pinging www.google.com:80 [208.67.219.137] with 32 bytes of data:

Reply from 208.67.219.137: bytes=32 time=41ms TTL=241
Reply from 208.67.219.137: bytes=32 time=42ms TTL=241
Reply from 208.67.219.137: bytes=32 time=94ms TTL=241
Reply from 208.67.219.137: bytes=32 time=28ms TTL=241

Ping statistics for 208.67.219.137:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 28ms, Maximum = 94ms, Average = 51ms
-------------------------------------------------------------------------------------
0
 

Author Comment

by:cinepro
ID: 20368737
It turns out the problem was the firewall on my Kaspersky software.  It had been disabled, but was still blocking Firefox after Firefox automatically updated last night.

Followed the directions here:

http://support.mozilla.com/kb/Configuring+Kaspersky+Internet+Security

Now it works. :)
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 20805687
PAQed with points refunded (125)

Computer101
EE Admin
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Security measures require Windows be logged in using Standard User login (not Administrator).  Yet, sometimes an application has to be run “As Administrator” from a Standard User login.  This paper describes how to create a shortcut icon to launch a…
Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question