Solved

Stop iis using port 443 on an IP

Posted on 2007-11-28
6
1,383 Views
Last Modified: 2012-08-14
I have a w2k3 server. On this server I have 2 ip addresses which I have tried using on a single nic and on second nic. I have owa running on the main ip address which I have changed iis from using unassinged address to the correct address. I need to use 443 for another application on the other ip address but iis seems to still have hold of it even though I have told it to use the primary ip for the default website.

Can anyone shed any light on how i can resolve it
0
Comment
Question by:perfectpc
  • 3
  • 3
6 Comments
 
LVL 3

Expert Comment

by:whatsoverthere
ID: 20367720
So is your configuration like this:

IIS OWA - IP address # 1 - port 80
Other application - IP address # 2 - port 443

And your problem is that IIS is using port 443, preventing the other application from using it?
0
 
LVL 3

Author Comment

by:perfectpc
ID: 20367863
My set up is 10.10.10.2 for 80 and 443 with certificate running owa over ssl.
I need to install my application on 10.10.10.3 with port 443
I have tried using both 1 and 2 nic's
0
 
LVL 3

Expert Comment

by:whatsoverthere
ID: 20367925
OK.

First make sure that no websites in IIS are set to use the IP address: All Unassigned
Go to Advanced web site identification and make sure that SSL isn't using All Unassigned IP addresses either.

Then you may need to disable socket pooling in IIS. To do this follow the steps at http://support.microsoft.com/kb/238131

Hope this helps
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 3

Author Comment

by:perfectpc
ID: 20368491
Ok so iis set to use 10.10.10.2 and the script from the above kb and still iis is holding 443
0
 
LVL 3

Expert Comment

by:whatsoverthere
ID: 20406257
Hmm, I'm not sure. Have you double-checked that no websites are using unassigned IP addresses? And did you restart IIS?

You could try forcing IIS to use another port for SSL with the following command from the Inetpub\Adminscripts folder:

cscript c:\inetpub\AdminScripts\adsutil.vbs set w3svc/1/securebindings ":8000:"

You can use any uncommon port instead of 8000
0
 
LVL 3

Accepted Solution

by:
perfectpc earned 0 total points
ID: 21229023
I had to use microsoft fix WindowsServer2003-KB892777-SupportTools-x86-ENU.exe This resolved the problem.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) (http://technet.microsoft.com/en-us/library/cc758834(WS.10).aspx) is a much better solution when you need to p…
What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question