Stop iis using port 443 on an IP

I have a w2k3 server. On this server I have 2 ip addresses which I have tried using on a single nic and on second nic. I have owa running on the main ip address which I have changed iis from using unassinged address to the correct address. I need to use 443 for another application on the other ip address but iis seems to still have hold of it even though I have told it to use the primary ip for the default website.

Can anyone shed any light on how i can resolve it
Who is Participating?
perfectpcConnect With a Mentor Author Commented:
I had to use microsoft fix WindowsServer2003-KB892777-SupportTools-x86-ENU.exe This resolved the problem.
So is your configuration like this:

IIS OWA - IP address # 1 - port 80
Other application - IP address # 2 - port 443

And your problem is that IIS is using port 443, preventing the other application from using it?
perfectpcAuthor Commented:
My set up is for 80 and 443 with certificate running owa over ssl.
I need to install my application on with port 443
I have tried using both 1 and 2 nic's
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.


First make sure that no websites in IIS are set to use the IP address: All Unassigned
Go to Advanced web site identification and make sure that SSL isn't using All Unassigned IP addresses either.

Then you may need to disable socket pooling in IIS. To do this follow the steps at

Hope this helps
perfectpcAuthor Commented:
Ok so iis set to use and the script from the above kb and still iis is holding 443
Hmm, I'm not sure. Have you double-checked that no websites are using unassigned IP addresses? And did you restart IIS?

You could try forcing IIS to use another port for SSL with the following command from the Inetpub\Adminscripts folder:

cscript c:\inetpub\AdminScripts\adsutil.vbs set w3svc/1/securebindings ":8000:"

You can use any uncommon port instead of 8000
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.