?
Solved

PIX Config change

Posted on 2007-11-28
9
Medium Priority
?
197 Views
Last Modified: 2010-04-09
I have a PIX 515 running version 6.3(4) of the IOS.
I need to change the IP address of my mail server and there is a line in the config i need to change but can't.
The line is:

static (inside,outside) *external IP* *internal IP* netmask 255.255.255.255 0 0

I need to change the internal IP address but if i try to remove this line or add another it fails on the static word.

Any ideas on how i can edit this line?

Thanks.
0
Comment
Question by:nealerocks
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 20368722
To remove the line copy and paste it back into the configuration but with the 'no ' keyword infront.
You can then enter the new command with the modifed IP address.
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20368736
Are you in config mode?  Your prompt should look like this:

pixfirewall(config)#

If you have the "#" prompt at the end and it says (config), then you should be able to issue the "no" form of the static command to remove it.  In other words,

no static (inside,outside) *external IP* *internal IP* netmask 255.255.255.255

and then type the static command back in with the new value(s).
0
 
LVL 25

Expert Comment

by:Cyclops3590
ID: 20368948
i have to agree with batry_boy.  typically when this happens to me, i'm in a hurry to make a simple change and sometimes forget to put myself in config mode first.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 12

Author Comment

by:nealerocks
ID: 20369128
Thanks for your responses guys.
However i am in config mode and i have tried typing the whole line with "no" in front of it.

It give me an error and the little arrow points to the word static.
0
 
LVL 28

Accepted Solution

by:
batry_boy earned 2000 total points
ID: 20369210
Try clearing your existing xlates first with the command:

clear xlate

and then try removing it again.  If that doesn't work, I would reload the PIX and try again.
0
 
LVL 12

Author Comment

by:nealerocks
ID: 20369295
I tried the clear xlate command but it wont accept it. i tried in config mode and normal mode.
the error is the word clear. is there another command to clear the xlate?
0
 
LVL 12

Author Comment

by:nealerocks
ID: 20369363
when i try clear xlate in enable mode the error points to xlate.
i typed clear ? and xlate did not show up in the list of available commands.
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20369476
OK, something weird is going on here...post the output of the "show version" command, please.
0
 
LVL 12

Author Comment

by:nealerocks
ID: 20369623
Holy shit, i'm the dumbest person in the world! i had the console cable plugged into the wrong port. that is why the commands were not working. i plugged it into the router by mistake which sits on top of the pix.
sorry guys.

Thanks for your help batry. im going to give you the points because i had the right commands from the beginning, i just noticed the problem when you asked for the show version output.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question