ATI2Drag.dll - Fatal Error on remote reboot using VPN

I connect to a machine at work that only allows remote desktop connections from the same network, so we have a vpn that i use from home. This all works great, but when i use ctrl-alt-end from home, and try to restart, the remote computer always crashes with this error:

ati2drag.dll

minal_server_driver_made_incorrect_memory_reference

 and a bunch of number references. i can succesfully (and without error) use the same technique from a computer within the network (a local computer not using vpn).

any ideas about this error?
alternately, is there a way i could have the restart command come from another remote computer? i tried this by logging into a different remote computer, and then remote desktop from there to the other remote computer, but the ctrl-alt-end command seems to always target the connection i made from home, not the other remote computer.  
chrismarxAsked:
Who is Participating?
 
johnb6767Commented:
I wouldnt worry about a worjkaround, I would look at the Video Drivers of the mahcine you are RDPing into....

Sure that isnt ATIDiag.dll?

Uninstall your Display adapter in the Device Manager, reboot, and reinstall the adapter with the latest drivers....

Then retest....
0
 
SysExpertCommented:
1) Use a batch program to restart the computer ( shutdown.exe or similar, also tools in the windows resource kit )

2) Get the latest drivers on the remote machine, and also disable any nonessential startup services, including possibly the ATI relarted services.



I hope this helps !
0
 
chrismarxAuthor Commented:
thanks,  i like the idea of some kind of batch program. im going to download this:

http://www.download.com/Shutdown-Machine/3000-2344_4-10138257.html?tag=lst-2

ill let you know how it goes-
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
chrismarxAuthor Commented:
i ended up putting this in a shortcut

%windir%\system32\shutdown.exe -r -f -m \\full.computer.name -t 60 -d up:125:1

however, this only worked when i was connected to the computer from another computer at work, not a direct connection from home to work. any ideas why?
0
 
chrismarxAuthor Commented:
i;ve made progress. i noticed that after remoting in from another computer, one of my monitors was blank, and the only way to get the screen to come back up was to disable and then reenable the monitor from the display control panel. on a hunch, i disabled the monitor and then tried the remote restart. no problems. it was clear the error was due to the graphics drivers. any ideas how to more permanently fix this problem?
0
 
chrismarxAuthor Commented:
sure that isnt atidiag.dll? you mean rather than ATI2Drag.dll? i may have copied down the error code incorrectly, is there a difference?
- ok will do
0
 
SysExpertCommented:
You might also disable any of the ATI programs that are in the startup via msconfig,  to see if that helps. Most are not really needed for daily use, and are just for convenince.


I hope this helps !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.