Solved

Hostname in Message-ID does not match FQDN for SMTP server.  Does this matter?

Posted on 2007-11-29
4
592 Views
Last Modified: 2013-11-30
We have an SBS machine that we use as our internal mail server.

Recently, we have had a number of emails returned from a number of different recipients.  Reasons for non-delivery are time expired or permission denied.  These are just one-off emails - not part of any bulk mailing activity.

There have also been a number of emails delayed for many weeks - some sent in August have just been delivered to the recipient.

Some of the recipients are using public services like hotmail - so I assume it's not an issue with the recipient servers.

I've double checked all settings on our server...been to DNSstuff.com to check junk email blacklists and made sure reverse DNS is set up correctly.

Retry intervals on the SMTP server are 10 minutes, expiry after 7 days.

All appears to be as it should.

However, one thing I have noticed is that the Message-ID header on our outgoing emails contains a different hostname to the one sent as FQDN, which is the one registered with reverse DNS.

We have two hostnames pointing to our public IP
mail.ourcompany.com
secure.ourcompany.com

Originally, the only host name we used was mail.ourcompany.com and so MX records, SMTP server's FQDN and reverse DNS are setup for mail.ourcompany.com

However, there is a small web application that needs to be accessed by a couple of our customers that runs on our SBS machine - restricted by IP to their offices and also password protected.  We have a SSL certificate for this (public CA) under the hostname secure.ourcompany.com.

So this same certificate has been used in the SBS Connect to Internet wizard for use with Exchange.

As a result, the Message-ID header on outgoing emails has the suffix @secure.ourcompany.com and not @mail.ourcompany.com which can be correctly resolved using rDNS.

Would this cause a problem?


Open in new window

0
Comment
Question by:devon-lad
  • 2
  • 2
4 Comments
 
LVL 104

Expert Comment

by:Sembee
Comment Utility
If the server is announcing itself as secure.domain.com and that resolves to the same IP address then I would suggest that you get everything switched across to that.

Another option would be to stop using the home grown certificate and purchase one for that name. Then setup SBS using your preferred name for mail.

It is probably the FQDN value that is causing the problem.
ESM, Servers, <your server>, Protocols, SMTP. Right click on the default SMTP VS and choose Properties. Then click Delivery and then Advanced. The FQDN should match what the Reverse DNS record says. The wizard never sets it correctly.

Simon.
0
 
LVL 1

Author Comment

by:devon-lad
Comment Utility
Server is currently announcing itself as mail.ourcompany.com as per reverse DNS

"...FQDN and reverse DNS are setup for mail.ourcompany.com..."

We are not using homegrown

"...SSL certificate for this (public CA)..."

FQDN does match reverse DNS - but it does not match the hostname in the Message-ID headers.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 250 total points
Comment Utility
No one scans on the message-id headers. That isn't an issue as far as I am concerned. The message-id reflects the server's real name. You get email from me it will say server4.domain.local and I have no problems with email delivery.

Therefore the message-id is not the cause of your problems.

Simon.
0
 
LVL 1

Author Comment

by:devon-lad
Comment Utility
Right...that's what I wanted to know.
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
how to add IIS SMTP to handle application/Scanner relays into office 365.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now