Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1406
  • Last Modified:

Ghost Imaging- trying to "inject" SATA drivers onto SATA drive that has been cloned from an IDE drive to make SATA bootable

I am trying to image a PC with Ghost Enterprise 8.0 that has an IDE hard drive and push the image down to a PC with a SATA drive in it.

I was able to image the IDE computer fine and have the image on my network.  I was able to push that image down to the SATA computer fine, from the network, but when I boot up on the SATA computer the "Load last good configuration", "Load normally", "safe mode", etc. screen appears.  No matter what I choose, I get a blue screen.  If I try to run a Windows Repair from the OS CD, I get a blue screen when the setup gets to the "..Loading Windows..." part.  I even tried to the "Press F6 to load 3rd party RAID/Controller drivers" and pointed setup to the right drivers but it still doesn't work.

I was able to get the SATA drive out of the computer and into another one that already had 3 IDE drives in it.  So now I can boot to one of the IDE drives and see the SATA one under My Computer.  My question is: How can I load the correct SATA drivers onto the SATA drive so that when I try to boot to that drive I don't get a blue screen?  I have done research and am 99.9% sure that the reason why I'm getting blue screen is because there's no SATA drivers on the SATA drive (why would it, it has cloned contents of an IDE drive...).  I am going to try to run the actual setup.exe for the SATA drivers but I'm not sure if that would all of a sudden make it bootable (don't know where Windows looks to to grab the correct hard disk drivers upon bootup.).
0
Swamp_Thing
Asked:
Swamp_Thing
1 Solution
 
willcompCommented:
Install SATA controller driver in XP installation on IDE drive. Then image drive.
0
 
jrittenhCommented:
The best way to do this would be to install the drivers on the old machine before taking an image.

If the machines aren't very similar internally, it's possible that there are other issues.  If that's the case, you can try installing appropriate chipset drivers, etc. for the new machine on the old machine before imaging (like the SATA drivers), but this may fail, particularly if the chipsets are different.
0
 
h11Commented:
Have you tried turning off the sata drive in the Bios?  This may fix your problem.  Depending on your Bios and type of computer you can usally disable it or turn it off.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Swamp_ThingAuthor Commented:
Answered question myself:
  Within the BIOS there was a setting called "IDE Drive UDMA" with a DISABLE and ENABLE options.  The setting was currently at DISABLE and once I changed it to ENABLE everything worked.
0
 
h11Commented:
is that not more or less what I said look into the bios and enable or disable this setting
0
 
Swamp_ThingAuthor Commented:
This answer didn't exactly solve the problem but you mentioned entering the BIOS to make changes so I gave you the points.  What solved my problem wasn't due to the fact that I disabled SATA control like you said but it was because I turned "IDE Drive UDMA" functionality to the ENABLED state.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now