?
Solved

Remote Web Workplace on SBS 2003

Posted on 2007-11-29
15
Medium Priority
?
2,286 Views
Last Modified: 2009-08-02
When trying to login to a client computer in RWW, I choose the computer I want, Click Connect and the IE page goes to Done and the window goes blank never taking me to the computer to login. I have to click the link for Main Menu.  This happens from more than 1 computer.  Is there a setting with RWW that would cause this?  When I try to access it with Mozilla Firefox I get the following error:

This portion of the Remote Web Workplace requires the Microsoft Remote Desktop Active X Control.  Your browsers security settings may be preventing you from downloading Active X controls.  Adjust these settings and try to connect again.
0
Comment
Question by:pcmb
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +4
15 Comments
 
LVL 15

Expert Comment

by:Dave_AND
ID: 20373723
You must make sure you have 444 and 4125 opened to your server from your firewall, and you cannot use firefox to access RWW.
0
 
LVL 1

Author Comment

by:pcmb
ID: 20374048
I opened 444 (UDP and TCP)  and 4125 (UDP and TCP) and I have the same result that I described in my initial question.
0
 
LVL 19

Expert Comment

by:Stephen Manderson
ID: 20374197
you need port 3389 for the actual connection to the desktop.

Below are the following ports required for SBS
443 = https
444 = sharepoint services (companyweb) if required.
4125 = RWW
1723 = VPN if required.
3389 = Remote Desktop

Regards
Steve
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Expert Comment

by:klaus1013
ID: 20374267
Are you connecting from outside or inside the network? If it is from outside, can you test from inside? That would confirm if the problem is with the firewall settings or your browser.

Klaus
0
 
LVL 15

Expert Comment

by:Dave_AND
ID: 20374359
You dont actually need 3389 unless you want to connect to the server's TS session. 4125 should be enough for the connection. (scrap the 444 i was having  "moment")

and yes, please can you check using klaus1013's comment, so we can rule out 1 or the other.
0
 
LVL 19

Expert Comment

by:Stephen Manderson
ID: 20374901
3389 could possibly be needed as first line states connecting to the client computer, then again might just be reading questions wrong as usual :-P
0
 
LVL 1

Author Comment

by:pcmb
ID: 20375137
Yes, I am able to connect internally.  I was prompted to install Active X when accessing it internally and when I did it took me to the remote desktop login prompt for the server.  It worked internally.  I wonder if the firewall is blocking that Active X prompt to install somehow.  They have a Verizon FIOS firewall/router.
0
 
LVL 15

Expert Comment

by:Dave_AND
ID: 20375700
Ok, so it works internaly.. good, one less thing to worry about. Maybe you have a block on the out bound traffic on those ports?

Or maybe you need to install the active X bit to the browser outside the network.. have you tryed this on a diff PC with IE 6 or something? i know IE7 can be a pain with this.
0
 
LVL 1

Author Comment

by:pcmb
ID: 20375868
There are 3 "General Security" settings for this device and it is set to the lowest allowing all outbound traffic.  That device has to be blocking the Active X controls somehow.  As I stated in my initial comment IE does nothing when you try to connect to the desired computer and Firefox gets an error stating what I listed in my earlier comment.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 20383364
You can't use Firefox with RWW, as was already stated above.

As Dave_AND suggested, have you tried connecting from a different machine with IE in order to isolate this issue to the specific machine you are trying to connect with?

Jeff
TechSoEasy
0
 
LVL 1

Author Comment

by:pcmb
ID: 20385513
As I mentioned above, RWW works internally to access client and server computers but not externally.  Externally, I can login to RWW and get to the main menu but when I go to connect to computers it does nothing.  I can see the main menu and the RDP login for the computer I am trying to access never even loads.
This server is on a network that has a Verizon FIOS router as the gateway performing NAT.  After looking at the log I noticed this error that may be related to this issue:

Event Type:  Blocked - NAT out failed
Details:         First packet in connection is not a SYN packet : TCP 192.168.1.1:80 > 192.168.1.47:47992

192.168.1.1 is obviously the gateway
192.168.1.47 is the SBS server where RWW is hosted.    
0
 
LVL 1

Author Comment

by:pcmb
ID: 20385599
Jeff,
I have tried to connect to RWW of this environment from several computers outside the network.  I have been able to login externally and internally to the Main Menu but not able to connect any client or server computers externally.  Once I was able to connect to client and server computers internally I thought it has to be some traffic being blocked by that FIOS router/firewall.
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 1000 total points
ID: 20386442
If you are unable to connect externally then you don't have port 4125 forwarded to 192.168.1.47

(You also need port 443 as well since this goes over an SSL connection)

Jeff
TechSoEasy
0
 

Expert Comment

by:avrtek
ID: 20634638
I'm still experiencing the identical problem: There are no difficulties internally accessing the RWW, but from outside I get the login page, anda vbscript stating connection error after I've logged in. THe Verizon FIOS router has error messages stating

Event Type:  Blocked - NAT out failed
Details:         First packet in connection is not a SYN packet : TCP 192.168.1.1:1 > 192.168.1.103:47992

All ports indicated are opened including 3389,443,444,4125, and 1723.
0
 
LVL 1

Expert Comment

by:baz_can_fix_it
ID: 22210427
Hi,

Some routers require you to Save & Reboot before it takes effect just beware of that...
Also some ISP's block these ports from their end also beware of that...

Cheers
0

Featured Post

Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had to do a bit of research to find the answer to this question so I thought I'd share my results.  Due to our outdated mainframe systems, we need to downgrade IE9 to IE8 in order to stay compatible.  We also needed to downgrade Java.  In order to…
I recently found myself in a Corporate Situation where the client had requested blocking access to any and all websites except his own Domain? Easy? I am sure this would be your answer but their requirement was, this has to be done without using…
This Micro Tutorial will demonstrate how nuggets on the Web are formatted by using Chrome Developer Tools. These tools would not only view the site's CSS but it can also modify it and save the CSS to use on your own site.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question