Configuring Microsoft ISA 2006 Web Proxy to use port 80 instead of 8080

I would to like to configure my MS ISA 2006 web proxy to port 80 instead of the default port of 8080. I have changed the port number to 80 in the Web proxy tab on my Internal Networks and clicked Apply.  If I then change the proxy address on IE on a client machine from port 8080 to 80, then IE doesn't work. Am I missing a step?
mandaljAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Keith AlabasterConnect With a Mentor Enterprise ArchitectCommented:
That would be fine - it is the same thing really as you have moved the service on the ISA server to another port, thereby freeing up port 80 but it begs the bquestion of why do you have IIS on the ISA server anyway? ISA does not need it.
0
 
Keith AlabasterEnterprise ArchitectCommented:
Open the ISA gui
Select configuration - networks - internal - properties - select the web proxy tab
Change the port from the default 8080 to 80.

Save the policy
Amend your ie browsers proxy settings to use port 80

That should be it - no you are not missing a step
0
 
Keith AlabasterEnterprise ArchitectCommented:
What happens after the change? What error?

Open the isa gui - select monitoring - logging - click start query. What meesages do you get in the log?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
mandaljAuthor Commented:
The Monitoring shows that port 80 is being denied by the default policy
0
 
mandaljAuthor Commented:
There are no errors, the web page of the URL is not displayed
0
 
mandaljAuthor Commented:
If I change the web proxy to any other port setting say 85, then it works. Websense Enterprise is configured to monitor content on another machine. Is there a rule ordering issue?
0
 
Keith AlabasterEnterprise ArchitectCommented:
1 of 2 things then.

First, ISA does not believe that port 80 traffic is allowed to pass from the internal & local host to external?
second, are you running IIS on the ISA server itself?

No, there is not a rule issue on this - if there was  then the other ports would not operate either that you set the proxy to. Also, the denied message would give a rule name in the list, it would not have dropped down to the default rule at the bottom.

Make sure you have .net 1.1 on the ISA box
Run up the ISA bpa
http://www.microsoft.com/downloads/details.aspx?FamilyId=D22EC2B9-4CD3-4BB6-91EC-0829E5F84063&displaylang=en


0
 
mandaljAuthor Commented:
Yes, I run IIS, do I need to change the default web site port, it is currently 80?

And I have run ISA Bpa - 1 critical error - The External network is used in single network card sceniro.
0
 
Keith AlabasterEnterprise ArchitectCommented:
That should be OK assuning you used the single nic network template wizard when you installed ISA.

It seems the issue you have is that ISA is already using port 80 (for the IIS service) therefore it cannot use this for the web proxy service also. In theory it should be OK but in practice i have seen it once or twice before causing problems.
Yes, I would put it back to 8080, the default.

Keith
0
 
mandaljAuthor Commented:
I amended the IIS Default Web site port to  85 and then changed the web proxy to 80 and it seems to work - is a viable solution?
0
 
mandaljAuthor Commented:
Thanks, I will raise the question with guy who installed it.  Many thanks for all your help.
0
 
Keith AlabasterEnterprise ArchitectCommented:
Welcome :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.