Solved

Creating a Point-to-Point T1 connection between Cisco 2620 and Adtran 3205 Routers

Posted on 2007-11-29
25
621 Views
Last Modified: 2012-07-23
I am trying to put in a point to point connection between a cisco 2620 and an adtran 3205 (because they are what I had lying around).  

Can someone give me what the config should look like?  

My network is like the following:
fastethernet1/1 10.0.10.x---Cisco2620---serial0/0 192.168.62.1 -----------t1---------------Unconfigured Adtran

Thanks! - I am supposed to have this up and running today!!!
0
Comment
Question by:ptinc
  • 12
  • 12
25 Comments
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20376172
Both Adrans need to be configured for 24 channels, B8ZS/ESF, 64k per channel.

One Adtran needs clock source line (network), the other Adtran needs clock source internal.

Both routers need to be properly IP addressed and encapsulation specified if they are not both Cisco.
0
 

Author Comment

by:ptinc
ID: 20382227
Thanks Jesper.

I can now ping both routers (ti) sides of each other.  But no more.  Here are my configurations on the routers:

Cisco 2620 (Main Office)
Using 638 out of 29688 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ptinc2620
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 ip address 172.23.9.3 255.255.0.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.10.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 service-module t1 remote-alarm-enable
!
ip default-gateway 172.23.2.240
ip classless
ip route 172.23.0.0 255.255.0.0 Serial0/0
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

Adtran 3205 (Remote Office)
Using 855 bytes

!
!
enable password password
!
ip subnet-zero
ip classless
ip default-gateway 172.23.2.240
ip routing
!
event-history on
no logging forwarding
logging forwarding priority-level info
no logging email
!
ip policy-timeout tcp all-ports 600
ip policy-timeout udp all-ports 60
ip policy-timeout icmp 60
!
!
!
interface eth 0/1
  speed auto
  ip address  172.23.7.4  255.255.0.0
  no shutdown
!
interface t1 1/1
  clock source internal
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface ppp 1
  ip address  192.168.10.2  255.255.255.0
  no shutdown
  cross-connect 1 t1 1/1 1 ppp 1
!
ip route 172.23.0.0 255.255.0.0 eth 0/1
!
no ip snmp agent
!
!
!
line con 0
  no login
!
line telnet 0
  login
line telnet 1
  login
line telnet 2
  login
line telnet 3
  login
line telnet 4
  login
!
end


Any Help would be great!
0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20382331
You have the same LAN subnet at both ends.

Cisco:

interface FastEthernet0/0
 ip address 172.23.9.3 255.255.255.0

no ip route 172.23.0.0 255.255.0.0 Serial0/0
ip route 172.23.7.0 255.255.255.0 192.168.10.2

Adtran:

interface eth 0/1
  ip address  172.23.7.4  255.255.255.0

no ip route 172.23.0.0 255.255.0.0 eth 0/1
ip route 172.23.9.0 255.255.255.0 192.168.10.1


If you want more than 256 hosts at each end, we can do that by assigning one end the 172.24 network at one end.
0
 

Author Comment

by:ptinc
ID: 20382377
The 172.24 sounds like a better solution to me.

What would the Adtran side look like with a new 24 network?  Mainly with the default gateway and such?

I am brand new to router work - sorry if these questions are dumb!
0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20382441
This is what the configuration would look like if you want a larger number of hosts at each end:

Cisco:

interface FastEthernet0/0
 ip address 172.23.9.3 255.255.0.0

no ip route 172.23.0.0 255.255.0.0 Serial0/0
ip route 172.24.0.0 255.255.0.0 192.168.10.2

Adtran:

interface eth 0/1
  ip address  172.24.7.4  255.255.0.0

no ip route 172.23.0.0 255.255.0.0 eth 0/1
ip route 172.23.0.0 255.255.0.0 192.168.10.1
0
 

Author Comment

by:ptinc
ID: 20382635
I am making headway - thanks for your help!  

I can now from both routers ping the the ethernet side of the other router.

However - from the Cisco - I can ping my entire LAN behind the ethernet side.  From the Adtran I cannot ping what is behind it on the LAN at the remote office.  

Thanks
0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20382754
On the Adtran side:

1) have you changed the IPs of the machines with the correct netmask
2) have you changed the default gateway of these machines?
0
 

Author Comment

by:ptinc
ID: 20382757
Just in trying I added on the ADTRAN:

ip route 172.24.0.0 255.255.0.0 eth 0/1

and now i can ping what is behind the adtran on the remote office side.  

I still cannot ping any remote office equipment from the main office router or visa versa.  
0
 

Author Comment

by:ptinc
ID: 20382799
yes - i changed default gateway on machines to 172.24.2.240
i also changed this on the adtran router
0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20383041
This is wrong.  You shouldn't have to specify a route statement to a directly connected network.

 no ip route 172.24.0.0 255.255.0.0 eth 0/1

From a machine on the 17.23 network (not the router unless you do an advanced ping), can you ping the ethernet interface of the adtran?
0
 

Author Comment

by:ptinc
ID: 20383149
ok took that routing out.  

The machine on the 172.23 network cannot ping the ethernet interface of the adtran.  

0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20383233
On the Adtran, can you look at the routing table and post it?

Same for the cisco.

On the Cisco, the command is -> sh ip route

And post the results.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 28

Expert Comment

by:Jan Springer
ID: 20383264
I just noticed this on the adtran (change it to 192.168.10.1)

ip default-gateway 172.23.2.240

-> ip default-gateway 192.168.10.1
0
 

Author Comment

by:ptinc
ID: 20383426
OK Changed the gateway on the adtran.  Here is the routing tables of both:

cisco:


Gateway of last resort is not set

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.2/32 is directly connected, Serial0/0
C       192.168.10.0/24 is directly connected, Serial0/0
C    172.23.0.0/16 is directly connected, FastEthernet0/0
S    172.24.0.0/16 [1/0] via 192.168.10.2


adtran:

DESTINATION      MASK             GATEWAY          INTERFACE  SOURCE     HOPS
192.168.10.0     255.255.255.0    0.0.0.0          ppp 1      Connected     0
172.24.0.0       255.255.0.0      0.0.0.0          eth 0/1    Connected     0
172.23.0.0       255.255.0.0      192.168.10.1     ppp 1      Static        1


0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20383490
First:

From a PC on the Cisco network, run a tracert to an IP on the Adtran network.

Second:

Add a default route on both machines each pointing to the other
  Cisco example -> ip route 0.0.0.0 0.0.0.0.0 192.168.10.2
0
 

Author Comment

by:ptinc
ID: 20383536
Here is the tracert:

Tracing route to 172.24.10.4 over a maximum of 30 hops

  1     *        *        *     Request timed out.
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.
  5     *     ^C
.
Also added the default routing on both:

ip route 0.0.0.0 0.0.0.0 192.168.10.1 ----> Adtran
ip route 0.0.0.0 0.0.0.0 192.168.10.2 ----> Cisco

0
 

Author Comment

by:ptinc
ID: 20383540
Same response on tracert after adding the default routings
0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20383578
I would suspect that the default gateway in the PC is incorrect.  Can  you verify that it points to the IP address of its local ethernet interface on the router?
0
 

Author Comment

by:ptinc
ID: 20383674
OK - I did that on the adtran side.  Changed the default gateway to 172.24.10.1 and here is what i get for two trace routes - one to the ethernet interface of the Cisco, and one to a machine behind the cisco on the lan:


C:\Documents and Settings\admin>tracert 172.23.9.3

Tracing route to 172.23.9.3 over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms  172.24.10.1
  2     2 ms     2 ms     2 ms  172.23.9.3

Trace complete.

C:\Documents and Settings\admin>tracert 172.23.11.2

Tracing route to 172.23.9.3 over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms  172.24.10.1
  2     2 ms     2 ms     2 ms  192.168.10.1
  3     *       *          *     Request timed out.
  4  ^C


A bigger question on this I guess is if I change the gateway on the main site to the ethernet interface of this cisco router - what happens to my connections to the internet and things like that which go through the gateway of 172.23.2.240 (to our firewall and other routers and such)???  

0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20383724
Your default route (gateway) always points *upstream*.  

Is 172.23.11.2 a valid IP?  Can you ping that IP from the Cisco router?  Because the packet gets to the Cisco router, either is isn't a valid IP on the 172.23 net or the PC on the 172.23 net is not configured properly (gateway, netmask).
0
 

Author Comment

by:ptinc
ID: 20383771
yes from the cisco router i can ping 11.2 address.

When I change the default gateway on 11.2 address to 172.23.9.3 instead of 172.23.2.240 - i can do all of the following:
from 11.2 -> ping 172.23.9.3
from 11.2 -> ping 172.24.10.1 (address assigned to ethernet interface of adtran)
from 11.2 -> ping 172.24.10.4 (machine on back side of adtran)
from 172.24.10.4 -> ping 172.23.11.2
I cannot access internet when connected with 172.23.9.3 gateway though

When I change the gateway back to 172.23.2.240 - i can obviously go to internet, but nothing works again.  

0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20383814
What interface / IP is the internet?

Because I see only one connection between the two routers?  Is your internet connection on the ethernet interface?  If so, your default route on the Cisco router should point to the *IP Address* of the ethernet gateway to the internet.

There is a 3rd piece of equipment in play that I'm not aware of :)

So, make the default route on the PCs point to the cisco.

On the cisco, remove the default route to 192.168.10.2 and make a default route ->
  ip route 0.0.0.0 0.0.0.0 172.23.2.240

if 172.123.2.240 is the ethernet IP address of this 3rd piece of equipment that connects to your internet.
0
 

Author Comment

by:ptinc
ID: 20383908
I think that this is correct :).  I should have explained this from the beginning.  

This cisco will be behind our firewall.  All machines currently point to the firewall as their default gateway.  The firewall then determines what route to send through.

I may not be explaining this very well.  

I will try what you said and let you know
0
 
LVL 28

Accepted Solution

by:
Jan Springer earned 500 total points
ID: 20383960
Ok.  :)

1) The default route of the PCs should be the firewall
2) The firewall should have a route statement for 172.24.0.0 pointing to the ethernet IP of the cisco router (please don't point it to an interface name)
3) The adtran should have a default route to 192.168.10.1
4) The adtran PCs should have a default route to the adtran ethernet IP address.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now