Solved

Configuring Trunking between two switches.

Posted on 2007-11-29
7
1,443 Views
Last Modified: 2012-05-01
I am trying to configure a port on my Layer3 2600 procurve switch to trunk to a layer2 Cisco 2950 for my Vlan2 which is the Vlan that the phone system rides on. The configurations are as follows:

HP 2600:
Running configuration:


; J8762A Configuration Editor; Created on release #H.10.38


hostname "VLANSWITCH_Russel_13156"

interface 1

   name "Data_Only"

   speed-duplex 100-full

exit

interface 2

   name "Data_Only"

   speed-duplex 100-full

exit

interface 3

   name "Data_Only"

   speed-duplex 100-full

exit

interface 4

   name "Data_Only"

   speed-duplex 100-full

exit

interface 7

name "Voice_Only"

   qos priority 6

exit

interface 8

   name "SpectraLink_SVP_Server"

   qos priority 6

exit

interface 9

   name "Fiber_to_BMW_Bldg"

exit

ip default-gateway 10.217.129.254

no ip directed-broadcast

snmp-server community "public" Unrestricted

snmp-server host 10.217.129.54 "public"

vlan 1

   name "Data-LAN"

   untagged 1-6,9

   ip address 10.217.129.144 255.255.255.0

   tagged 7-8

   exit

vlan 2

   name "Voice-LAN"

   untagged 7-8

ip address 10.10.1.8 255.255.255.0

   qos priority 6

   tagged 5-6,9

   exit


The cisco 2950:
ersion 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RusselMazdaSW-1
!
enable secret 5 $1$AgtN$thQB3MhZ9x.FCglX7heUu.
enable password root
!
ip subnet-zero
!
no ip domain-lookup
vtp domain russelvlan
vtp mode transparent
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 2
!
!
!
!
vlan 2
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 speed 100
 duplex full
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 speed 100
 duplex full
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
 speed 100
 duplex full
!
interface FastEthernet0/21
!
interface FastEthernet0/22
 description Fiber Tranciever from Mazda to BodyShop
 speed 10
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport voice vlan untagged
!
interface Vlan1
 ip address 10.217.129.80 255.255.255.0
 no ip route-cache
!
interface Vlan2
 ip address 10.10.1.60 255.255.255.0
 no ip route-cache
 shutdown
!
ip default-gateway 10.217.129.202
ip http server
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 130 deny   tcp any any eq 4444
access-list 130 deny   udp any any eq tftp
access-list 130 deny   udp any any eq 8998
access-list 130 deny   tcp any any eq 707
access-list 130 deny   tcp any any eq 135
access-list 130 deny   udp any any eq 135
access-list 130 deny   tcp any any eq 137
access-list 130 deny   udp any any eq netbios-ns
access-list 130 deny   udp any any eq netbios-dgm
access-list 130 deny   tcp any any eq 138
access-list 130 deny   tcp any any eq 139

I want port 7 on the procurve to connect to port 24 on the Cisco and be able to pass vlan2 traffic
access-list 130 deny   udp any any eq netbios-ss
access-list 130 deny   tcp any any eq 193
access-list 130 deny   tcp any any eq 445
access-list 130 deny   tcp any any eq 593

0
Comment
Question by:Russelauto
  • 4
  • 3
7 Comments
 
LVL 21

Expert Comment

by:from_exp
ID: 20380245
you can say:
conf t
int fa0/24
no switchport voice vlan untagged
sw mo ac
sw ac vl 2

after that only vlan 2 will pass through procurve to cisco

if you need to transfer data trafic via the same port:
conf t
int fa0/24
no switchport voice vlan untagged
sw mo tr
sw tr na vl 2
sw tr al vl 1,2


0
 

Author Comment

by:Russelauto
ID: 20420278
I tried that but VLAN 2 on the Cisco shuts down and if I enable it Vlan 1 shuts down.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20420487
sorry, change for the fa0/24

sw tr na vl 2 - > sw tr na vl 99
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:Russelauto
ID: 20422915
I am not sure why but Vlan1 still goes to shutdown. Why does that happen? Is there something else that I need to configure?
0
 

Author Comment

by:Russelauto
ID: 20423500
I think that I might have figured it out. The cisco is a layer 2 switch that only supports one managment Vlan interface at a time. Is this correct?
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20423907
yes it is correct, but this corresponds only to ip interfases - on L2 switches you can have only one ip interface on one vlan
0
 
LVL 21

Accepted Solution

by:
from_exp earned 500 total points
ID: 20423953
i have double checked your initial the configuration

if you configure cisco with this settings you will be able to see vlan 2 from procurve via port7
conf t
int fa0/24
no switchport voice vlan untagged
sw mo ac
sw ac vl 2
exit

to check if the vlan is working type in cisco
show mac-address int fa0/24
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my office we had 10 Cisco 7940G IP phones that were useless as they were showing PROTOCOL APPLICATION INVALID when started. I searched through Google and worked for a week continuously on those phones, and finally got them working. This is a di…
I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now