How to enable hardware RAID after Windows Server 2003 SBS has already been loaded and configured

I have a Dell PowerEdge SC420 with hardware RAID (not enabled yet) running Windows Server 2003 SBS. The server acts as domain controller.

My goal is to enable RAID 1.

I enabled RAID via BIOS and rebooted. RAID BIOS Controller messages showed up indicating two healthy disks. Booting continued to show Windows Server 2003 starting up, then system immediately rebooted. This continued in endless cycle until I disabled RAID in BIOS.

Any ideas on how to enable hardware RAID after SBS has already been installed?
HairlipDog58Asked:
Who is Participating?
 
PUNKYConnect With a Mentor Commented:
In windows environment, install raid controller drivers. Restart system, access bios, change boot order, and then enable raid.
0
 
McKnifeCommented:
Install the raid driver. Some controllers will have a raid and a non-raid driver
In any case: backup/image your system first.
0
 
HairlipDog58Author Commented:
I'm able to get into the BIOS and enable RAID, then a re-boot proceeds to show the Adaptec RAID configuration with both drives listed as healthy.

Are you suggesting that I need to Install a RAID driver for Windows Server?

0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 
McKnifeCommented:
Yes
0
 
HairlipDog58Author Commented:
Unless I'm missing something, that does not seem possible.

When the Raid driver is enabled in BIOS, Windows does not boot, hence no way to install driver.

Do you have a suggestion on how to install Windows RAID driver?
0
 
Handy HolderConnect With a Mentor Saggar maker's bottom knockerCommented:
Or boot from CD, F6 to install 3rd party drivers amd then go through repair process.
0
All Courses

From novice to tech pro — start learning today.