Solved

Could not start the installler service on the Local Computer.

Posted on 2007-11-30
2
426 Views
Last Modified: 2013-12-05
I'm not sure what caused this, however I've been trying to install a program.  The error message was something like windows installer cannot be accessed.  When I go into Admin Tools -> Services, I noticed that the service is not started but set to automatic.  When I try to manually start it I get...  

Could not start the Windows Installer service on the Local Computer.
Error 997:  Overlapped I/O operation is in progress.
0
Comment
Question by:fferrel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 18

Accepted Solution

by:
Andrej Pirman earned 500 total points
ID: 20381879
Is this a workstation or server? Domain controller?

It might be some 3rd party backup software/agent, which prevents recreation of some system resource. Here is a debate on same subject:
http://www.pcreview.co.uk/forums/thread-2108280.php

Maybe the problem can be solved by reinstalling Windows Installer. If this does not help, here is a great utility to reinstall and repair many problems, and repairing problems with Windows Installer is one of them:
http://www.litepc.com/xplite.html
0
 
LVL 1

Author Comment

by:fferrel
ID: 20382776
This is a Domain Controller.  

I don't believe any software has been installed for quite some time.  Windows Updates, Anti-virus, and maybe a management program.

I do not see the option for Windows Installer Service in XP Lite.  Perhaps because it is not running?  or because I am only using the trial version?
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Boot PC and press F10, select storage options and change the compatibility from “AHCI” to “IDE”, save and exit 2. Boot PC and press F12 3. Upon PXE display of searching for DHCP server, press Pause break to obtain MAC address 3. Open Configu…
Problem Description: Actually I found the below issue with some customers after migration from SMS 2003 to SCCM 2007 and epically if they change site code, some clients may appear in the console with old site code, plus old sites still appearing …
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question