Solved

I have ssh but not sshfs

Posted on 2007-11-30
5
1,001 Views
Last Modified: 2013-12-16
I'm able of accessing my server by ssh but not by sshfs.

Am I missing something in configuration?

I get this error:

$ sudo sshfs -odebug,sshfs_debug,loglevel=debug oleber@myserver.pt:/home/oleber my_path | more
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to myserver.pt [10.134.15.114] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.8.1p1 Debian-8.sarge.4
debug1: match: OpenSSH_3.8.1p1 Debian-8.sarge.4 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.6p1 Debian-5build1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'myserver.pt' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: No more authentication methods to try.
Permission denied (publickey,keyboard-interactive).
read: Connection reset by peer
0
Comment
Question by:oleber
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 10

Author Comment

by:oleber
ID: 20382281
Maybe important, I'm using 'dsa' to do the connection
0
 
LVL 14

Expert Comment

by:arrkerr1024
ID: 20382306
Did it ever prompt  you for your password?  It says that it can do keyboard-interactive, but does it just die or is that maybe just missing from the capture?

When you ssh to the server, does it ask  you for a password, or does it use shared-key authentication?

Have you tried shared-key for this (run "ssh-keygen -t dsa" on the guest, then copy ".ssh/id_dsa" to ".ssh/authorized_keys" on the server)?
0
 
LVL 10

Author Comment

by:oleber
ID: 20382513
I did 'ssh-keygen -t dsa' and send the public to the administrator. He did something, and now I have ssh.

This key have a passphrase

The 'ssh vm-pesquisa.labs.sapo.pt' asks for the passphrase

but 'sudo sshfs oleber@myserver.pt:/home/oleber my_path' don't asks for it.

I have no configuration experience, so please help.

0
 
LVL 14

Accepted Solution

by:
arrkerr1024 earned 125 total points
ID: 20382953
Oh, gotcha.  You're using shared key authentication, so it is looking for your part of the key in your home directory.  The problem is, when you run "sudo", you are running the command as root, not as yourself, so it is looking in root's home directory and not yours.  Just take off the sudo, you shouldn't need to run the command as root.

You may need to "chown oleber mountpoint" if you have a permissions problem, and depending on the distro you may need to add your user account to a group.  But you shouldn't need to be root.
0
 
LVL 10

Author Comment

by:oleber
ID: 20382996
This is the solution of a day of job:
sudo addgroup oleber fuse
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question