Solved

Need help with Cisco 1751 router and Cable Modem setup, cant access internet

Posted on 2007-11-30
9
675 Views
Last Modified: 2013-12-14
I need some help with my home network setup.  I have a Cisco 1751 router and 2950 switch.  My internet is provided by Timewarner cable.  Below is the setup:

The cable modem is directly connected to the 1751 WIC 1ENET card and has been assigned a dhcp addr of 10.114.184.83 from the cable modem.  My 2950 is directly connected to the 1751 Fast Ethernet port (fa0/0) with a static ip of 192.168.100.3.  My workstation is connected to the 2950 switch, with an ip of 192.168.100.6 and default gateway of 192.168.100.3 and I can ping both 192.168.100.3 and 10.114.184.83 interfaces, but I cant access the internet.  

Whats weird is from the 10.114.184.83 interface I can ping www.timewarnersandieogo.com but thats it.  The running config is below:

 Building configuration...

Current configuration : 864 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname rscapp_1751
!
enable password firewall
!
memory-size iomem 20
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
ip name-server 66.75.164.90
ip name-server 66.75.164.89
ip name-server 67.102.133.222
!
!
!
!
interface Ethernet0/0
 ip address dhcp
 ip nat outside
 full-duplex
!
interface FastEthernet0/0
 ip address 192.168.100.3 255.255.255.0
 ip nat inside
 speed auto
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.100.0
!
ip nat inside source list 102 interface Ethernet0/0 overload
ip classless
no ip http server
ip pim bidir-enable
!
access-list 102 permit ip 192.168.100.0 0.0.0.255 any
!
!
line con 0
line aux 0
line vty 0 4

Could this be a DNS issue on the workstation.  I am using a public DNS server in the TCP\IP properties and the router IP also.  I have a DNS server in my network but I dont know if its working correctly.

If any additional information is needed please let me know.

thanks
0
Comment
Question by:rscapp
9 Comments
 
LVL 12

Expert Comment

by:bhnmi
ID: 20383195
Need to add a gateway of last resort. I think, let me check I have never done it with my public interface set to DHCP.
0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20384041
No, need a default route.

On the router -> ip route 0.0.0.0 0.0.0.0 <ip.other.end.of cable.connection>

Your ISP should either be providing a default route (check with "show ip route") or ask them what it is so that you can manually configure it.
0
 
LVL 14

Expert Comment

by:bfason
ID: 20384104
bhnmi is correct in that you need a gateway of last resort but using dhcp you will have to set it to an interface.

Ip route 0.0.0.0 0.0.0.0 e0/0

Jesper, your comment is setting a gateway of last resort.

Hope this helps
B
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 28

Expert Comment

by:Jan Springer
ID: 20384178
I've had to help too many people that use the incorrect statement.  The correct statement is "default route".

ip default-gateway <ip.address>

is different from

ip route 0.0.0.0 0.0.0.0 <ip.address>
0
 

Author Comment

by:rscapp
ID: 20384893
Sorry, but I am still confused.  See the output below.  It appears the cable modem ip is 10.113.160.1 which I set as the Gateway of last resort.  However I see E0/0 directly connected to 10.113.160.0, so is that the IP I should be using.  With this current config, I can ping www.timewarnersandiego.com, but not www.cnn.com.  I still cant get out to the internet from the workstation.

rscapp_1751#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter ar
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.113.160.1 to network 0.0.0.0

     10.0.0.0/19 is subnetted, 1 subnets
C       10.113.160.0 is directly connected, Ethernet0/0
C    192.168.100.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [254/0] via 10.113.160.1
rscapp_1751#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.100.6           2   001a.9292.7d93  ARPA   FastEthernet0/0
Internet  192.168.100.3           -   0009.435f.c2ab  ARPA   FastEthernet0/0
Internet  10.113.172.15           -   0004.dc0c.b539  ARPA   Ethernet0/0
Internet  10.113.160.1            2   0030.b8c9.65b0  ARPA   Ethernet0/0
rscapp_1751#ping www.timewarnersandiego.com

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 24.94.1.12, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/12 ms
rscapp_1751#ping www.cnn.com
Translating "www.cnn.com"...domain server (66.75.164.90) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 64.236.91.24, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
rscapp_1751#ping 64.236.91.24

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 64.236.91.24, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
0
 
LVL 28

Expert Comment

by:Jan Springer
ID: 20386149
That means nothing :)  That IP does not allow ICMP.
0
 

Author Comment

by:rscapp
ID: 20386803
So do you see anything wrong in my running config?  I still cant get a any website, even timewarnersandiego.com.  Could it be something with DNS?  At this point I have no idea what to do next.
0
 
LVL 28

Accepted Solution

by:
Jan Springer earned 500 total points
ID: 20388586
I'd like you to do a few tasks in tandem

1) do an nslookup on a website
2) ping the website by host.domain.com
3) in your browser, go to that website
4) on the router, do a # sh ip nat trans
    and post the translation table
5) repeat 1-4 for each website, I've included locations that are pingable
    websites to hit ->  www.yahoo.com
                                    www.chicagotribune.com
                                    www.cindysthrows.com
                                    www.experts-exchange.com

The problem could be that Time Warner is not translating your external private IP but allows its transit within its network.
0
 

Author Closing Comment

by:rscapp
ID: 31411944
great, thanks for your help.  I had the wrong default gateway.  I did a direct connect to the cable modem, then took the IP and assigned it to e0/0, then added the ip route command, unpluged the cable modem, waited 30sec pluged back in and connected the router, now i have internet.  thanks again.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question