Solved

How do I stop Lotus Notes downloading Attachments twice.

Posted on 2007-11-30
7
478 Views
Last Modified: 2013-12-18
Hi,
In Lotus Notes I have an email that has an attachment and when I click to open the message body it downloads the attachment.   The problem I have is that when you then go to open the attachment it downloads it again.  My knowledge of Notes is limited but I can't believe this is how it works so does anyone know how I can just download the body on the original request and only download the attachment if I need to?
Thanks in advance
0
Comment
Question by:NortonN
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 63

Expert Comment

by:SysExpert
ID: 20389833
Normally you open a doc, an either view or launch the attachment.
The other option is to save it locally.


I would lokk into getting a local replica of your Notes database so that everything is avalable locally also, to keep the download times to a minimum.


I hope this helps !
0
 

Author Comment

by:NortonN
ID: 20392709
Thanks for the response but I think I have not explained my problem correctly
I am on a PC in say Newcastle and my Notes server is in say Paris, around 50ms away, so download times are critical to as I can see delays in the network.
In Lotus Notes I can see say 2 emails.  I click on the first email that has 50 words in the body of the email and it takes say 10 seconds to open.  I click on the second email that has 50 words in the body of the email but also has a 2Mb attachment and this takes say 100 seconds to open the body.  When the email body opens and I can see the attachment I then click on the attachment to open it and it takes say 90 seconds to open.
From this I presume the attachment gets downloaded twice which when I am some distance from the server causes me problems.  I was hoping there is a setting in the Notes client setup where you say "On initial opening of email do not download any attachment" so that when you then go into email body you can then decide to download or not.  In any event it seems odd to download the attachment twice.

Thanks in advance
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 20393607
OK.

That is why a local replica would help resolve your issues.

See the Help on how to create a local replica, and then open just the local replica, not the one on the server.

Also set the replication schedule to be fast enough to catch mail in a reasonable time.

Most maangers I know use a 15 minute schedule, while other users do 30 -- 60 minutes.


I hope this helps !
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:NortonN
ID: 20394591
Many thanks for your help.

I will llook at setting up a replica as sugested.

Regards
0
 
LVL 31

Accepted Solution

by:
qwaletee earned 250 total points
ID: 20399919
It doesn't download the attachment twice. When it asks teh server for the message, it gets the message MINUS the attachment. That initial 100 seconds must be due to other information on the message.  It could be a very long message, or contain graphics (the attachment icon is a small graphic that REPRESENTS the attachment, but is not the attachment itself, but as a graphic, it does occupy a small amount of space).

You can get a rough idea of the size of the message sans attachment, open document properties (Edit -> Properties). At the bottom it says Size: ###### (bytes). That is the overall size of the message including attchments. Now click the second tab. On the left, scroll up to the top, and find the entry for $File, and click $File. On the right, scroll down about 2-3 lines and you will see "object length: #######" This is the length of the file itself. Subtract the object length number from the number on the first tab. That will be the size of the message without attachments that downloads when you open the message.

Note that if you use a local replica, it will normally "silently" download both the message and its attachments before even displaying the message in your inbox. The big advantages are really in that the system is more responsive to your requests (instant opening of message, even though the message to longer to be available to start with). It also helps if you freuqently open messages more than once, since there is no network hit for opening it on the local.  If you opened it off the server, you get that network hit each and every time you open the message.
0
 

Expert Comment

by:Nico_R
ID: 21804197
I actually do experience the same issue as NortonN with my lotus notes client 6.5 and I am working on a local network.
I have been living with this issue for a couple of years already but today I got an annoying example.
I received an e-mail with an attachment of 5 MB. Lotus Notes clearly downloads more than the mail without attachment. When I open this mail, it takes few seconds to open it whereas an e-mail without attachment is opened immediately.
The odd thing is that a colleague of mine received the same e-mail and when he opens it, it happens without delay.
I once asked my Notes administrator and he told me that it seem to happen when we once change the Internet Browser settings in the "Location Preferences", which is what I once did a long time ago. Although I changed back to the original settings, it did not help. E-Mails with attachment will always take longer to open than e-mails without attachment. My Notes administrator could not help me either.

I took a look to the properties of my e-mail.
Document size: 5.191.647 (bytes)
I found 79 entries of $FILE: the first 78 entries have object length 65535 and the last one has object length 822.
If I understood correctly the last posting in this thread, lotus notes should only read 5.191.647-78*65.535-822=79.095 bytes.
I can assure you that it is not what Lotus Notes does.

Does anybody experience the same issue?
Is there a known solution to it?
0
 
LVL 31

Expert Comment

by:qwaletee
ID: 21806591
Open a new question
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

You’ve got a lotus Domino web server, and you have been told that “leverage browser caching” is a must do. This means that we have to tell the browser everywhere in the web to use cache. In other words, we set (and send) an expiration date in the HT…
Lack of Storage capacity is a common problem that exists in every field of life. Here we are taking the case of Lotus Notes Emails, as we all know that we are totally depend on e-communication i.e. Emails. This article is fully dedicated to resolvin…
This video discusses moving either the default database or any database to a new volume.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now