Windows XP system can not browse Workgroup system in different subnet

Windows XP system can not browse Workgroup system in different subnet
Who is Participating?
SwassLikeMeConnect With a Mentor Commented:
This is not going to be possible to browse a workgroup on another subnet, because workgroup browsing is handled on a subnet by subnet basis, by doing network broadcasts and having a master browser.  Each subnet is allowed a master browser by elections that take place by Windows systems on your subnet.

Active directory and Windows domains take care of this problem, but the systems have to be a part of that in order for you to browse those domains.
dis1931Connect With a Mentor Commented:
Hello twuexperts,

Do you have a router setup on your network?  If you do then you can connect to another PC you just will have to use the address rather than browsing.


dis1931, that is correct.

To accomplish this, go to Start -> Run, then type in:


The will obviously have to be replaced by the IP address of the system you are trying to connect to.  If there is a restrictive firewall between you and the other PC, you may be unable to do this however.
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

oldPCguyConnect With a Mentor Commented:
Try adding the computers you want to browse to the lmhosts file on your local PC.
The lmhosts will only work if there is a route to the other subnet/network...but it will alleviate the headache of remembering any addresses as long as they know the name of the PC.  However, depending on how many PCs you have this may become slightly burdensome as you need this file on each PC.  

You probably have a XP-SP2 firewall problem.
You have to do the "scope settings"

How you do this:

Go to -- Control panel -- "network connections" -- doubleclick your "LAN" card -- select "advanced" -- then "settings" -- then "exceptions" -- find and doubleclick "file and printer sharing" -- here you will find portnumbers (137, 138, 139, 445) For each of them do the folowing:
Select one and click "change scope". Here you have default selection "My network (subnet) only". Change this to: "any computer" or "custom list" (here you have to enter all your subnets)

This should help you...

For testing if this is the problem, you can temporarily disable the firewall on all computers on your network before you do the settings on XP firewall. (than reenable it an do those settings)

For browsing your computers you should use DNS or WINS server, but if you don't have any servers, then, you should edit "hosts" file and copy it to all other computers in your network (presumed that you have fixed IP addresses on all computers).
Path for hosts file : C:\windows\system32\drivers\etc\  (hosts file is without extention so use notepad)

Without name resolution you can access other computers with entering this to explorer
"\\ip-of-other-workstation\sharename" example - \\\disk-c

I hope this helps....
Forced accept.

EE Admin
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.