Solved

How to aggregate links between Cisco 4510 and 3560

Posted on 2007-11-30
9
4,149 Views
Last Modified: 2012-08-14
I'm trying to aggregate links between all of our Cisco switches, with VLAN trunking. We have the following:

- 1 4510 Sup V, 48-port gigabit blades
- 3 3560 48-port, gigabit, PoE
- 1 3560 48-port, gigabit
- 1 3560 24-port, gigabit (for an iSCSI SAN)

All purchased in the last month or so, all running recent IOS software (3560's have identical versions)

The 4510 is a VTP server with 5 VLANs. We were originally using 802.1q, but I'd like to have more than 1 gigabit of bandwidth between the switches. (STP blocks 1 of the links)

The config below isn't working, and I'm not sure why. I've tried following a few documents on the web, and it looks like I did everything correctly (but obviously not if I can't reach the 3560 from the 4510). Any ideas?

::4510::
 
interface Port-channel3
 no ip address
 
interface GigabitEthernet3/5
 no switchport
 no ip address
 channel-group 3 mode active
 
interface GigabitEthernet3/6
 no switchport
 no ip address
 channel-group 3 mode active
 
 
 
::3560::
 
interface Port-channel1
 no switchport
 no ip address
 
interface GigabitEthernet0/23
 no switchport
 no ip address
 channel-group 1 mode active
 
interface GigabitEthernet0/24
 no switchport
 no ip address
 channel-group 1 mode active

Open in new window

0
Comment
Question by:cmsJustin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20384825
Did you have connectivity before trying to establish the etherchannel? If not, do that first.

What is the output when you issue a "show int status" and a "show ether summ"?
0
 
LVL 3

Author Comment

by:cmsJustin
ID: 20384924
Yes, I had connectivity previously. I have a 3rd cable between them also, and I issue a shutdown on that cable when I want to test connectivity on these 2. And I wait about 5 minutes to allow STP to work just in case.

Oh, I changed the port-channel on the 4510 to be 1 instead of 3, so that's why it's different in the output below.
::4510::
 
sh ether sum:
 
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)         LACP      Gi3/5(P)    Gi3/6(P)
 
sh int status:
 
Port      Status      Vlan    Duplex Speed  Type
Gi3/5     connected   routed  a-full a-1000 10/100/1000-TX
Gi3/6     connected   routed  a-full a-1000 10/100/1000-TX
 
::3560::
 
sh ether sum:
 
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)         LACP      Gi0/23(P)   Gi0/24(P)
 
sh int stat:
 
Port      Status      Vlan    Duplex Speed  Type
Gi0/23    connected   routed  a-full a-1000 10/100/1000BaseTX
Gi0/24    connected   routed  a-full a-1000 10/100/1000BaseTX

Open in new window

0
 
LVL 3

Author Comment

by:cmsJustin
ID: 20384937
Sorry I also have this at the bottom of each sh int status:
Po1 connected routed a-full a-1000

Open in new window

0
Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

 
LVL 50

Expert Comment

by:Don Johnston
ID: 20385156
There's your problem.

 no switchport
 no ip address

You've got a layer 3 link but you don't have an IP address assigned. If you want a trunk (which is what it sounds like) you need to issue the "switchport" command on the interfaces.
0
 
LVL 3

Author Comment

by:cmsJustin
ID: 20385587
I did the following and it seems to work now, thanks! But in the Cisco Network Assistant, it says that one of the links in BLK state.

My goal is to have complete connectivity and redundancy between the switches at the highest bandwidth possible, with the quickest failover time in case of bad link somewhere. I also want the 4510 to route between some of the VLANs.

Am I going down the right path with port-channel? I liked 802.1q but I could only have 1 link active at a time. What's the best way to do this?


::4510::
conf t
int range gig3/5-6
sw
 
::3560::
conf t
int range gig0/23-24
sw

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20385633
>it says that one of the links in BLK state.

A physical interface or a port channel interface?

?Am I going down the right path with port-channel?

Etherchannel will allow multiple links to carry data. As for increasing bandwidth... maybe.

?I liked 802.1q but I could only have 1 link active at a time.

Etherchannel and trunking are unrelated. You can do one with the other or not. Trunking allows multiple VLANs over a single link. Etherchannel is a way of tricking spanning-tree to not block redundant physical links between switches.

What does you topology look like?
0
 
LVL 3

Author Comment

by:cmsJustin
ID: 20386269
One of the physical interfaces. However, in the IOS, I can't find any evidence of one of them being blocked.

So I can run 802.1q over an etherchannel link? What should the total config be for the physical and port-channel interfaces?

The topology is pretty simple. The 4510 will have 2 cables each going to 4 3560s. Two of the 3560s are in the same IDF closet, and I'm debating on whether to run a loop with the 2 cables and a third cable in between, or do etherchannel to 1 of them and then daisy-chain the second . The third 3560 is in another IDF closet. The fourth will be an iSCSI SAN switch, also used for some VMware functions and redundancy.
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 20386625
>So I can run 802.1q over an etherchannel link?

Yes.

Personally, I'd have links from each 3560 to the 4510. Running a link between the 3560's wouldn't hurt if you've got the ports to spare. I wouldn't daisy-chain if I could avoid it.
int g3/1
 switchport
 switchport encap dot1q
 switchport mode trunk
 channel-group 1 mode desirable
int g3/2
 switchport
 switchport encap dot1q
 switchport mode trunk
 channel-group 1 mode desirable

Open in new window

0
 
LVL 3

Author Comment

by:cmsJustin
ID: 20396022
Thanks! Here's what I ended up doing and it's working great.
int range gig0/47-48
sw
sw trunk encapsulation dot1q
sw mode trunk
channel-group 1 mode desirable
 
int range gig3/5-6
sw
sw trunk encap dot1q
sw mode trunk
channel-group 3 mode desirable

Open in new window

0

Featured Post

Transaction Monitoring Vs. Real User Monitoring

Synthetic Transaction Monitoring Vs. Real User Monitoring: When To Use Each Approach? In this article, we will discuss two major monitoring approaches: Synthetic Transaction and Real User Monitoring.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question