Using RHEL 3 update 4. Trying to install a custom app. I get the following errors message:

How do I install the correct library to get the software installed?


Here is the error message:[root@occdev003 Desktop]# rpm -Uvh iHEAT.rpm
error: Failed dependencies:
        libstdc++.so.6(GLIBCXX_3.4) is needed by iHEAT-3.1.0-3273

When I try to install library updates I get this error:
[root@occdev003 ussmbta]# rpm -Uvh libstdc++-3.2.3-59.i386.rpm
warning: libstdc++-3.2.3-59.i386.rpm: V3 DSA signature: NOKEY, key ID 025e513b
error: Failed dependencies:
        libgcc_s.so.1(GCC_4.2.0) is needed by libstdc++-3.2.3-59
        libstdc++ = 3.2.3-20 is needed by (installed) libstdc++-devel-3.2.3-20

Need the correct libstdc++ for that app.

Thanks,
mbtalinuxuser


mbtalinux_userAsked:
Who is Participating?
 
ravenplConnect With a Mentor Commented:
The application iHEAT You trying to install is not supported under RH3. It's for RH4.
Can You upgrade?
No, then grab libstdc++ from RH4 (or centos4) and install with
rpm -i libstdc++-3.4.6-3.1.... (or similar) It should install along with version 3.2 from RH3.
0
 
amirs80Commented:
do u try yum to upgrade
0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.