Solved

Exchange stops responding until ipconfig /flushdns

Posted on 2007-11-30
12
1,211 Views
Last Modified: 2008-12-31
I have been running an Exchange 07 server for a few months now.  In the last few days, I have had repeated calls from the customer about Outlook 2003 responding with an error that the server was unavailable.  I tried a bunch of things, including repairing Outlook, creating a new profile, creating new accounts, and finally found that using ipconfig /flushdns clears the issue... temporarily it seems.  The one user having the issue has grown to 10 or so.  I have restarted a few of the services on the Exchange server as well.

On a side note, the first user, when I recreated her account, gets new mail, has old mail but only up until sept of this year and then it is completely empty until the day I recreated it.  

Anyone have any suggestions on either?
0
Comment
Question by:Telstar-Networks
  • 5
  • 3
  • 2
12 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 20386590
For the connection issue, first place to look now is the TCP Chimney issue.
http://msexchangeteam.com/archive/2007/07/18/446400.aspx

For the second issue, I would suggest looking for a PST on the user's machine.

Simon.
0
 
LVL 7

Expert Comment

by:mcse2007
ID: 20387376
check the event viewer log both in Exchange Server and also in clients to see what kind of errors been reported then you can starts troubleshooting the problem.
0
 
LVL 1

Author Comment

by:Telstar-Networks
ID: 20389706
The only errors I can find on clients are Unable to update public free/busy data, then followed by nothing, by <localpath\forusers\Outlook\outlook1.ost is not an offline file, or an object could not be found.

Exchange only has a number of errors, all the same, source is MSExchangeTransport, cat: TransportService, Event ID: 12014, Exchange couldn't find a certificate that contains the domain name smtp.mydomain.com in the personal store on the local computer.  Therefore, it is unable to offer the STARTTLS SMTP verb for any connector with a FQDN paramater of smtp.mydomain.com.  Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for every connector FQDN.

In terms of the TCP Chimney issue, shouldn't that not be working anyway, as the domain policy forces a configured Windows Firewall to be turned on anyway?

There are pst files on the users computer, but they all are either previous backups, or they are the PSTs that were in use until the Exchange server was installed, namely Sept. 07, at which point all the mail they contain ends on that day as well.
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 1

Author Comment

by:Telstar-Networks
ID: 20541830
Anyone able to contribute anything else?  This problem persists.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 20541934
This site doesn't operate like a forum. The only people that will see your comments are those that originally posted in the question. You cannot bump the question back up the list.

Have you made any of the changes from the TCP Chimney URL I provided above. Dismissing it because you have disabled the firewall via group policy isn't really a good idea. Most sites will not have the Windows firewall enabled on the Exchange server, but it is still an issue. You should at least ensure that you have the latest drivers for the NICs - Broadcom for example have recently released updated drivers.

Simon.
0
 
LVL 1

Author Comment

by:Telstar-Networks
ID: 20542078
The TCP Chimney had been disabled.  I downloaded some new drivers, but it will have to wait until the weekend as I can't afford to have downtime during business hours unless it is absolutely necessary.

Thanks.
0
 
LVL 7

Expert Comment

by:mcse2007
ID: 20546865
The Exchange server, may setup to use wrong certificate or doesn't setup to use certificate.
 
" The certificate should reflect the external FQDN name of the server.
 

RESOLUTION
 
 
1. Open "Exchange Management Shell".
 
2. Write "get-ExchangeCertificate" and press on "Enter" button.
 
3. Write down the Thumbprint of the certificate that reflect the required FQDN name of the server.
 
4. Review the current certificate that use by the Exchange server and
 
         each certificate function.
 
5. Write "Enable-ExchangeCertificate -Thumbprint 2afd26617915932ad096c48eb3b847fc7457662 -Services "SMTP"
 
       and press on 'Enter" button.
 
" The value of -Thumbprint obtained in stage 3.
 
 
6. Restart the Exchange server.

Source: http://support.microsoft.com/default.aspx?scid=kb;en-us;555855
 
0
 
LVL 1

Author Comment

by:Telstar-Networks
ID: 20554948
I'm not entirely sure what you mean when you say review the current certificate and each function.  
0
 
LVL 104

Expert Comment

by:Sembee
ID: 20556241
I saw that posting and I don't think it has anything at all to do with your issue. Certificates are part of the Exchange transport, but certainly would not be the cause of this problem.

Simon.
0
 
LVL 1

Accepted Solution

by:
Telstar-Networks earned 0 total points
ID: 23215279
Just stopped on its own eventually.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What does UTC stand for?  “Coordinated Universal Time” – Think of this as the true time on Planet Earth that never changes with the exception of minor leap seconds here and there to account for the changes in the planet's rotation.   What does th…
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
how to add IIS SMTP to handle application/Scanner relays into office 365.

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question