Solved

Cisco PIX - application network performance slow across vpn site to site tunnel

Posted on 2007-11-30
2
487 Views
Last Modified: 2011-10-03
Hello All,

          I have a client that is experiencing a really wierd issue. The client is connecting two location over a site to site VPN tunnel. Both locations are using DSL with a average speed of 1.5 mbit / 768k bandiwidth. We preformed speed tests at both locations and they sites are getting great throughput. Problem is traffic going across the tunnel is really slow. The client has an application that times out when connecting over the tunnel. People reports that applications are really slow accessing rsources across the tunnel yet they have good throughput. Is their a reason why the traffic going over the tunnel is really slow when though their DSL speeds are blazing? My configurations are below.

Main site:

PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 96utOTR.PJJoSyt2 encrypted
passwd OLwrzN2..uVF.NHM encrypted
hostname HascoPix
domain-name nt.hasco.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names        
access-list 100 permit udp any any eq isakmp
access-list 100 permit icmp any any
access-list 100 permit esp any any
access-list 100 permit tcp any host 64.x.x.x eq 3389
access-list 100 permit tcp any host 64.x.x.x eq 3389
access-list NONAT permit ip 132.147.12.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list NONAT permit ip 132.147.12.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list VPNSPLIT permit ip 132.147.12.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list POMONA permit ip 132.147.12.0 255.255.255.0 192.168.100.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 64.x.x.x 255.255.255.224
ip address inside 132.147.12.10 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNpool 172.16.1.1-172.16.1.50 mask 255.255.255.0
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 64.x.x.x 3389 132.147.12.16 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp 64.x.x.x 3389 132.147.12.17 3389 netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 64.x.x.x 1
route inside 192.168.100.0 255.255.252.0 132.147.12.11 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map VPNmap 10 ipsec-isakmp
crypto map VPNmap 10 match address POMONA
crypto map VPNmap 10 set pfs group2
crypto map VPNmap 10 set peer 71.x.x.x
crypto map VPNmap 10 set transform-set ESP-3DES-MD5
crypto map VPNmap 800 ipsec-isakmp dynamic outside_dyn_map
crypto map VPNmap interface outside
isakmp enable outside
isakmp key ******** address 71.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp keepalive 15
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup HO idle-time 1800
vpngroup Hasco address-pool VPNpool
vpngroup Hasco dns-server 132.147.12.16
vpngroup Hasco wins-server 132.147.12.16
vpngroup Hasco default-domain nt.hasco.com
vpngroup Hasco split-tunnel VPNSPLIT
vpngroup Hasco idle-time 1800
vpngroup Hasco password ********
vpngroup HASCO idle-time 1800
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
terminal width 80

Branch Site:

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 96utOTR.PJJoSyt2 encrypted
passwd OLwrzN2..uVF.NHM encrypted
hostname Pix-Pamona
domain-name nt.hasco.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit udp any any eq isakmp
access-list 100 permit icmp any any
access-list 100 permit esp any any
access-list NONAT permit ip 192.168.100.0 255.255.255.0 132.147.12.0 255.255.255.0
access-list NONAT permit ip 192.168.100.0 255.255.255.0 172.16.0.0 255.255.255.0
access-list VPNSPLIT permit ip 192.168.100.0 255.255.255.0 172.16.0.0 255.255.255.0
access-list LONGBEACH permit ip 192.168.100.0 255.255.255.0 132.147.12.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 71.x.x.x 255.255.255.0
ip address inside 192.168.100.1 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNpool 172.16.0.1-172.16.0.50 mask 255.255.255.0
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 71.x.x.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.100.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map VPNmap 10 ipsec-isakmp
crypto map VPNmap 10 match address LONGBEACH
crypto map VPNmap 10 set pfs group2
crypto map VPNmap 10 set peer 64.x.x.x
crypto map VPNmap 10 set transform-set ESP-3DES-MD5
crypto map VPNmap 800 ipsec-isakmp dynamic outside_dyn_map
crypto map VPNmap interface outside
isakmp enable outside
isakmp key ******** address 64.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp keepalive 15
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup HOP idle-time 1800
vpngroup HascoP address-pool VPNpool
vpngroup HascoP dns-server 132.147.12.16
vpngroup HascoP wins-server 132.147.12.16
vpngroup HascoP default-domain nt.hasco.com
vpngroup HascoP split-tunnel VPNSPLIT
vpngroup HascoP idle-time 1800
vpngroup HascoP password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd address 192.168.100.10-192.168.100.137 inside
dhcpd dns 132.147.12.16
dhcpd wins 132.147.12.16
dhcpd lease 604800
dhcpd ping_timeout 750
dhcpd domain nt-hasco.com
dhcpd enable inside
terminal width 80
0
Comment
Question by:greenbeanx81
2 Comments
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 20386130
   Nothing looks wrong. What are the time values of pings in miliseconds? May this application be copying/executing a file/module on the remote site from local site? Have seen people whose application is installed in x site and running the executable from y site by browsing the x site. This cause application to load to memory, which means the copying  5-6 MB< from remote site. Of course this takes some time and this time can be a timeout value for a software which is actually designed for LAN use.

Regards
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 20387977
sounds like a MTU issue on the DSL lines where the PIX is sending full sized encrypted packets and they are getting fragmented. DSL typically carries an extra 8 byte overhead for PPPoE.

This command on both PIX's might help

sysopt connection tcpmss 1300

There are other options for PIX 7.x and IOS, but not many choices for PIX 6.3
Here's a good reference paper on the subject:
http://www.cisco.com/warp/public/471/fragmentation.pdf

0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
TL-R470T+ and Cisco ASA 2 21
Auto-launch VPN via Wifi 7 49
VPN Server config in Modem 5 23
Cisco IOS upgrade c3560_backup and deletion of drwx 7 8
OpenVPN is a great open source VPN server that is capable of providing quick and easy VPN access to your network on the cheap.  By default the software is configured to allow open access to your network.  But what if you want to restrict users to on…
If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question