Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cisco 2851 configuration for a single T1 on a dual port WIC - config review

Posted on 2007-12-01
12
2,684 Views
Last Modified: 2008-02-01
Noob on Cisco routers.  I have a new Cisco 2851 router with dual port WIC in slot 0.  This is for a single T1 internet connection.  Verizon tech did the config for the router.  I'm not able to access the internet and have pull the config.  I don't see the WAN ip configured on the serial interface... i think that is the problem.  Below is the config of the router:  Does the config look right?  Am I correct in that the WAN ip is needed on serial interface to route outbound traffic to Verizon?  If so, what and how to make changes to make this work?

hostname u123456
no service udp-small-servers
no service tcp-small-servers
!
ip subnet-zero
ip routing
no ip http server
!
enable-password ******
!
controller T1 0/0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
 
interface GigabitEthernet0/0
ip address 65.215.x.x 255.255.255.248
duplex auto
speed auto
!
interface Serial 0/0/0:0
description to UUNET u123456
no ip address
no ip redirects
no ip proxy-arp
encapsulation frame-relay IETF
no ip mroute-cache
no fair-queue
frame-relay lmi-type ansi
!
interface Serial 0/0/0:0.1 point-to-point
ip unnumbered GigabitEthernet0/0
no arp frame-relay
frame-relay interface-dlci 500 IETF
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0:0.1
!
ip domain-name ALTER.NET
ip name-server 198.6.100.38
!
line con 0
login
password ******
transport preferred none
!
line aux 0
login
password ******
modem InOut
transport preferred none
transport input all
transport output all
stopbits 1
rxspeed 9600
txspeed 9600
flowcontrol hardware
!
line vty 0 4
login
password ******
transport preferred none

Open in new window

0
Comment
Question by:99YammieR1
  • 6
  • 6
12 Comments
 
LVL 14

Expert Comment

by:bfason
ID: 20389002
config on the router looks ok depending on what you are using for internal Ip addresses. Do you have another device doing Nat?
0
 

Author Comment

by:99YammieR1
ID: 20389040
bfason, i have a pix firewall sitting behind the router that does nat.  i don't need nat on the router.  why isn't the wan ip i got from the isp not configured on the serial interface?
0
 
LVL 14

Accepted Solution

by:
bfason earned 500 total points
ID: 20389048
The sub-interface of S0/0/0.1 is the one communicating with your provider. The command "Ip unnumbered G0/0" tells it use the ip address of the gigabit interface. This saves internet routable IP addresses. So your pix's outside interface will need an address in the same subnet as the g0/0 interface on router.

Hope this helps
B
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Author Comment

by:99YammieR1
ID: 20389100
bfason, definitely helps.  after talking to the verizon tech, i did get the cpe wan ip from him.  this ip is on a 255.255.255.252 subnet and is not part of the block of lan ip i got.  the g0/0 lan ip is not the same scheme as the wan serial ip.  if i replace "ip unnumbered g0/0" with ip x.x.x.x 255.255.255.252 (the router wan ip i got from verizon) for s0/0/0.1 then it'll be able to talk to the isp side.
0
 
LVL 14

Expert Comment

by:bfason
ID: 20389106
Great, let us know how it works out for you.
0
 

Author Comment

by:99YammieR1
ID: 20391455
I changed the ip on serial0/0/0:0.1 from "ip unnumbered g0/0" to "ip x.x.x.x 255.255.255.252" but still no go.  I can see the lan side of the router.
0
 
LVL 14

Expert Comment

by:bfason
ID: 20393513
From the router can you ping the isp gateway?

Another thing is the gateway of last resort. I would change it from ip route 0.0.0.0 0.0.0.0 s0/0/0.1 to ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
0
 

Author Comment

by:99YammieR1
ID: 20393600
no i cannot ping the isp gateway (the router wan ip i've assigned to s0/0/0.1)
0
 
LVL 14

Expert Comment

by:bfason
ID: 20393694
Is the gateway address and the given S0/0/0.1 address in the same subnet?

When you do a "show ip int brief" is s0/0/0.1 up and up?

If so do a "show frame pvc" and see if the pvc is active.
0
 

Author Comment

by:99YammieR1
ID: 20393743
Verizon address and CPE address are on the same subnet, 255.255.255.252.

GigabitEthernet0/0         65.215.53.xxx   YES NVRAM  up                    up

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

Serial0/0/0:0              unassigned      YES NVRAM  up                    down

Serial0/0/0:0.1            63.111.121.xxx  YES NVRAM  down    

0
 
LVL 14

Assisted Solution

by:bfason
bfason earned 500 total points
ID: 20395169
Looks like your frame circuit isn't up.

Do a show frame lmi and look for Num status enq sent and recieved to determine if LMI is up.
0
 

Author Comment

by:99YammieR1
ID: 20396710
yep, circuit wasn't up.  it's resolved now.  thanks for all your help.  greatly appreicate it.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

766 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question