Solved

ip helper-address passing DHCP to server but not back?

Posted on 2007-12-01
2
1,676 Views
Last Modified: 2008-04-23
I have two 3750 switches in a stack configuration. The Gig Switch is the data vlan, the 100 mbps switch is voice. DHCP on the voice VLAN through a server on the LAN VLAN is non-functional. Requests are getting to the DC but not getting back. I can see the leases in the DHCP control panel but phones/PCs get nothing on the voice VLAN. The DC can ping the voice subnet. If I remove the helper command, clients on the voice VLAN ports get a LAN IP. I've pasted the config below. Any thoughts?
!
version 12.2
no service pad
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname 10-42-1-250
!
logging buffered 32768 informational
no logging console
enable secret 5
enable password 7
!
username backup privilege 15 password 7 0
aaa new-model
aaa authentication login default group tacacs+ local
aaa authentication enable default group tacacs+
aaa authorization console
aaa authorization config-commands
aaa authorization exec default group tacacs+ local
aaa authorization commands 1 default group tacacs+ if-authenticated
aaa authorization commands 15 default group tacacs+ if-authenticated
!
aaa session-id common
switch 1 provision ws-c3750g-24ts-1u
switch 2 provision ws-c3750-24p
system mtu routing 1500
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree extend system-id
spanning-tree vlan 1 priority 16384
spanning-tree vlan 2 priority 24576
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/1
 description Uplink to ASA
 spanning-tree portfast disable
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
 description Voice Equipment
 switchport access vlan 2
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface FastEthernet2/0/1
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/2
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/3
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/4
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/5
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/6
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/7
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/8
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/9
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/10
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/11
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/12
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/13
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/14
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/15
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/16
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/17
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/18
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/19
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/20
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/21
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/22
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/23
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/0/24
 switchport access vlan 2
 speed 100
 duplex full
!
interface GigabitEthernet2/0/1
!
interface GigabitEthernet2/0/2
!
interface Vlan1
 ip address 10.42.1.250 255.255.255.0
!
interface Vlan2
 ip address 10.42.5.250 255.255.255.0
 ip helper-address 10.42.1.10
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.42.1.254
no ip http server
!
tacacs-server host xxxxxxxxx
tacacs-server host xxxxxxxxxxxxxx
tacacs-server directed-request
tacacs-server key 7
radius-server source-ports 1645-1646
!
control-plane
!
!
line con 0
 password 7 0
line vty 0 3
 password 7 1
line vty 4
 password 7 0
line vty 5 14
 password 7 0
line vty 15
 password 7 0
!
ntp clock-period 36028772
ntp server 198.123.30.132
end
0
Comment
Question by:mrpez1
2 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20390941
So the phones are connected to the second switch (2/0/x)?
And with no ip helper-address on the VLAN2 interface, the phones get an IP address on VLAN1?

What port is the DHCP server connected to and does it have a scope for the 10.42.5.0 network?
0
 
LVL 5

Accepted Solution

by:
mrpez1 earned 0 total points
ID: 20397353
Issue resolved. I unplugged a third, uplinked switch and DHCP magically started working again. Plugging that switch back in did not kill DHCP again so I guess this is a mystery for the ages. Thanks.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
extend vlan through a layer 3 connection 31 144
Line cards, Supervisor, Control plane 7 33
DHCP scope restore question Server 2003 to 2012R2 6 57
Cisco Policy based routing 2 38
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now