Solved

iMac not connecting to wireless network

Posted on 2007-12-02
14
2,086 Views
Last Modified: 2013-11-09
I have a customer that originally had a home wireless network that was working fine with 3 PCs and 1 new iMac.  Their wireless was set up with just the default SSID of linksys and no security.  They were having some problems with the wireless reaching some areas of the house so I added a second AP to the network.  I kept the SSID the same and changed the default channel.  So now one AP is on channel 1 and the other is on channel 11 with same SSID and still no security.  All the PCs are working great with Very Good to Excellent signals in all locations.   However the iMac will now not connect to the network.  Does anyone know why?  I know next to nothing about MAC.
0
Comment
Question by:waytron
  • 8
  • 5
14 Comments
 
LVL 1

Author Comment

by:waytron
ID: 20391066
Additional Info: customer just emailed me giving me more information on the iMac.
It says two things. It can't join the network. And the server cannot be contacted on port 110.  It says the computer is not connected to the Internet.
0
 
LVL 53

Expert Comment

by:strung
ID: 20391630
Presumably only one of the AP's is acting as a DHCP server?

Does the Mac connect to the router, but not obtain an IP address by DCHP?

You could try setting the Mac to a fixed IP. Pull down the Apple Menu to System Preferences. This is the Mac equivalent of Windows Control Panels. Go to the network preferences pane and select the Airport connection. Then go to the TCP/IP tab and change it from DHCP to manual. Set the IP address to an address on the same subnet as the AP and the Router (which should have different IP's by the way). Set the subnet mask to 255.255.255.0. The router address should be the IP address of whichever router is connected directly to the internet. Use the router address for the Domain Name Server address.

0
 
LVL 1

Author Comment

by:waytron
ID: 20391721
The setup is as follows:
A master wired router which handles DHCP, 192.168.1.1
2 other routers setup as AP's, no DHCP, One on 192.168.1.253 other on 192.168.1.254
Both AP's set to same SSID
Each AP set to a different Wireless Channel
As I mentioned before all the other Wireless PC's work fine and I can roam around the entire house.
Mac Worked fine until I added the second AP

I did not know if there is some strange Mac thing, simular to I can never seem to get a Mac to work on networks that have WEP 64. Yet I change to 128 or WPA and I am fine.
0
 
LVL 53

Expert Comment

by:strung
ID: 20392108
Thanks. Does the Mac see the SSID? Does it show as being connected? What IP address is shown in the Network Control Panel?

I am trying to figure out if you are having trouble connecting wirelessly or whether the problem is that you are connecting, but are not picking up a IP from the DHCP server.

You might also check to make sure the firmware is uptodate on your router and AP's.

Are these Linksys devices?
0
 
LVL 1

Author Comment

by:waytron
ID: 20392310
I will not know until I go there tomorrow and check the settings.  The Hardwired router is a linksys, the other two (set as AP) are a linksys and a belkin.
0
 
LVL 1

Author Comment

by:waytron
ID: 20402123
Well, I went to my customers home to check out the problems.  The iMac could see and connect to the wireless network just fine but just could not get an internet conneciton.  I performed all the standard reboot everything and still no internet.  I tried to let the iMac diagnose the problem and it could not solve the problem.  I tried setting a static IP, but still no Internet.  Disabled and enabled the Airport in the Mac.  Disconnected from the network and reconnected, rebooted.  All other computers in the house had no problem, including an iBook.  I finally resolved the problem by changing the SSID name of the network. It found the new network and connected fine.
0
 
LVL 53

Expert Comment

by:strung
ID: 20402870
Weird!
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 1

Author Comment

by:waytron
ID: 20408971
Well, I am not out of the woods.  Customer called today and he shut down his iMac last night and this morning it will not connect to the internet again.  I don't know if it would shed some light on the subject but he upgraded the OS on this iMac 2 weeks ago.
0
 
LVL 5

Expert Comment

by:crashelite
ID: 20409077
it seems as if the imac is trying to connect to the old network i would try removing all the networks in the preferred network list on the imac (apple system preferences then network and then select under show airport and then you can either set it to only connect to one or connect threw a list - in the list remove all the preferred and if you want to simplify it make it only connect to the one network)
0
 
LVL 1

Author Comment

by:waytron
ID: 20410648
Hum, I will go back today and check, but he said even when he manually selects the correct network name it connects but no internet.  He also said that if he manually selects the correct network, I keeps asking for a WEP code.  NONE was assigned.
0
 
LVL 53

Expert Comment

by:strung
ID: 20411002
If he left the default SSID on his router, the Mac may be trying to connect to another network with the same SSID. Suggest he change the SSID on his router and try again. If the Mac is asking for a WEP code, then whatever it is trying to connect to has WEP enabled.
0
 
LVL 1

Author Comment

by:waytron
ID: 20413153
No, I changed the SSID yesterday from the default "linksys" to linksysSM" the iMac then connected fine. But when it rebooted this morning, same thing, connected to the network but no Internet Connection.  All 4 other computers both hard wired and wireless have no problems including an iBook.  Could it have anything to do with upgrading to the newest OS from MAC?
0
 
LVL 53

Accepted Solution

by:
strung earned 500 total points
ID: 20421514
If you are running OS X 10.5 (Leopard) this would seem to be a common problem and everyone is waiting for Apple to issue a fix. In the meantime, in the Apple Discussion Forums at:

http://discussions.apple.com/thread.jspa?messageID=6002656#6002656

BobP1776 offers the following workaround:

"I've seen this problem with several different accounts now.

I now have a procedure which appears to fix it, but I'm not sure it is the minimal procedure. Folks who try this may find they can eliminate one or more steps and still get the good result.

Symptom: Airport won't reconnect to a known network, and turning Airport off and then back on again does NOT make the connection to the known network happen.

Solution: Do the following steps in order

    *
          o Turn off Airport


    *
          o Go to System Preferences / Network. Click on the lock and authenticate with an administrator password if necessary.


    *
          o Select Airport in the column on the left.


    *
          o CLEAR the check box for "Ask to join new networks"


    *
          o Click on Advanced.


    *
          o CLEAR the check box for "Remember any network this computer has joined"


    *
          o Click on the known network in the list if it is already in there. Click on "-" to delete it from the list.


    *
          o Click OK to exit the Advanced pane. Click Apply in the main Network pane to make these changes take effect.


    *
          o Now turn on Airport. The network will not be selected of course since it is no longer "known".


    *
          o Click on the Airport indicator in the Menu Bar to open the drop down menu.


    *
          o Click on "Join Other Network". Do this EVEN IF the network you wish to join is not "closed, i.e., is already showing in the list.


    *
          o In the dialogue panel, enter the name of the network, the type of password, and the password itself. Also VERY IMPORTANT click to check the box to "Remember This Network". Connection should now be established.


    *
          o Return to the System Preferences / Network pane. Click on Advanced again and confirm that this network is once again in the list. Click on Cancel to return back to the main Network pane without making any changes.


    *
          o Click on Assist Me. Click on Diagnostics.


    *
          o Even though the early test will likely say that everything is fine, click Continue to go through the rest of the tests ANYWAY. The Airport network you are connected to should show up in the list when you are asked to choose which network to join. Click on it. If it is not in the list for some reason, select Other and type in its name.


    *
          o You should now be presented with a panel asking you to AGAIN enter the password for this network. Do so. And VERY IMPORTANT click to check the box to remember this password in the keychain.


    *
          o Diagnostics should now complete and tell you everything is fine.


At this point, your account should now reliably and automatically rejoin this network either on restart or on waking from sleep. If the system ever misses the network on restart or waking due to weak signal or some transmission timing glitch on startup, simply turning Airport off and back on again (using the indicator in the menu bar) should suffice to get you connected again. This procedure for remembering the network should work with both open (visible names) and closed (non-visible names) networks.

Presumably there is something going on in this procedure that causes the key bits of information to be saved in the right places.

It SHOULD be easier than this of course. But at least this seems to work until Apple sorts this out.

Please note that this appears to be a PER-ACCOUNT problem. I.e., you will likely need to fix this in EACH account that's having trouble remembering the network and re-connecting automatically."



0
 
LVL 1

Author Comment

by:waytron
ID: 20426719
Yes, this was Leopard.  Well, it is too late to try your fix (Strung).  I have no idea what is going on but, I seemed to have fixed the problem by replacing the AP that was closest to the iMac.  Originally I had an old Linksys Wireless router (set as an AP) and a newer Belkin Wireless Router (Set as an AP).  I replaced the older Linksys router with another Belkin unit and everything seems to be just fine now.  But it has only been a  day or two now, so maybe it will crap out again.  Thanks for all  the help and suggestions,  I will keep this question open for a little longer to make sure I have actually sloved the problem.
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

In this article we will discuss some EI Capitan Mail app issues and provide some manual process to resolve them.
For Sennheiser, comfort, quality and security are high priority areas. This paper addresses the security of Bluetooth technology and the supplementary security that Sennheiser’s Contact Center and Office (CC&O) headsets provide.  
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now