Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Help setting up Cisco 2611 as my home router.

Posted on 2007-12-02
29
Medium Priority
?
495 Views
Last Modified: 2010-04-21
I wanted to see if someone had a quick config for using this router at home.  I want to have Int E 0/0 connected to Cox Bridge that assigns addresses via DHCP.  Then have E 0/1 connected to a 1900 switch.  I want to run a DHCP server on the router and assign IP's out of E 0/1.

Later on I would like to setup 5 VLAN's and truck them with 5 1900 series switches using the router for intervlan communication.  That can come later for now I just want to make the router work with the default VLAN.

Building configuration...  vpdn-template          
 
Current configuration : 677 bytes#r, output neve
R1(config-if)#nev
! 
version 12.3onfig
  x25 
service timestamps debug datetime msecng
R1(config-if)#ip dhcpounters never 
service timestamps log datetime msecommandsstati
 
 
R1(config-if)#ip dhcp
no service password-encryption             Global XOT comman
!a
hostname R1           
! 
boot-start-marker    
 
R1(config)#
boot-end-markeronfig)#Info
   
! 
enable secret 5 $1$TC/G$4QDr7vEDPsf8bF2V1ynQ61zed command marker. Map    
  5 m
R1(config)#i
enable password XXXXXXXXXXXX
ip  Shows taca
R1(config-if
!?
no aaa new-modelnterface configu
ip subnet-zero: dchp ?
     
ip cef      
! 
! 
 ip address 192.168.0.110 255.255.255.0pe (arpa, probe, snap) or timeouttermin
 full-duplexR1(config-if
 no cdp enablee, 0 overrun, 
!i
interface Ethernet0/1           Modify bac
 no ip addressa
% Invalid in
 shutdowned at '^'
 half-duplexion
  bandwi
no ip http server
ip classless
!
!
dialer-list 1 protocol ip permit
no cdp run
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password XXXXXXXXXXXX
 login
!
!
end

Open in new window

0
Comment
Question by:Stevexpress
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 8
  • 8
29 Comments
 
LVL 4

Expert Comment

by:redcelltech
ID: 20391600
The output you posted is very rough. Can you issue a sho run and post that. Also a sho ver.
0
 
LVL 4

Expert Comment

by:redcelltech
ID: 20391605
And don't post it to the code snipet. Just paste into the body.
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391642
I'm sorry I was side tracked when I posted that.  Posting the config was pointess its new out of box.  when you power it on you get.

Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS4-M), Version 12.3(18), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Wed 15-Mar-06 14:16 by dchih
Image text-base: 0x80008098, data-base: 0x8188C8D8

cisco 2611 (MPC860) processor (revision 0x203) with 61440K/4096K bytes of memory
.
Processor board ID JAD05240FD7 (2336068139)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
2 Ethernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 4

Expert Comment

by:redcelltech
ID: 20391662
Go through the initial setup and answer the basic questions. What is your level of experience with Cisco.
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391683
Pretty low.  I understand theory and some basic commands.  I have my 1900 switches setup and trucking so maybe that helps describe my experience level.

Once I have gone through the initial setup will the router write my config changes to memory so when I power cycle it doesnt lose the configuration?
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391700
Also, how to I configure E 0/0 to accept an address VIA DHCP.... do I just bring the interface up with no ip information entered?
0
 
LVL 4

Accepted Solution

by:
redcelltech earned 1200 total points
ID: 20391740
Issue this command an E 0/0 "ip addr dhcp" This should take care of the WAN interface.

As for the LAN, check these out.
ip dhcp pool {add descriptive name}
host 192.168.0.250 255.255.255.0

!
ip dhcp pool 1
network {you network address here}
default-router {your default router here}
dns-server {your dns servers here}

Thanks,
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391790
Ok thanks I am going to give it a try.  I will post up in a little while hopefully using the cisco.

its going to have a public IP so if you wanted to login to it at some point you could.

0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 800 total points
ID: 20391807
Here's a basic config. There's a bunch more tasks that should be done, but this is a start.


config t
Hostname MyRouter
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp pool home
 network 192.168.20.0 255.255.255.0
 dns-server 4.4.4.4 (or whatever dns servers you want)
 default-router 192.168.20.1
int e0/0
 ip address dhcp
 ip nat outside
 no shut
int e0/1
 ip address 192.168.20.1 255.255.255.0
 ip nat inside
 no shut
ip nat inside source list 1 int e0/0 overload
access-list 1 permit 192.168.20.0 0.0.0.255
line vty 0 4
 no exec

Open in new window

0
 
LVL 4

Expert Comment

by:redcelltech
ID: 20391829
I was going to make him work a little, LOL. He obviously wants to learn this. But I will say Nice post Don!!
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391860
Once I have the router setup the way I want it.  Or I am going to power the router down after the inital setup what do I do to make it store the settings in I assume NVRAM?
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391882
I think I have answerd my last qustion

copy system:running-config nvram:startup-config  
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391952
no that didnt work it still says

can you tell me how to get it out of this mode.  It just keeps resetting everything after I power cycle the box.

Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS4-M), Version 12.3(18), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Wed 15-Mar-06 14:16 by dchih
Image text-base: 0x80008098, data-base: 0x8188C8D8

cisco 2611 (MPC860) processor (revision 0x203) with 61440K/4096K bytes of memory
.
Processor board ID JAD05240FD7 (2336068139)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
2 Ethernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20391955
copy running-config startup-config
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20391991
Thanks man you have been a great help.  Going to put the router into a running environment and see what happens.
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20392117
its not working copy running-config startup-config everything looks like its working how it should but if i power cylce I get

--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20392128
Do a "show version" and look at the bottom of the output (you may have to hit space to get to the bottom) and verify that the config-register is set to "0x2102". If it's not, you'll need to change it.



config t
config-reg 0x2102
end

Open in new window

0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20392133
hahah I should have known that one>  I had to do the same thing o my 2500 cisco.  

thanks for the fast response.  Going to power cylce the router again.
0
 
LVL 4

Expert Comment

by:redcelltech
ID: 20392140
wri mem is the quick way to handle it once you have moved the config register
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20392145
The config register is set directly from global config. There is no need to update NVRAM.
0
 
LVL 4

Expert Comment

by:redcelltech
ID: 20392170
I was referring to a quick was to handle copy running-config startup-config.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20392185
Cisco has been threatening to remove the "write memory" command from the IOS command set for quite some time. One day they're going to make good on that promise. For people just starting with the IOS, I recommend using "copy run start" so you won't have to unlearn a useless command.
0
 
LVL 4

Expert Comment

by:redcelltech
ID: 20392196
Didn't know that. I don't quite understand why, but alright.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20392199
Don't understand what?
0
 
LVL 2

Author Closing Comment

by:Stevexpress
ID: 31412195
Thank you both for your help router is up and running.
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20392607
I have my PC connected to the 1900 switch and the router from there.  With a run of the mill dlink I can get about 23000Kbps out of my connection.  With the new setup I am seeing about 6000  is this a limit of the router or the switch.  I know I am only connected to a 10Mbit Ethernet but I would assume it could get close to the link speed of 10Mbit not 6Mbit.  MTU size is 1500.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20392657
The 1900XL's aren't know for their performance.

That said, are you sure about 23,000kbps? That works out to 23mbps.
0
 
LVL 2

Author Comment

by:Stevexpress
ID: 20392786
100% sure.   I couldn't believe it either its COX high speed with there boost   last at night I have hit 29Mbit.  I think I pay for 15Mbit and with the booster it goes higher.   Cox high speed in Oklahoma City I believe its the fastest home internet you can get in the $50-100 range.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20392842
You might want to make sure the 1900xl port is set to full duplex.
0

Featured Post

Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question