Solved

Cisco Routing Issue

Posted on 2007-12-02
9
402 Views
Last Modified: 2008-02-01
I have Router 1 plugged into the UnWired modem. The UnWired modem assigns a global DHCP address to the fa 0/0 of Router 1.

I have a notebook and a NAS plugged into another Cisco router, Router 2, through a 1900 switch.

Router 1 is connected to Router 2 through serial interface. The private networks being used between router 1 and router 2 are 172.16.0.0 255.255.0.0

The private network being used between Router 2 and the end devices is 192.168.0.0 255.255.255.0.

I have enabled NAT on router 1, the one connected to unWired. I have also enabled RIP version 2 between the two routers.  I have used the command default information-originate on Router 1 so that the default route assigned by the DHCP on unwired gets propagated down to router 2.

Router 1, can ping any domain name on the internet. However, for some reason Router 2's traffic cannot be routed to the public internet by router 1.

When I try to do a debug ip ICMP, i get the following errors

ICMP: time exceeded (time to live) sent to 192.168.0.10 (dest was 72.14.207.99)  
ICMP: time exceeded (time to live) sent to 192.168.0.10 (dest was 72.14.207.99)

192.168.0.10 is the IP address of my notebook.

When I do a tracert from my notebook I note that Router 2 correctly sends the traffic to router 1. but some how router 1 doesnt know what to do with it although there is a default route set on it.

I am copy pasting the config files over here.

Config for Router 1.(The one connected to UnWired Modem)

Hostname UnWired
interface FastEthernet0/0
 description Connection to the UnWired Mmodem
 ip address dhcp client-id FastEthernet0/0
 ip nat outside
 duplex auto
 speed auto

interface Serial0/0
 description Connection to the Middle Router
 ip address 172.16.0.1 255.255.0.0
 ip nat inside
 no fair-queue
!

router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip nat inside source list 15 interface Serial0/0 overload
ip nat inside source list 16 interface Serial0/0 overload
ip http server
!
access-list 15 permit 192.168.0.0 0.0.0.255
access-list 16 permit 172.16.0.0 0.0.255.255

Config for Router 2. The one connecting the notebook and NAS.


Hostname Middle
interface FastEthernet0/0
 description Connection to NAS and Notebook
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
!


interface Serial0/1
 description Connection to the UnWired Router
 ip address 172.16.0.2 255.255.0.0
 clock rate 56000
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.0.0


Here are the routing tables from Router 1 and Router 2.

Router 1
 
                    Gateway of last resort is 125.63.133.1 to network 0.0.0.0

C   172.16.0.0/16 is directly connected, Serial0/0
     10.0.0.0/32 is subnetted, 1 subnets

S   10.11.1.11 [254/0] via 125.63.133.1, FastEthernet0/0
     125.0.0.0/24 is subnetted, 1 subnets

C   125.63.133.0 is directly connected, FastEthernet0/0

R   192.168.0.0/24 [120/1] via 172.16.0.2, 00:00:00, Serial0/0

S*   0.0.0.0/0 [254/0] via 125.63.133.1

Router 2
 
                    Gateway of last resort is 172.16.0.1 to network 0.0.0.0

C    172.16.0.0/16 is directly connected, Serial0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/0
R*   0.0.0.0/0 [120/1] via 172.16.0.1, 00:00:07, Serial0/1

Any idea whats wrong?

Why cant my notebook access the internet? I have set the DNS servers to the IP address of the DNS servers of UnWired.
Config for Router 1.(The one connected to UnWired Modem)
 
Hostname UnWired
interface FastEthernet0/0
 description Connection to the UnWired Mmodem
 ip address dhcp client-id FastEthernet0/0
 ip nat outside
 duplex auto
 speed auto
 
interface Serial0/0
 description Connection to the Middle Router
 ip address 172.16.0.1 255.255.0.0
 ip nat inside
 no fair-queue
!
 
router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip nat inside source list 15 interface Serial0/0 overload
ip nat inside source list 16 interface Serial0/0 overload
ip http server
!
access-list 15 permit 192.168.0.0 0.0.0.255
access-list 16 permit 172.16.0.0 0.0.255.255
 
Config for Router 2. The one connecting the notebook and NAS.
 
 
Hostname Middle
interface FastEthernet0/0
 description Connection to NAS and Notebook
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
!
 
 
interface Serial0/1
 description Connection to the UnWired Router
 ip address 172.16.0.2 255.255.0.0
 clock rate 56000
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.0.0
 
 
Here are the routing tables from Router 1 and Router 2.
 
Router 1
 
                    Gateway of last resort is 125.63.133.1 to network 0.0.0.0
 
C   172.16.0.0/16 is directly connected, Serial0/0
     10.0.0.0/32 is subnetted, 1 subnets
 
S   10.11.1.11 [254/0] via 125.63.133.1, FastEthernet0/0
     125.0.0.0/24 is subnetted, 1 subnets
 
C   125.63.133.0 is directly connected, FastEthernet0/0
 
R   192.168.0.0/24 [120/1] via 172.16.0.2, 00:00:00, Serial0/0
 
S*   0.0.0.0/0 [254/0] via 125.63.133.1
 
Router 2
 
                    Gateway of last resort is 172.16.0.1 to network 0.0.0.0
 
C    172.16.0.0/16 is directly connected, Serial0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/0
R*   0.0.0.0/0 [120/1] via 172.16.0.1, 00:00:07, Serial0/1

Open in new window

0
Comment
Question by:zorawar_bahadur
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 250 total points
ID: 20394836
You need to change the NAT statements
ip nat inside source list 15 interface Serial0/0 overload
!
access-list 15 permit 192.168.0.0 0.0.0.255
access-list 15 permit 172.16.0.0 0.0.255.255

Open in new window

0
 

Author Comment

by:zorawar_bahadur
ID: 20394868
that didnt work either.

I tried static NAT, and it worked but the speed is crap.

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20394903
This message would indicate that the packet is looping.

> ICMP: time exceeded (time to live) sent to 192.168.0.10 (dest was 72.14.207.99)

Can Router 2 get to the internet? If not, can you change the IP address for the serial link? Something like 192.168.1.0/24.

This shouldn't be necessary, but when troubleshooting...
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 

Author Comment

by:zorawar_bahadur
ID: 20394911
forget about router 2.

Even router 1's internal IP address cannot ping google.com

I tried extended ping and used the serial 0/0 as the source IP address. it didnt work.

its the issue with NATing.

static NAT worked.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20395364
Please ping from a host and then post the output (from Router1) of a "show ip nat stat" and "show ip nat trans"
0
 

Author Comment

by:zorawar_bahadur
ID: 20401049
Should I do it with the config I have posted above? or with the one I changed and made it work? I used static one to one NAT and it worked. but the speed is so crap.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20401058
Try it with PAT (overloading).
0
 

Author Comment

by:zorawar_bahadur
ID: 20401076
Ok will do that a little bit later.

in another 3 or 4 hours.

I am at office right now.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20434173
So what was the problem?
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Setting up a VPN 60 229
Bandwidth cap???? 8 99
Show IP BGP Information 10 73
Help review broadcast on systems patching directive 6 98
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question