Solved

Applications fail to open in ICA Web Client

Posted on 2007-12-02
11
668 Views
Last Modified: 2008-02-16
First off, I am completely new to Citrix. The scenario is some of the users in my office connect to one of our clients via Citrix. One of our new users installed Citrix Presentation Server Clients Version 10.150 and used the web client to connect. He is able to connect and see the applications that are allowed for the user. When selecting an application such as Word from the web client another window appears but the application never loads. There are 3 users in my office that have the same client and connect with no problem. I installed the client from Citrix's web site on my PC and I have the same problem. We are all logging in as the same user.
0
Comment
Question by:zuech
  • 4
  • 4
  • 3
11 Comments
 
LVL 6

Expert Comment

by:cottsak
ID: 20394216
Citrix can be flakey thru the browser like this.

try uninstall completely all Citrix clients then nav to the server address in IE. rather than having the web client pre-installed, follow the link from the site to install the web client. try again after install of the ActiveX component.

my idea is that the version required may be slightly different to the latest one from the Citrix site you installed. if we can ask the particular installation of Citrix server to giv u the client, u should get the required version.
0
 
LVL 11

Expert Comment

by:AdamBNYC
ID: 20400916
What window comes up? Which version of citrix are you running? is the user coming in remotley, or using citrix in the same office that the citrix server is in?
0
 
LVL 1

Author Comment

by:zuech
ID: 20401137
It is one of our clients Citrix servers so the users in my office are connecting remotely. I don't know what version they have. We are using the download from Citrix - Presentation Server Clients Version 10.150. The window that comes up is like the startup window for Windows, where it is blue with nothing else on it while it is loading except in this case it never loads.

I uninstalled the client and tried from their link from the Citrix Server and it keeps giving me CGI Timeouts on my laptop but the user I am troubleshooting this for said he downloaded it from that link and still had the same results. I tried from another PC at my house and I couldn't download it from the link. I then downloaded it from Citrix and it worked fine. So now I personally have a laptop which I can't get it to work and a PC that it does work on using the same clients.
0
 
LVL 6

Expert Comment

by:cottsak
ID: 20401202
zuech,
i can only empathise with you at this point. cirtix used to cause me no end of pain. i dont use it now. i'm sorry i dont have any more suggestions.
0
 
LVL 11

Expert Comment

by:AdamBNYC
ID: 20403976
This sounds like a citrix glitch. Have you downloaded and applied the newest hotfix roll up packs to your citrix servers?
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 1

Author Comment

by:zuech
ID: 20405615
I have some more information. The Citrix Server is Metaframe XP and it is version 1 release 2. It isn't our server so I'm not sure if they would allow us to do anything on it such as updates.

We created a new virtual PC and the only thing we installed was the Citrix client and it didn't work for that either. We are up to roughly 15 PCs that it works on and 4 that it does not. I checked out services, firewalls etc etc. and nothing seems different from the ones that work and compared to the ones that don't work.

We did also notice that even though we log in, we do not appear in the Citrix management console as connected. The users that can open up an application, only when that app opens do they appear in the console.
0
 
LVL 11

Expert Comment

by:AdamBNYC
ID: 20405944
What do you mean that it isnt your server? Are you using an ASP? If you loaded a completely new VM, and installed the citrix client, then tried to access the citrix and had the same exact issue, the problem is not client side, its server side.
0
 
LVL 6

Expert Comment

by:cottsak
ID: 20407888
"we do not appear in the Citrix management console as connected."
... i've seen that happen before. it happens sometimes when a pc re-connects to a disconnected session instead of starting a new citrix session. with citrix, sometimes there is no visible difference between joining an old session a starting a new one - this could be why u dont detect it. u should jump on the  management console and 'end' all disconnected sessions and try the affected computers again. hopefully forcing them to create new sessions might prove useful.
0
 
LVL 1

Author Comment

by:zuech
ID: 20408236
AdamBNYC - What I mean by it isn't our server is we are connecting to a client's Citrix server so they own it and allow vendors such as us to use the web client to access parts of their network. I work for an IT consulting company that writes programs, creates web sites and does networking for clients. In this case one of our programmers is trying to access their databases via citrix to create custom reports for them. For now we are using a spare laptop so he can connect but I would like to fix the issue so he can use his own laptop.

cottsak - They rebooted the server this morning to try and correct this issue and still we can't connect from certain PCs but can from others. I'm assuming citrix is sort of like RDP session and a reboot will terminate any disconnected sessions.

I will see if they will allow us to apply hotfix roll up packs as you suggest AdamBNYC. Does that typically require a reboot? I appreciate both of your help on this issue.
0
 
LVL 11

Expert Comment

by:AdamBNYC
ID: 20408538
Yes, it will require a reboot for the hotfix rollup. Im almost positive this is a server side error, Dont drive yourself too crazy trying to fix your client systems. Also Citrix XP release 2 is super old. They should be at least running release 3. I am not even sure that hotfixes are still availiable for xp.
0
 
LVL 1

Accepted Solution

by:
zuech earned 0 total points
ID: 20720695
I finally found out the issue. The issue was the smart card reader. If you disable the service it will work.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
#Citrix #POC #XenDesktop #vCenter #VMware #ESX
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now