?
Solved

Slackware + Gateway + Outlook

Posted on 2007-12-02
8
Medium Priority
?
755 Views
Last Modified: 2013-12-05
I've mail server with slackware and outlook run with no problem at all. Now i want to set this servers as gateway for my local user use this as a gateway. I've search at EE and found some solutions that gave a rc.firewall scripts as a result and work fine. I also try use that scripts and work fine, my local user can connect to internet using my mail server as a gateway.

My problem is when i run rc.firewall, i cannot send email to outside, also when i try to login to my email from IE (squirrelmail) it said IMAP server errors. 110 port bla bla bla ( sorry forgot what it said)

I also try modify the rc.firewall by adding
$ipt -A INPUT -p tcp --dport 25 -j ACCEPT
$ipt -A INPUT -p tcp --dport 110 -j ACCEPT

but also cannot solve my problem ....
please expert any idea ??
0
Comment
Question by:wlb7631
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 3

Accepted Solution

by:
drcheap earned 100 total points
ID: 20412967
You posted iptables commands to accept SMTP and POP, but none for IMAP.  That may explain why your clients see IMAP errors.

IMAP uses port 143, so maybe this will help:
$ipt -A INPUT -p tcp --dport 143 -j ACCEPT
0
 

Author Comment

by:wlb7631
ID: 20448911
Same as before.

The message could not be sent because one of the receipients was rejected by the server. The rejected email
address was 'email@email.com'. Subject 'test', Account: 'mail.domain.com', Server: 'domain.com', Protocol:
SMTP, Server Response:'550 5.7.1 <email@email.com>..Relaying denied. Proper authentication required., Port: 25,
Secure[SSL]: No, Server Error: 550, Error Number:0x800CCC79

When i try to log in to my email using ie, the error is :

Error connecting to IMAP server: domain.
110 : Connection timed out
0
 
LVL 3

Expert Comment

by:drcheap
ID: 20461645
I don't see where IMAP fits into this, other than the error that mentions IMAP for whatever reason.

The 550 5.7.1 is an SMTP code coming from the actual server, which means you are making communication with it.  That particular error is probably because you are using "email@email.com" which is not one of the domains serviced by that box, and you are not on one of the networks considered trusted by that box.  You just need to enable SMTP authentication to fix that issue.

As for the port 110 connection timeout...that is POP3, which again is not an IMAP issue.  This should not be a problem since you have the iptables rule just like you do for SMTP.  I would try to connect to the POP3 from someting on the same subnet to make sure it is actually working in the first place.
0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 
LVL 19

Assisted Solution

by:Gabriel Orozco
Gabriel Orozco earned 100 total points
ID: 20483105
This have nothing to do with firewalling, but with smtp relaying.

you need to allow your internal network to relay.
if the user trying to send an email to "mail.com" domain is also on the internet, this is not allowed, because if some spammer find your smtp server, he/she will use it to send their email and your server will be flagged as an open relay on all black lists.

so, never allow email from the internet to the internet, *unless you setup smtp-auth*¨, and you can safelty allow relay to your internal network.

how to do this? it depends on the smtp software you are using.

--
forgot to say: you need to allow forwarding also from 127.0.0.1 or your webmail will be unable to send email (this is assuming your webmail run in the same computer than your email server)

hope it is not too late ;-)
0
 
LVL 19

Expert Comment

by:Gabriel Orozco
ID: 20664742
one more question

did you added a rule to allow anything to localhost? that can cause a lot of strange problems..

add this:

$ipt -I INPUT -A lo -j ACCEPT
0
 
LVL 1

Expert Comment

by:Computer101
ID: 20953302
Forced accept.

Computer101
Community Support Moderator
0
 

Expert Comment

by:rchack
ID: 21889462
if i use CentOS, what file should i modify ??
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In order for businesses to be compliant with certain information security laws in some countries, you need to be able to prove that a user (which user it was becomes important to the business to take action against the user after an event has occurr…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question