Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2169
  • Last Modified:

Word 2003 thesaurus takes a long time to load

Hi there

When using Word and I want to bring up alternative words I press Shift-F7 (with the input text in or beside the word in question) to bring up the thesaurus.  Only thing is it takes around 10 - 15 seconds to load up.

System is WinXPPro running Office 2003 Pro both fully patched running on a new Dell D830, 2GHz with 2GB RAM - so I don't think it is old/slow hardware that is the problem.

Can't think what might be causing the delay - anyone have any ideas?

vasp
0
vasp
Asked:
vasp
  • 10
  • 3
  • 2
  • +1
2 Solutions
 
geneusCommented:
When you installed Office, did you install the Full package to install or did you accept some defaults allowing some items to Install on First use such as Proofing Tools?

Also, what are your Language defaults for both your PC and for Office?
0
 
vaspAuthor Commented:
I did a custom install which installed everything to the hard drive except Infopath and Publisher.

PC and Office language is UK.
0
 
geneusCommented:
Try Removing the Proofing Tools and then Re-Adding the Proofing tools via Add/Remove Programs (Office 2003).
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
vaspAuthor Commented:
Removed the proofing tools and readded but get the same slow thesaurus load(and dictionary for that matter...).
0
 
vaspAuthor Commented:
Could AV software be the cause?  Recently switched from eTrust to Sophos...

I watched task manager after hitting Shift-F7 - the sophos AV service (savservice.exe) eats up 45% of one of the cores on the CPU during the thesaurus delay.  This sounds like an AV issue now.

Heard of AV interfering with Office before?
0
 
geneusCommented:
I know that Office uses the Internet for some of its options when it can to get the most recent information.  I have never used Sophos but it is a possibility.  Can you Trust Applications in Sophos or in your Firewall application?
0
 
vaspAuthor Commented:
I've disabled the online content (in Word go Tools>Options>General>Service Options).  Will have a chat with Sophos and post any fix here.
0
 
vaspAuthor Commented:
Sophos haven't come back with anything useful yet - will post in the New Year if they do.
0
 
vaspAuthor Commented:
For other reasons the laptop's disk will be replaced shortly so a fresh build will be put on the laptop - I will post back here if the problem happens again.
0
 
vaspAuthor Commented:
On the fresh build the delays are smaller but are still there - it should be instantaneous.  Issue is with Sophos again.  Will post any good response.
0
 
dgage123Commented:
In my opinion, the thesaurus in Word is rather limited.
A little while back I started using:
http://thesaurus.reference.com/
and found it generated excellent results.
I don't know if you have Internet access when using Word, but this may be worth a try.

(FYI: I have no association whatsoever with the recommended website; and I am NOT a Microsoft basher. This is just a useful tool for those who prefer exhaustive thesaurus results.)
0
 
vaspAuthor Commented:
Turning off the On-access scan setting "Scan for suspicious files (HIPS)" solved the problem.
0
 
vaspAuthor Commented:
The solution was to disable the On-access scan setting "Scan for suspicious files (HIPS)", however your comments helped me along.
0
 
WilsonsITDeptCommented:
Hi,

I have the same issue and am running Sophos but the option for scanning suspicious files is turned off.  Does anyone know of any other reason why they were getting this issue?

regards

Simon
0
 
WilsonsITDeptCommented:
Just to update:

After testing on a PC that did not have Sophos Anti-Virus and the Thesaurus worked quickly.

Pushed out Sophos AV via Enterprise Manager to that terminal Thesaurus ran slowly.

Spoke with Emterprise Manager administrator in house, she then excluded c:\program files\common files\microsoft\shared\proof directory from on access scanning, pushing out setting to test pcs and this resolved the issue.

This setting was then rolled out via EM and now working fine and fast.  tested on Windows 7 with Office 2010 as well (which was running slow before change also).

regards

Si
0
 
vaspAuthor Commented:
Thanks for reporting back...  will have a look at doing that myself.

vasp
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 10
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now